Recommended Posts

When I first played the game it wasn't so slow. Now it's almost unplayable. Can not enjoy the game with it that slow. Takes me about 12 seconds just to turn 360 degrees with the camera. It's a joke for real. Nothing funny about it at all. I feel ripped off.

 

Share this post


Link to post
Share on other sites
8 hours ago, MAustinN said:

When I first played the game it wasn't so slow. Now it's almost unplayable. Can not enjoy the game with it that slow. Takes me about 12 seconds just to turn 360 degrees with the camera. It's a joke for real. Nothing funny about it at all. I feel ripped off.

 

Are u playing on xbox?

Share this post


Link to post
Share on other sites
4 minutes ago, Ken Sanderson said:

When I first played the game it wasn't so slow. Now it's almost unplayable. Can not enjoy the game with it that slow. Takes me about 12 seconds just to turn 360 degrees with the camera. It's a joke for real. Nothing funny about it at all. I feel ripped off.

 

2 minutes ago, Sir DarkDudez said:

Same here. I know it's a known issue (on Xbox) but it makes the game unplayable. I hope the next patch begins to addresses this issue on the console

 

Share this post


Link to post
Share on other sites

I'm experiencing FPS degradation on the PC too. I've got bases on all the planets, and my FPS has dropped considerably the more worlds I've visited. I've noticed that there are base & Rover tags all over the place. Including my rovers that have been, somehow, launched into space. It's rendering everything, I think, and not just what's on the world you are currently on.

Share this post


Link to post
Share on other sites
On Tuesday, January 17, 2017 at 0:12 AM, Ken Sanderson said:

Are u playing on xbox?

Yea. I think it's not as stable as the pc version.

Share this post


Link to post
Share on other sites

And I see that System Era hasn't bothered to reply to anybody that's complaining about the frame rate.  Not good customer service in all honesty.

Share this post


Link to post
Share on other sites

PLEASE DO NOT BUY EARLY ACCESS IF:

  • you do not understand what "Early Access" means
  • bugs, broken savegames, losing progress, exploits, glitches, bad performances, crashes, broken stuff, etc ... bother you
  • you complain about the above instead of giving helpful bugreports
Quote

And I see that System Era hasn't bothered to reply to anybody that's complaining about the frame rate.  Not good customer service in all honesty.

They have in fact replied, just on a difference "social media-channel". There is just to much of this "social media"-crap these days, but thats another story.

The Devs already fixed crashes and performance Problems (for example the bad performance when you had multiple trucks connected in previous versions).

Its a small Dev team. Time is very precious. Moderating a Forum takes time. Right now the best thing you can do is:

  • report your problems and wait. They WILL read it and deal with it.

The Devs are very well aware of the performance degradation over time (*will put link in here if I find the YT-video with specific time*). Artist Adam Bromell talked about this on Twitch.

Basically they focus on stability and performance right now.

 

Latest info is:

Patch with more performance improvements is on the way

https://www.twitch.tv/ses_adam/v/115401194    (@39:00, @44:00, @54:15)

PC-Steam-updates will always be faster btw. Thats because Microsoft / Xbox has some kind of validation-process to ensure quality ... I don't know the details.

Share this post


Link to post
Share on other sites
5 hours ago, Tucklis said:

And I see that System Era hasn't bothered to reply to anybody that's complaining about the frame rate.  Not good customer service in all honesty.

thats because its a known issue with the game if you have a big base and have used tethers to explore caves and such (xbox)

Share this post


Link to post
Share on other sites
4 hours ago, ragdoll said:

PLEASE DO NOT BUY EARLY ACCESS IF:

  • you do not understand what "Early Access" means
  • bugs, broken savegames, losing progress, exploits, glitches, bad performances, crashes, broken stuff, etc ... bother you
  • you complain about the above instead of giving helpful bugreports

They have in fact replied, just on a difference "social media-channel". There is just to much of this "social media"-crap these days, but thats another story.

The Devs already fixed crashes and performance Problems (for example the bad performance when you had multiple trucks connected in previous versions).

Its a small Dev team. Time is very precious. Moderating a Forum takes time. Right now the best thing you can do is:

  • report your problems and wait. They WILL read it and deal with it.

The Devs are very well aware of the performance degradation over time (*will put link in here if I find the YT-video with specific time*). Artist Adam Bromell talked about this on Twitch.

Basically they focus on stability and performance right now.

 

Latest info is:

Patch with more performance improvements is on the way

https://www.twitch.tv/ses_adam/v/115401194    (@39:00, @44:00, @54:15)

PC-Steam-updates will always be faster btw. Thats because Microsoft / Xbox has some kind of validation-process to ensure quality ... I don't know the details.

Thank you. That's what I needed to know.

Share this post


Link to post
Share on other sites

About FPS drop:

my HW is an AMD phenom II X6 1090 T 8GB ram Windows 7 64bit with Radeon 7900 series 3GB Vram.

my Son's (playing multi with him) HW AMD X8 FX-8320 12GB ram with GTX960 4GB vram

Playing on 1920*1080 and default settings with sound on (no change in FPS with nosound) on both PC

1. Playing solo with no tether used 11-12FPs average, with aprox 30element Base and 2 truck 1 rover 1 spaces ship. (with tethers FPS drops to 8-9 avg.)

2. Playing multi with the same base 6-8 FPS,  joined player has 45-60FPS

3. Joining my son's game (now he is hosting), I have 52-65FPS host running 12-15FPS with 10-20elements size base and 2 vehicle

When I'm the host my GPU runs on average 43% load with avg 50-60% CPU load on all core, it's true for the solo play as well

Joining a game GPU load same, CPU load 60-80% avg.

Hope it helps a bit.

Share this post


Link to post
Share on other sites

i have also experianced this and i found i can make it more usable but at a cost..

everytime i get low FPS i simply set my res from 1920x1080 to MINIMAL, but this does keep resetting to the highest avil for some reason , and have already put up a post about it  .

 

i hope this helps you 

Share this post


Link to post
Share on other sites
14 hours ago, Securitycop said:

i have also experianced this and i found i can make it more usable but at a cost..

everytime i get low FPS i simply set my res from 1920x1080 to MINIMAL, but this does keep resetting to the highest avil for some reason , and have already put up a post about it  .

 

i hope this helps you 

I have xbox. You can't change resolution. PC users have it made compared to xbox one when it comes to speed and stability on this game.

Share this post


Link to post
Share on other sites

man that stinks sorry man

i have also experianced this and i found i can make it more usable but at a cost..

everytime i get low FPS i simply set my res from 1920x1080 to MINIMAL, but this does keep resetting to the highest avil for some reason , and have already put up a post about it  .

 

i hope this helps you 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now