JJATH

[Merged] Game Freezes

Recommended Posts

I'm having the exact same issue.

4 crashes already

Most time I could keep playing was an hour or so... Other than that between 5 and 10 minutes.

Worst part? I lost my whole progress... Autosave feature please.

Edited by 30crlh

Share this post


Link to post
Share on other sites
14 minutes ago, SkeedR said:

I'm getting the same thing less than 5 minutes into my first game. Frustrating and dissapointing! DxDiag dump attached for hardware info.

DxDiag.txt

Astroneer version 4.12.5.0

Share this post


Link to post
Share on other sites
9 hours ago, Vorel said:

I've found a way around the freezing. Although this may be system dependent.

If you're using NVIDIA then you have to set PhysX to CPU instead of Auto / GPU.

NVIDIA Control Panel -> Set PhysX Configuration -> CPU.

That worked for me for another hour, then if froze again out of nowhere.  I'm pretty sure I was just walking around my base when it happens.  What could cause it to freeze that changing PhysX to CPU fixes (momentarily)?

Share this post


Link to post
Share on other sites

Ok, to start off with, it runs so smoothly at 60+ fps. Randomly after about 10+ minutes, the game freezes but still have the audio. Can not exit from the game at this point. Looking in task manager, it shows cpu usage and memory usage.

It is not saving any logs. I do not see a log folder where the forum admin listed for steam games. I do have a Logs folder in User/AppData/Local/Astro/Saved/Logs but there is nothing in there when I look.

2 other things I ran across:

1. Exiting to main menu, there is no option at that point to exit to desktop or out of the game.

2. I was adding terrain while on top of it to get to a floating terrain with power resources on it and fell beneath the map when my added terrain hit the floating object while i was on top of the added terrain.

DxDiag.txt

Edited by TwitchtvLordAsp

Share this post


Link to post
Share on other sites

My frame rates hit like 1 or 2 when I'm either mear my base in a vehicle and near tethers or when my vehicle connects to a tether. I know its pre alpha. I love this game. Not complaining just pointing out a bug you're probably aware of. Love the game

Share this post


Link to post
Share on other sites

The game freezes on my at random times and the only way to exit is to force close from the task manager.

There are no logs at all.

GeForce GTX750Ti

Xeon e3-1270 V2 3.5GHz

18GB RAM

 

I'm loving the game so far, and I understand it's early access but it's frustrating not being able to make any progress.

Share this post


Link to post
Share on other sites

Same as above. 2-5 minutes of gameplay and freeze. Last patch did semi resolve frames issues. frames drop at sunset and sunrise, freeze usually happens about the same time.

Share this post


Link to post
Share on other sites

Ok, so I started the game in Steam with the -NOSOUND command and haven't had it freeze up or drop frames. Sucks to not have any sound at all since it is relaxing music and the loss of the game sounds sucks too.

Share this post


Link to post
Share on other sites

have you have and more issues with the game after you removed the sound from it? also how would I do that because I would love play the game past the shuttle screen. 

Share this post


Link to post
Share on other sites

Game still freezes after a time. -nosound does improve the framerate but I am only getting 2-10 minutes of play until it hard freezes and must be closed via task manager. Updating audio device drivers seems to help a little but -nosound does the most to improve frames. CPU load and memory usage just drop to zero when it freezes, so it's not like it's having a thread waiting issue or CPU load issue. It just stops and never recovers.

 

Share this post


Link to post
Share on other sites
4 hours ago, kmacspitfire said:

That worked for me for another hour, then if froze again out of nowhere.  I'm pretty sure I was just walking around my base when it happens.  What could cause it to freeze that changing PhysX to CPU fixes (momentarily)?

The same thing happened to me, but I'm more than positive swapping PhysX to CPU fixes the terrain tool freeze. Any time I'm digging around I don't freeze, just when I move my camera quick. Also there's another bug with the camera itself. Randomly it will do a 180 when inside a vehicle.

Share this post


Link to post
Share on other sites

Guys, can you try launching the game with the "-nosound" flag? This almost completely fixed my lag. Tiny tiny stutters now, totally playable where as before it would lag horribly every time I moved even a little bit (in some areas, but not all, in some areas I could move fine without lag).

  1. Right Click the game in your Steam Library
  2. Click properties
  3. Navigate to General Tab (should be selected by default)
  4. Click "Set Launch Options..."
  5. Type in "-nosound" without quotes
  6. Click "Okay"
  7. Click "Close" on Properties Window
  8. Launch Game
  9. Profit?

Share this post


Link to post
Share on other sites
11 minutes ago, Hotrian said:

Guys, can you try launching the game with the "-nosound" flag? This almost completely fixed my lag. Tiny tiny stutters now, totally playable where as before it would lag horribly every time I moved even a little bit (in some areas, but not all, in some areas I could move fine without lag).

  1. Right Click the game in your Steam Library
  2. Click properties
  3. Navigate to General Tab (should be selected by default)
  4. Click "Set Launch Options..."
  5. Type in "-nosound" without quotes
  6. Click "Okay"
  7. Click "Close" on Properties Window
  8. Launch Game
  9. Profit?

Yes the NoSound Option worked for me very good no Lags anymore .

WRITE -nosound in steam startoptions

Thank You  

Hotrian

!

Share this post


Link to post
Share on other sites

So for me at least, it turns out this is because I use a program called Breakaway Audio Enhancer! I have no idea why, and I've never had any issues with any other game. Breakaway is using 1% CPU so it's not having any issues itself, but for some reason Astroneer does NOT want to pipe audio through Breakaway. When I close and disable Breakaway, and disable all audio devices except my Optical Out to my speakers, I can use sound again and no lag!

 

Any chance you guys are using some type of sound equalizer or processor? Try disabling all audio devices except the one you are using, and all audio equalizers if you have any such software installed.

Share this post


Link to post
Share on other sites
6 minutes ago, Hotrian said:

Any chance you guys are using some type of sound equalizer or processor? Try disabling all audio devices except the one you are using, and all audio equalizers if you have any such software installed.

 

Sadly I use no enhancement software and still have this issue. Checked all sounds.

Share this post


Link to post
Share on other sites
2 minutes ago, mortinusu said:

 

Sadly I use no enhancement software and still have this issue. Checked all sounds.

Can you also make sure all enhancements are disabled on your Playback Device? Right click your Playback Device in the Playback tab of the Sound settings window, click Properties, go to Enhancements tab if you have it, and disable all enhancements. I haven't tested these yet but I suspect they might also be causing the issue.

Share this post


Link to post
Share on other sites
Just now, Hotrian said:

Can you also make sure all enhancements are disabled on your Playback Device?

Yea that's what I meant when I said checked all sounds. No enhancements whatsoever, straight default sound.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now