SES_Adam

"117" - January 9th, 2017

Recommended Posts

Open the store app then click your login pic should bring up another window second from the top should be downloads and updated click on that then check for updates and it should find it.

Edited by TrojanSteel

Share this post


Link to post
Share on other sites

I've been playing all day on a new world on the Xbox patch and sadly I've still gotten some lag, I've heard this patch still hasn't smashed the bug that is happening to the fps and performance but I'm just tying to inform

Share this post


Link to post
Share on other sites

I really wonder the difference between XBOX and PC performance, anyone have both? 

I'm running with a i5-6500 with the integrated GPU, HD 530, I'm getting 20~30 fps in game, not the best, but good enough. 

Share this post


Link to post
Share on other sites
4 minutes ago, Sir Tubs said:

I've been playing all day on a new world on the Xbox patch and sadly I've still gotten some lag, I've heard this patch still hasn't smashed the bug that is happening to the fps and performance but I'm just tying to inform

Mind you that if I was able to tell you the lag it would probably be 40-20 fps

Share this post


Link to post
Share on other sites
10 minutes ago, Sir Tubs said:

I've been playing all day on a new world on the Xbox patch and sadly I've still gotten some lag, I've heard this patch still hasn't smashed the bug that is happening to the fps and performance but I'm just tying to inform

ive played on the xbox all day, bases on 3 planets, a truck and trailer at each base, no thethers whatsoever ( other then a few when needed but instantly picked back up and placed on my pack) and i havent experienced any performance drops yet...also i park my vehicles low underground, they seem to stay put that way every time

Share this post


Link to post
Share on other sites
12 hours ago, SES_Adam said:

patch117.png

This patch focuses on bug fixes and stability for Xbox One Game Preview, Windows 10 Game Preview, and Steam Early Access as well as build version parity between platforms.

BUILD NUMBERS:

  • Xbox & UWP: 0.2.10117.0. 
  • Steam: 0.2.117.0.

Xbox/UWP gets all fixes from Steam 111 and 115. Recapping (minus Steam only issues):

  • Allow the 2 expansion slots on backpack to use Filters, Tanks, and Tethers
  • Fix exploit allowing player to trade for infinite resources by thieving the item like a pirate while launching
  • Fix bug that would not allow a full oxygen tank to save an Astroneer from suffocating
  • Cut value of Fuel in half on Trade module
  • Double power requirement and production time of Condenser
  • Fix known physics problems when attaching things to large storage on truck
  • Fix bug allowing player to make building platforms after a conduit hub has already been branched.
  • Change the Shuttle/Spaceship conduit hub type to the same as the habitat
  • Allow Shuttle/Spaceship to reattach to previously created hubs
  • Fix algorithm that picks the height of new base platforms, so that flat terrain makes flat bases
  • Fix issue where resources hover out of backpack on loading save
  • Fix Popper hazards spawning new research items on save load
  • Fix for client Condenser exploit that would allow player to take unfilled fuel canister.  
  • Fix for research item exploit where player could save game after getting item, and reload. 
  • Fix for clients not seeing correct light and oxygen state on tethers. 
  • Fix for clients being unable to hear anything in SFX category of sounds. 
  • Don't allow player to enter vehicles while interacting/holding anything else

New in 117:

  • Fix four major crashes including one that could prevent saves from loading, and one that could occur on MP join.
  • Fix issue where some unburied discoveries would not simulate physics after reloading a save.
  • Fix very bad performance when training together many rovers or trucks.
  • Fix trade module save behavior. All existing lost trade ships in save games should return to earth (possibly after doing the wrong trade, but all new saves will work properly)
  • Bring in physics freeze distance by a bit, reducing incidence of cases where objects fall through ground. (More improvements incoming).

About time they fixed the last one. Was so annoying when everything sunk into the ground

Share this post


Link to post
Share on other sites

Thank you for bringing Xbox up to date! 

 

I feel like the fps are a bit better but I'm still in the low 10s on my save... Oh well, I'll just wait for the next one and play on PC in the meantime. By the way, is the W10 version locked to 30fps? 

Keep up the good work! The game is incredibly addictive and well designed.

Share this post


Link to post
Share on other sites

First off thanks for the update.

 

 However:

 

Trucks and items loose on the ground bouncing 50 feet in the air and in one instance launching into orbit, After restarting from a save.

Either bring back the ability to lock items in place with a save and exit.

Or put in something that can allow us to geolock items in place. Such as the small delivery shuttle (ships with 2-3 materials inside) And the large solar panels, Having them flop around in the frequent windstorms is annoying and they always loose base tether.

Because i just love being able to use the big solar panels to power my operations. see attached captures

Now panels just vibrate like mad make massive noise and if you try to bury the bent strut it bounces out of the ground and flies away.

Base connected workstations and some pedestals do not pass power when supplied only way to power them is to put a power generation item on them.

Multiplayer host can see what is researched others can not. , other players than host can not see trade station rocket after it lands to use the materials and the trade for selector for other players is not correct after moving away from the site.

5 massive solar panel array.PNG

astroneer big panel working1.PNG

Astroneer free storage1.PNG

Inspecting the solar panel installation.PNG

Share this post


Link to post
Share on other sites

I haven't fully tested this patch but is the bug where driving any land vehicle forwards then changing camera angle backwards and driving that way then the vehicle spazes out, is this fixed?

 

Share this post


Link to post
Share on other sites
52 minutes ago, TheRagerNager said:

I haven't fully tested this patch but is the bug where driving any land vehicle forwards then changing camera angle backwards and driving that way then the vehicle spazes out, is this fixed?

 

I got this game a week after its release and enjoy it very much, although this was one of the only things putting me off from playing until it was fixed as i could not travel at sometimes from this bug

Share this post


Link to post
Share on other sites
7 minutes ago, TheRagerNager said:

I got this game a week after its release and enjoy it very much, although this was one of the only things putting me off from playing until it was fixed as i could not travel at sometimes from this bug

also i have an idea for the game. can you add an item similar to the filter but is tether like where you can pass through the areas of poisonous gas but it requires power of some sort or something similar

Share this post


Link to post
Share on other sites
10 minutes ago, TheRagerNager said:

also i have an idea for the game. can you add an item similar to the filter but is tether like where you can pass through the areas of poisonous gas but it requires power of some sort or something similar

There's an ideas forum here : https://forum.systemera.net/forum/3-astroneer-feature-requests-ideas/ 

Make a post and let's see what others will say

Share this post


Link to post
Share on other sites
11 hours ago, piespace said:

Does your PC meet minimum requirements?

I still struggle with fps issues too. It makes the whole game glitchey. With the current lag still evident, the "momentum" in player and camera movement gets out of hand, not to mention using the terrain tool.....just the smallest click can have a huge effect while terraforming. What is seen on the gamescreen is the delayed reaction of the actions given. Classic lag.

 

Let's hope this gets sorted out in the next patch. If not, I'll wait a while to see what gets resolved.

ps....8 core cpu, 4gb gpu, 32gb ram and win7 64bit.

 

Well done devs, keep the momentum going (but not in the game).

Edited by nerb

Share this post


Link to post
Share on other sites
23 hours ago, SES_Adam said:

patch117.png

This patch focuses on bug fixes and stability for Xbox One Game Preview, Windows 10 Game Preview, and Steam Early Access as well as build version parity between platforms.

BUILD NUMBERS:

  • Xbox & UWP: 0.2.10117.0. 
  • Steam: 0.2.117.0.

Xbox/UWP gets all fixes from Steam 111 and 115. Recapping (minus Steam only issues):

  • Allow the 2 expansion slots on backpack to use Filters, Tanks, and Tethers
  • Fix exploit allowing player to trade for infinite resources by thieving the item like a pirate while launching
  • Fix bug that would not allow a full oxygen tank to save an Astroneer from suffocating
  • Cut value of Fuel in half on Trade module
  • Double power requirement and production time of Condenser
  • Fix known physics problems when attaching things to large storage on truck
  • Fix bug allowing player to make building platforms after a conduit hub has already been branched.
  • Change the Shuttle/Spaceship conduit hub type to the same as the habitat
  • Allow Shuttle/Spaceship to reattach to previously created hubs
  • Fix algorithm that picks the height of new base platforms, so that flat terrain makes flat bases
  • Fix issue where resources hover out of backpack on loading save
  • Fix Popper hazards spawning new research items on save load
  • Fix for client Condenser exploit that would allow player to take unfilled fuel canister.  
  • Fix for research item exploit where player could save game after getting item, and reload. 
  • Fix for clients not seeing correct light and oxygen state on tethers. 
  • Fix for clients being unable to hear anything in SFX category of sounds. 
  • Don't allow player to enter vehicles while interacting/holding anything else

New in 117:

  • Fix four major crashes including one that could prevent saves from loading, and one that could occur on MP join.
  • Fix issue where some unburied discoveries would not simulate physics after reloading a save.
  • Fix very bad performance when training together many rovers or trucks.
  • Fix trade module save behavior. All existing lost trade ships in save games should return to earth (possibly after doing the wrong trade, but all new saves will work properly)
  • Bring in physics freeze distance by a bit, reducing incidence of cases where objects fall through ground. (More improvements incoming).

that's perfect news i'm addected to this game now lol 

Share this post


Link to post
Share on other sites

I experienced the same with 117 as with 115. A few hours of game, then a reload, and game already full of strange bugs. :(

Some stones, plants, grass that I removed were back. Sometimes they were floating in the air, 'cause I lowered the ground before logging off.

I found the underground sattelite for the second time ( first time was in 115 ), and once again I can't go on with this.

FPS dropped down after something like 30mn of game.

 

Ok, Let's start a few other games, and wait for the next update :S

Share this post


Link to post
Share on other sites
19 hours ago, Pi_ said:

Concerning those of us who bought the game from the Windows Store (NOT STEAM, NOT XBOX)...

I fully understand the Windows version & the Xbox version are tied together.  And that the same update (0.2.10117.0.) applies to both platforms.

To actually get the update on PC (non-Steam PC), all we should have to do is start the game, correct?  The update should be installed automatically, correct?  Is there some other method to install the update for PC players who don't use Steam?

Because after starting my game, it still shows:  Pre Alpha Build - 0.2.10109.0

 

prehaps uninstalling and reinstalling the game. be sure to put your files in a folder aswell. you can find your save folders in /APPDATA%/Astro/Saves i believe then copy paste into a new folder before reinstalling 

Share this post


Link to post
Share on other sites

I've just applied the update on Xbox One loaded a saved game and it's pretty laggy.. is everyone's the same?

Edited by Crumpy

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.