Handbag Stevens

Can't join friend's game (both PCs): boots back to main menu

Recommended Posts

1. I launched Astroneer from Steam, my friend launched it from the icon launcher on the desktop.

2. We're friends on Steam.

3. Once both in game, my friend started their game.

4. I clicked shift-tab and clicked Join Game in the context menu next to their name.

5. The game showed the loading splash screen with the spinning loader icon at the bottom.

6. The sound cut out shortly after for a few seconds.

7. I saw an in-game sky, it was daytime but there were a few stars. It was as if I was looking upwards.

8. The camera moved backwards quickly, and possibly through my spacesuit? I saw a flash of an orange suit.

9. I was then shown the gray welcome screen, clicked the left mouse button and was back to the main menu. I also noticed that my saved games were gone, but came back after I quit and opened Astroneer again.

Share this post

Link to post
Share on other sites

I experienced this same bug last night when a few friends and I tried to load back into a game we started together a couple nights before.

I have noticed the way to see if you are able to successfully join is that your local save files will be gone on your launch menu:

- Save files on launcher after trying to join friend game = Unsuccessful Join
- No save files on launcher after trying to join friends game = Successful Join

1. Load up previous game
2. Let host land on surface.
3. Friends to to "Join Game" via Steam Friends List interface.
4. Grey loading screen 
5. Not able to join friends game, save files present


We were only able to join a multiplayer game by:

1. Creating new game NOT a previous save file
2. Waiting for host to land
3. "Join Game" via Steam Friends List 
4. Grey loading screen.
5. Save files not present on launcher

Share this post

Link to post
Share on other sites

Had this intermittently joining games myself.    Some people I can join, others I cannot, sometimes they can join my games, new or old saves, sometimes they cannot.

However, to be made clear.  I have never been able to join specific hosts and those unable to join my games, have never been able to.   I thought maybe they'd not allowed firewall access.   Nothing I've tried fixes it.

Share this post

Link to post
Share on other sites

Later on the same night I was able to join my friend's game. They were in-game, and I clicked Join Game from the Steam friends list WITHOUT ASTRONEER OPEN. That launched me into the game, and I got to the main menu and saw a planet with a blue Home indicator on it (my friend's game), and was able to launch in. This worked twice.

Share this post

Link to post
Share on other sites

I've never been able to join co-op. I always get sent to my standard screen that has my save games on it.

I've opened all Steam ports and confirmed they are open properly.

Share this post

Link to post
Share on other sites

@Handbag Stevens @thepyro.tv : What's your friends' Steam Version?  I experienced this myself and the friend was using the Stable build, and I was using Beta build.

Check the versions of your friends before or after you experience multiplayer issues.  I believe the version mismatch will cause multiplayer issues.  To be safe, use Stable unless developers ask us to use experimental builds.  Mods, is this explanation correct?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now