daeos

[Steam] Terrible Frame Rate and audio issue

Recommended Posts

Found This on the Steam Community board.  Works for me.  Give it a try!

 

Quote
Zilian iconGames.png5 minutes ago
A little test for those with lag...
For me the engine currently cannot handle any bitrates for audio above 44khz, so as a test for those who get lag constantly, right click your speaker icon on your taskbar and open up your playback devices, if you don't use any digital output disable them and then go to your default device and check the properties.

On the last tab change the bitrate from 48khz to 44khz. And try again.

For me this worked well.

 

Share this post


Link to post
Share on other sites

I've now tried both disabling all other audio devices (the GPU and DisplayPort connection primary monitor adds some), and not allowing exclusive access to the onboard audio.  I was already set to 16-bit 44.1kHz playback.  Logging in and I'm at 12 FPS.  I do note, however, that there's a terrain stitching issue right by my base. I can see through to caves below because the ground to just one side is higher than the base, but it's not stitched with the base ground correctly.  I can fix this with the terrain tool.

Share this post


Link to post
Share on other sites

Manually stitching that hole together hasn't helped the frame rate any.  Adding '-nosound' to the startup options does indeed result in no audio, but still the same 12-14 FPS after loading the save.  I do get a nice 60 FPS on the menu and loading screens.

Share this post


Link to post
Share on other sites

A fresh save is getting 50-60 FPS.  I'd have hoped with my hardware that would be a solid 60.  That was with vsync on, with it off, still only 62 FPS.  I hate to think what people on lesser hardware might be experiencing at this stage!

Share this post


Link to post
Share on other sites

I tried latest patch, current save I've been playing without sound loaded fine for about 30 seconds while I was able to get out of the pod, and then walk a way along my tether line.  Audio issues kicked in again.

Share this post


Link to post
Share on other sites

Tried the latest patch (0.2.90.0), also.  The USB audio frame-rate bug is still there,  and has the same fix as before.  I'll keep on re-testing each patch to tell you when I've nailed it.  Great job on the game, I know releasing it to the big bad internet is always a trial by fire, you guys are doing great!

Share this post


Link to post
Share on other sites

My game starts at 24fps, drops to about 20 after some time. I've tried -nosound, tried reducing the bitrate to 44khz, tried various Engine.ini and Game.ini files and none of it works.

i7-4770, 8gb ram, gtx 1070, patch 125

I guess I'll just have to wait for future patches

Share this post


Link to post
Share on other sites

Played another game and noticed the same problem - remembered that rebooting fixes that and gave it a shot. Astroneer at ~60fps is much nicer :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now