ProjectSpawn

HELP me and my friend cannot connect to each other!!!

Recommended Posts

Ok, sorry if this is the wrong format or whatever, i am VERY new to this fourm thing. 

(System specs. and platform listed below!!)

I am having a problem connecting to my buddy who lives in Canada. I however live in the states. Now the problem i am having is that whenever i try and connect to my friend, his frames drop to about 15fps and he cannot see me or my habitat flying in. On my side all i see is his habitat, everything he has built including him are nowhere to be found and i cannot leave my habitat. 

Now whenever he tries to join me, i do not ever see his little icon appear in the sky whatsoever and on his side he just gets the freezing "space loading screen thing" then his music stops and it doesnt load anymore.

We have played together in the past briefly for a couple of hours but it was very glitchy the entire time (things not making sounds, chunks of world not loading in, me not being able to pick things up i had previously dropped, etc.)

PLEASE HELP,  i've looked to the ends of google to try and resolve this issue which is why i'm posting here. Hopefully this is something that can be fixed in the next update as i would greatly enjoy playing with my friends. Thanks in advance!!

Both of us are playing on steam on PC

Candadians Friends specs:

intel i7 6700 4.0ghz

Nvidia GTX 1070 8gb

32gb ram

MSI z170m mobo

windows 10

My PC specs:

AMD FX 8350 eight-core 4.0ghz

AMD Radeon R9 200 series

16gb ram

Asus M5A97 

Windows 7

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now