Segment Pin / Branch (of Button repeater etc.) Bug


Recommended Posts

Mouse/Keyboard - Steam - Version 1.14.74.0

I was placing a delay repeater and a storage sensor when I noticed the Bug and found out what was going on exactly. I was playing with a friend on his save.

After I created a few branches with the delay repeater in a cave to activate some dynamite I wasn't able to create another branch although I had 6 left. The result was that I automatically placed the segment pin on soil. But I wasn't able to pick it up again. Every time I hovered with my mouse above the LAST pin I saw the window that usually pops up when clicking on the repeater itself (Pic1). After a few seconds everything ended in a crash of the whole game. I tried to rejoin but the game crashed again. Then my friend restarted the save and I could join again. I tried the whole thing one more time and my game crashed like 3 more times. I was able to join without reloading the save though.

Pic1:

image.png.dc3f33a429d330630f82e5e742bba92e.png

 

Later I tried to use a storage sensor. There I noticed the same Bug, but without the crashing-part. I placed the storage sensor like in the second picture and I wasn't able to pick up the last segment pin at the auto arm. It just showed me the Storage Sensor's window where I could select the cycles. Everything worked though.

Pic2:

image.png.ec782455928463ddc27263b866d6650c.png

 

We already finished the game on that save and we're just trying to achieve some of our goals like blowing up Atrox (we already have a huge hole reaching to the mushroom-level and a lot of ressourced/things are floating in the air. So its pretty full down there) or collect as many ressources as possible what might have led to these bugs, as well. But none of us ever had problems with lags or performance in general. So I got pretty suspicious when my game crashed 4 times in a row. Unfortunately I really dont know how to reproduce this bug. I hope my description gives you at least an idea of this issue.

Edited by Benana
Link to post
Share on other sites
  • 4 months later...

Good bug report, @Benana.

I may be able to shed some light, if I'm reading your bug report correctly.  You're hovering over the final pin in the sequence.  That is no longer a "segment pin."  The final pin that is connected to the a valid object or target is a "target pin."  A target pin behaves differently from a segment pin.  You can't branch, and as you noted, you get a different pop-up text.

I am very interested in your attempt to "blow up Atrox."  Always a worthy goal. a miserable moon.  Would you have a glance at my bug report?  Maybe you can shed some light on the problems I found?  I don't know if these bug reports are being read, or possibly my long bug report is just too much to deal with.  :(

https://forum.systemera.net/topic/69168-serious-bug-large-radius-explosions-cause-several-bad-behaviors-and-can-break-a-save-file-permanently

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

×   Your link has been automatically embedded.   Display as a link instead