- Steam - Multiple dedicated server issues

Recommended Posts

Several different issues while playing on self-hosted dedicated server so far:

  1. Terrain tool becomes unusable. You can open it in inventory, but you cannot enable and use it ('E' key not working). Usually happens after 2-3 flights from planet to planet, can be solved by reconnecting to server, but also, rarely, happens right after connection.
  2. Getting stuck on orbit after launching from planet. Menu to launch to another planet does not appear, only landing points on the planet clickable. Can be solved by landing and launching again (pretty bad if you use solid fuel thruster though!).
  3. Right after connecting to server some objects may load as 'invisible'. You try to walk over base or put some resource, and suddenly some item pops into existence on the spot.
  4. Exiting vehicles before full stop causes them to sometimes jump forward pretty fast instead of stopping.
  5. On rare occasions some production buildings become unusable for player (often others still can still use them normally), the use menu shows inactive buttons or does not allow to select from lists. No real reproduction steps though, seems pretty random.
  6. Soil centrifuge once or twice got stuck on outputting resources. Looked like the resource transfer animation did not finish and the item was not put on the storage, but was also already not selectable on the centrifuge itself. After several attempts of putting storage back on platform and removing it, the stuck resource suddenly became transferred.
  7. When performing planet-to-planet flight you sometimes appear to 'float' in space and after few seconds the ship catches on and you resume the flight. [just annoying]
  8. When landing on a planet it looks like first you land on just landscape, then objects are loaded and then landing animation is suddenly played again, often getting cut back to landed state. [just annoying]
  9. Printer sound often continues playing even after the object creation is over. [just annoying]
  10. Visual glitch on backpack building menu: when opening inventory holograms often look 'glitchy' like under strong wind. Toggling back and forth returns them back to normal. [just annoying]
  11. Chemical laboratory output tray animations seem detached from produced resource position. Looks like the tray position at the beginning of production is used, you end up with the produced resource culling through closed doors or not moving forward from inside when ready. [just annoying]
  12. Output to storage animations look choppy, especially noticeable on Soil centrifuge when outputting to something like Medium storage. [just annoying]
Edited by DartRaven
Link to post
Share on other sites
  • 2 weeks later...

Good post. I can repro as below:

1. Yep. This is also fixed by killing yourself somehow (oxygen deprival, fall damage, hazard, respawn at starting base) and the tool will become usable again. Usually after stuff detaches and reattaches during spaceflight.

2. Confirmed.

3. Confirmed. Usually when loading back into a game where there are a number of items surrounding the player (eg, a base)

4. Usually stop them, but yes, can confirm.

5. Cannot confirm. Trade platform is the only exception, but requires changing the trade resource to something else and back again.

6. Usually occurs when the output storage is full, but won't retransfer nuggets until a nugget on the centrifuge is manually moved.

7. Confirmed. Related to 1)

8. Confirmed, but seems to happen when loading in a large number of assets or a larger save.

9. Confirmed, but for me this has been most often the rover 'skidding' whilst someone else has driven it.

10. Confirmed, but known by SES. Happens on planets aside from Sylva.

11. Confiirmed, but only slightly forward in the Chem lab where I can see the nugget before process is complete..

12. Confirmed, but suspect this is linked to server framerate at the time. Larger saves or activity would have the server at a few FPS.


13. Extenders don't place properly in quick-extend mode whilst Player 1. Separately logged via email.

Link to post
Share on other sites

Also just yesterday caught a nasty glitch: while moving through a mountain on Sylva using large rover with Drill 3 and Paver, I suddenly got disconnected from the server. After reconnecting back again the game took about twice the time to load and eventually spawned me inside the mountain, just above the tunnel. After that it started pushing the character up, until it went above the ground and actually ended up rather high in the air. Somewhat luckily I was able to land on a slope, but still died due to lack of oxygen. The worst thing is that the rover disappered! I could not find it in the tunnel and on the surface, no idea where it ended up!

Regarding similar cases, some improvement ideas:

  1.  If the character ends the session in a shelter or a vehicle (exits the server), it is better to try and spawn it inside/on the vehicle if possible. Shelters are usually quite stable :)
  2. It seems that spawning objects and characters often does not take terrain modifications into account, this should be fixed. A good example of issue: if I place a buggy on a patch made using terrain tool, it often loads up with wheels stuck underground, as if it was initially placed on the "native" terrain and only after that manual modification were loaded.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

×   Your link has been automatically embedded.   Display as a link instead