KingPhantom

Astroneer Dedicatd Server in Steam

Recommended Posts

Hi

I cant find the "Astroneer Dedicated Server" in my Tools in Steam. I got the servers and SDKs for many other games but Astroneer is missing. Do I have to add it?

And using it in Steam means that we have to run the server on the "Gaming Machine" (I have Steam on that one) but I would prefer to use a dedicated server on my own server (next to me :D) which is running all the time.

Is ther nothing like an exe or zip to run a dedicated server on complete gaming server setups (without Steam)? Like it is possible for Rust or Minecraft.

Thx!

Share this post


Link to post
Share on other sites

The developers suggest using someone else's dedicated server (Nitrado Game Server), for which you need to pay money - monthly payment.
And all of the fact that the local cooperative has problems, then, in fact, nothing has changed with the last patch.

Share this post


Link to post
Share on other sites

I have the same problem.. Dedicated Server is not showing up in Steam Library under Tools. Maybe the dedicated server isn't released in all regions yet or rolled out to users over time? 

Share this post


Link to post
Share on other sites
29 minutes ago, Mirosya said:

The developers suggest using someone else's dedicated server (Nitrado Game Server), for which you need to pay money - monthly payment.
And all of the fact that the local cooperative has problems, then, in fact, nothing has changed with the last patch.

you should read everything. they have dedicated servers to rent hosted by a partner and there is the possibility to create your own dedicated server. but this is linked to steam... but i cant find it.

Share this post


Link to post
Share on other sites

seems to work using steamcmd.

after installing steamcmd, open steamcmd in a terminal / commandline and execute the following:

login anonymous
force_install_dir <your preferred installation directory>
app_update 728470
  

Your game will then be downloaded in the given directory. It needs to download ~1.7GB and shouldn't take long with a decent connection. Unfortunately I don't know how to actually run it yet. When I run one of the binaries it just quits without any message or logs..

Share this post


Link to post
Share on other sites

actually it seems the server just forks to the background (I can see the process running in the task manager). so probably working, but will need to do some port forwarding to actually check it

Share this post


Link to post
Share on other sites

its working fine, but only if you actually use your public IP in the server config. this is super annoying for everyone who wants to run a dedicated server at home. why you can't just use a domain instead is beyond me

Share this post


Link to post
Share on other sites

What happens if you bought the game on PC through the Microsoft Store, are you still able to host your own dedicated server?

Share this post


Link to post
Share on other sites

Hey,

my server shows up in the list and even the password is being checked correctly.
When i try to join i just get "Join failed". There is no log file at all.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, ravage said:

Hey,

my server shows up in the list and even the password is being checked correctly.
When i try to join i just get "Join failed". There is no log file at all.

Firewall problem. Recheck your setting. 

Edited by strat38

Share this post


Link to post
Share on other sites

Hello,

 

notice this little difference between nitrado and dedicated home server... 

 

serv_priv5.png

Share this post


Link to post
Share on other sites
9 hours ago, strat38 said:

Firewall problem. Recheck your setting. 

Port is open. Also tried to disable the firewall completely.

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, dominik_andreas said:

seems to work using steamcmd. 

after installing steamcmd, open steamcmd in a terminal / commandline and execute the following:


login anonymous
force_install_dir <your preferred installation directory>
app_update 728470
  

Your game will then be downloaded in the given directory. It needs to download ~1.7GB and shouldn't take long with a decent connection. Unfortunately I don't know how to actually run it yet. When I run one of the binaries it just quits without any message or logs..

download worked.

i added the port to engine.ini and i did the publicip entry in the config ini. i also added a servername and an owner to it.

i have 2 processes running:

Astro.exe

AstroServer.exe

 

nothing is working. i can't connect via dns name, publicip, internal network ip.

very strange.

 

edit: portforwarding is active. similar to minecraftserver which is working. so portforwarding should be correct.

Edited by KingPhantom

Share this post


Link to post
Share on other sites

Download with steamcmd (login as anonymous) worked. Server starting silently and stop working without any error or log files.

Share this post


Link to post
Share on other sites

Just the fact that the very first step of their own tutorial about how to set up your server doesn't work because there is nothing added to steam tools is kinda disgraceful.

Share this post


Link to post
Share on other sites

Let's wait another year, maybe something will change. Support for dedicated servers in some form, we waited - even if in such a perverted useless form.

Share this post


Link to post
Share on other sites
1 hour ago, thomasesr said:

Follow the link and open it with steam:
steam://install/728470
 

Works for me and Dedicated Server visible as Steam Tools, but non-working.  After starting, the server process appears for a while (20 seconds) and silently stops working.

Share this post


Link to post
Share on other sites

I added the port number to Engine.ini and in AstroServerSettings.ini I set the PublicIP, ServerName, and OwnerName.  I changed nothing else, clicked "Launch" from inside Steam, and I have AstroServer and AstroServer-Win64-Shipping in my task manager.  I actually came here to ask if there's an official / graceful way to have it shut down, rather than just killing the task.

Share this post


Link to post
Share on other sites
On 5/28/2020 at 10:08 AM, ravage said:

Port is open. Also tried to disable the firewall completely.

... and for others

 

Have you any kind of "internetbullshit" like kaspersky or norton ... they are knowned for screewing around.

Have you done nat redirection on your ISP router ... 

Do you have a full port range on your server-isp connection.

Have you tried to set another port ( i am using 12555 )

Delete files in  ../steamcmd\steamapps\common\ASTRONEER Dedicated Server\Astro\Saved\SaveGames

For reminder, 

 

 

steam://install/728470

if login asked, use anonymous

Set those files:

../steamcmd\steamapps\common\ASTRONEER Dedicated Server\Astro\Saved\Config\WindowsServer\AstroServerSetting.ini

 

[/Script/Astro.AstroServerSettings]
bLoadAutoSave=True
MaxServerFramerate=450.000000
MaxServerIdleFramerate=3.000000
bWaitForPlayersBeforeShutdown=False
PublicIP=YOUREXTERNALIPHERE
ServerName=WHATEVERYOUWANT
ServerGuid=AUTOGENERATED
OwnerName=YOURPLAYERIDHERE
OwnerGuid=AUTOGENERATED
PlayerActivityTimeout=SETIFYOUWANTTIMEOUT
ServerPassword=SETIFNEEDED
bDisableServerTravel=True
DenyUnlistedPlayers=False
VerbosePlayerProperties=True
AutoSaveGameInterval=900
BackupSaveGamesInterval=7200
ActiveSaveFileDescriptiveName=SAVE_1
ServerAdvertisedName=AUTOGENERATED
PlayerProperties=AUTOGENERATED

and

../steamcmd\steamapps\common\ASTRONEER Dedicated Server\Astro\Saved\Config\WindowsServer\engine.ini

 

[URL]
Port=YOURPORTNUMBERHERE

 

Dont forget to do the port mapping on your ISP box/modem/router

 

PM if you want a link to my server home-dedicated for testing

( Based in France on a 10G FTTH link, server is i7700K+32RAM )

 

Share this post


Link to post
Share on other sites

found out steam english/french is not exactly the same layout. Had to switch back and forth to be able to SEE the astroneer dedicated server stuff...

 

Also, you have to launch it with the incoming connection enable !!!

Share this post


Link to post
Share on other sites

I am waiting for some more magic recipes for launching a dedicated server - all of the above does not help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now