KingPhantom

Astroneer Dedicatd Server in Steam

Recommended Posts

I have the same problem - the process ends after about 20 seconds and there is a new folder in the folder "I have the same problem - the process ends after 20 seconds and there is a new folder in the folder "SteamApps \ common \ ASTRONEER Dedicated Server \ Astro \ Saved \ Config \ CrashReportClient \".

Share this post


Link to post
Share on other sites
On 5/28/2020 at 2:40 AM, KingPhantom said:

download worked.

i added the port to engine.ini and i did the publicip entry in the config ini. i also added a servername and an owner to it.

i have 2 processes running:

Astro.exe

AstroServer.exe

 

nothing is working. i can't connect via dns name, publicip, internal network ip.

very strange.

 

edit: portforwarding is active. similar to minecraftserver which is working. so portforwarding should be correct.

In the same boat here. I have the server binaries running just fine (Astro@450MB mem usage and AstroServer at just under 1MB). The client sees the server is up and says 0/8 players active. If I toggle the password in the setting it notices it needs a password so my port forwarding and firewall are clearly correct or it wouldn't see this much. However, when I actually try to connect the join fails. Password or no. I am connecting from my LAN, haven't tried external connections. Will give that a go.

Share this post


Link to post
Share on other sites
On 5/28/2020 at 9:39 AM, Mirosya said:

Download with steamcmd (login as anonymous) worked. Server starting silently and stop working without any error or log files.

Check to make sure your public IP is configured as your public IP. I tried it with my LAN IP and my external and internal DNS names and none of those worked.

On 5/27/2020 at 2:43 PM, ravage said:

Hey,

my server shows up in the list and even the password is being checked correctly.
When i try to join i just get "Join failed". There is no log file at all.

Yep, same boat here. Need a log at least.

Share this post


Link to post
Share on other sites
25 minutes ago, mzeb said:

Check to make sure your public IP is configured as your public IP. I tried it with my LAN IP and my external and internal DNS names and none of those worked.

Yep, same boat here. Need a log at least.

After changing IP in configuration from LAN IP to Real IP - server starting up and stay work. But client can't join to server. 

At least some progress. It is not very convenient to specify a real IP because the provider periodically changes it.

Share this post


Link to post
Share on other sites

For those that don't have a static IP:

I wrote a script that automatically updates your config with your current public ip and restarts the server when necessary while waiting for a new save game to occur: https://gist.github.com/dominikandreas/b6401392e0b5d50d322946e582e23aa6

you just need python >= 3.6 and adapt the path to your astroneer server at the bottom of the script. you can add a task in windows task scheduler to run this every 5 minutes or so or add a "while True:" loop before the "main()" call at the bottom if you'd like this to run forever instead.

you then still need to add the server manually by <IP>:<PORT> in astroneer, but at least this solves the hassle of reconfiguring the server every time the IP changes. hopefully we'll have support for domains with the next update..

 

Share this post


Link to post
Share on other sites
1 hour ago, Mirosya said:

After changing IP in configuration from LAN IP to Real IP - server starting up and stay work. But client can't join to server. 

At least some progress. It is not very convenient to specify a real IP because the provider periodically changes it.

True and true. You're at where I am. Server is up and running and can see it running in the dedicated server list but can't actually join. It errors out.

Share this post


Link to post
Share on other sites

I think the problem is that in the configuration with a separate router as an Internet gateway, the current ideology of a dedicated server will not work. My internet gateway has a real IP - my computer has a gray IP (192.168.x.x). I run a dedicated server on my computer and when I try to connect to it with a client, all packets go to a real IP - the Internet gateway does not perceive this adequately and these packets simply do not reach a dedicated server running on a gray IP (all this can be seen in Wireshark) . At the same time, a client trying to access the server from the outside (from another real IP) will most likely be able to connect to the server (I’ll check this in the evening).

Share this post


Link to post
Share on other sites

This reddit post is probably of interest to people following this thread: https://www.reddit.com/r/Astroneer/comments/grg3v9/some_info_on_self_hosted_dedicated_servers_as_of/

They point out that because you must connect to the server via public IP, if you want to reach your server from inside the same LAN where it's running, your router must support "NAT Loopback" (aka "hairpin routing") which allows LAN clients to talk to other nodes on the LAN via port-forwarding on the public IP.  My router doesn't support this so I'm stuck until they add the ability to access the server directly via LAN IP.

Share this post


Link to post
Share on other sites

Having done a little trick, I managed to connect to a local dedicated server.

On the computer with a dedicated server, add the real IP issued by the provider to your Internet gateway as the second IP address (for example, 11.12.13.14 and set the network mask to 255.255.255.0). On other computers in the same local area network, which need to connect to the server with a second IP address, we set the address from the same provider network (for example, 11.12.13.15 11.12.13.16, etc.) As a result, all computers on the local network will connect directly - without the participation of your internet gateway.

 

Share this post


Link to post
Share on other sites

This is fiendishly clever and I can't help but think that it's going to break something -- I just can't figure out what.  I'm trying it now.

Share this post


Link to post
Share on other sites

He asked his nephew to connect to the server from the external network - unsuccessfully, although traffic forwarding is configured on the Internet gateway. I will think further.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/29/2020 at 4:02 PM, Thw0rted said:

I added the port number to Engine.ini and in AstroServerSettings.ini I set the PublicIP, ServerName, and OwnerName.  I changed nothing else, clicked "Launch" from inside Steam, and I have AstroServer and AstroServer-Win64-Shipping in my task manager.  I actually came here to ask if there's an official / graceful way to have it shut down, rather than just killing the task.

this is working for me. you have to connect to the server with the IP&Port. No DNS Names are possible. It has to be the ip with the port and then its working.

you cant connect with your internal network  ip. you have to "go out into the internet, and come back via your opened por" :D

 

i was playing with a buddy connected from the internet.

Edited by KingPhantom

Share this post


Link to post
Share on other sites

I'm wrestling with this second problem.  It's called "hairpin" or "reflective" NAT, and basically it means that your router allows you to ask for your external IP using a forwarded port, and sends the packets to the server via the LAN.  It gets complicated enough that a lot of routers don't support it, and I know mine does not.  I did try assigning my external IP to the server as a second address on the interface (and same with the client using a different host number in the subnet), which let me see "0/8 connected" in-game, but I still time out trying to actually connect.  I might play with it some more today, but I also might just wait until the team gets around to releasing a version that works properly via the (regular) LAN IP.

Share this post


Link to post
Share on other sites
On 5/27/2020 at 9:12 AM, dominik_andreas said:

I have the same problem.. Dedicated Server is not showing up in Steam Library under Tools. Maybe the dedicated server isn't released in all regions yet or rolled out to users over time? 

  It shows up in Steam now, but only if you own the game in your account.  If you install the server this way you need to have two licenses (one for each Steam account) or you will never be able to join your own server since it is using your license to host the server.
  As listed elsewhere, installing the server through SteamCMD as anonymous allows you to only use one license.  It looks like they have finally added this option to the official dedicated server blog entry too!

Share this post


Link to post
Share on other sites
8 hours ago, Thw0rted said:

I'm wrestling with this second problem.  It's called "hairpin" or "reflective" NAT, and basically it means that your router allows you to ask for your external IP using a forwarded port, and sends the packets to the server via the LAN.  It gets complicated enough that a lot of routers don't support it, and I know mine does not.  I did try assigning my external IP to the server as a second address on the interface (and same with the client using a different host number in the subnet), which let me see "0/8 connected" in-game, but I still time out trying to actually connect.  I might play with it some more today, but I also might just wait until the team gets around to releasing a version that works properly via the (regular) LAN IP.

They really need to add this as a requirement to hosting your own dedicated server on the blog post (at least they've added SteamCMD as an option recently).  I am in the exact situation - I can see the server, I can even see folks from the internet connected to my server (so at least I know it is working), but there is no way for me to connect to the server to play or even administrate it.  Even to be able to see my server running I had to install a loopback network adapter and run a UDP port proxy.  Not something for the faint at heart, nice to see an alternative with "creative" public IP address hijacking - I will give that a try next.

Share this post


Link to post
Share on other sites

I played with it some more today and still time out waiting to connect.  I don't know what else I can try, so I guess I'm just waiting for it to be addressed by the team.

A fully-offline server would sure be nice to have.  I think all the trouble I've had so far has been because the server needs to phone home for some reason and register my public IP.  Why is it doing that?  Can you give us a standalone server that truly stands alone?

Share this post


Link to post
Share on other sites

Here are some guidelines and a launcher tool that might help you with your self-hosted server setup.  

https://tinyurl.com/astroneer-server-setup
https://github.com/ricky-davis/AstroLauncher/releases/latest

image.png.2e6bd949c9783bca673c6a02e9811ec7.png

 

If you're having NAT Loopback issues, there's quite a lot of information about that pinned in the #self_host_talk channel of the Astroneer Discord. https://discord.gg/Astroneer 

Share this post


Link to post
Share on other sites

Thanks Gina, I'm checking out the Discord now.  It looks like the launcher can't actually *fix* the Loopback issue, but at least it makes it easier to manage and diagnose.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now