multiple bugs with saving and ccop in Xbox game pass for PC

Recommended Posts

Okay, I have read some other posts about multiplayer problems etc. but mine somehow doesn't fall in any of those categories. I got Astroneer through the XBOX Game Pass for PC on a windows 10 machine. (With a AMD GPU I bought I got 3 Months free version.)
My friend got it with a 1 Dollar for a month Game Pass also on PC.
His game works perfectly, he can save games, he can Invite me etc. but he can not join me I'm unjoinable in his game settings.
I can't save my game. When I want to save it theres a cut off warning label appearing but it's not saying anything. Then when I exit the world, theres no save. I tried another XBOX Game Pass (made another account and bought it again!) But it did also not work (I also reinstalled Astroneer multiple times). So it's not the Game Pass but my PC that is the problem. I got it running on another PC just fine I could save and everything!
Next problem is, I can also not join my friend in COOP multiplayer. I got his name saying joinable but if I go on it and press join, nothing happens. We tried both being in a single player world etc. He can also invite me via this xbox gamebar thingy but if accept there, also nothing happens. So my game seems to be completely corrupted or something...
I am not in a Windows insider program, I looked at all the firewall settings and Astroneer got all the checks there. (There is no Astro apearing as some other people said tho) I restartet everything over and over again, reinstalled astroneer deleted all the files in that appdata/local/...../wg folder etc... It has to be a problem with my machine but I got it a week ago and I freshly installed Windows with an OEM Key... 

I don't know where to look anymore. 

Anybody got any suggestions?

Link to post
Share on other sites

I have not had this problem, but similar problem with Sea of Thieves which is also a crossplay/crossbuy game with xbox and the MS store. They problem may be with the XBOX app. Make sure you have all of you windows 10 updates applied and that your xbox app is called XBOX Console Companion. 

Try signing out of the xbox app and back into it. Sometimes the cached login causes issues when it says you are online but something isn't quite right. 

Try signing into windows 10 with your Microsoft account that you use for gamepass. You should not have to, but I've seen it fix weird issues like this. 

Hope you get it working! Good luck!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

×   Your link has been automatically embedded.   Display as a link instead