ApoNono

[Merged] Vehicle Issues

Recommended Posts

5 hours ago, BiZZ Keryear said:

Why am I only seeing: "No permission" : "Sorry, we can't show this content because you do not have permission to see it." in this quote?

Again wired forum software (and wired choice to use it).

And what is up with that I am unable to see these (video) attachments, how do I confirm the similarity to what I experienced?

i think the thread merging messed up my self-quote. i made these two videos:

https://www.youtube.com/watch?v=nufd5Dv0vmI

https://www.youtube.com/watch?v=4_tS8wesbDE

The post is currently here: http://forum.systemera.net/topic/2654-merged-bugged-truck/?do=findComment&comment=6331

Edited by rolfrudolfwolf

Share this post


Link to post
Share on other sites

i made a truk after having 3 rovers in a chain and then i had to go off for the night
when i loged on the next morning. the truck was there but not the rovers, i did't really notes until i whent mining 
in the first cave tonns of recorsas but not much els. however when i went down even more i
met an enormous cave an gees what i found... my rovers, in a cave i had never bean in

Share this post


Link to post
Share on other sites

This also happened to me but i put the crane and drill bit on the back, when i put the crane on it was fine but then i put the drill bit on and now  i have 3 tehtered trucks stuck in the air.

Share this post


Link to post
Share on other sites

I have 2 buggies in orbit (that I can see) and a truck is missing, presumed interstellar, I had a storage (holding 2 solar large solar panels and 1 large wind turbine) on the back of a truck with a large battery on the front with a 1 man seat (because I'm lonely) and I got it and it flipped over, flew into a mountain and kicked me off, It then proceeded to shoot off into a hole, and as soon as I take the battery off it stopped and stayed there. I tried the battery on again and it did the same, without the battery I drove it around and it just does wheelies and goes no where.

It was hilarious but it is annoying, Can you sort it?

Share this post


Link to post
Share on other sites

The wheels on the truck start spinning and won't stop. I dealt with this the first time by saving in the base and reloading. The second time it was the trailer that did it. I attempted to save in the cab of the truck and now that save crashes the game on load.

Share this post


Link to post
Share on other sites

Orig. Title: 

Truck Fährt nur 20 Meter und bleibt dann stehen

Nach 20 keine reaktion mehr beim Truck.

Short translation: The Truck drives for 20m and suddenly comes to a halt.

Edited by Wyvyrias
Translation added and merged topic

Share this post


Link to post
Share on other sites

I was so sad when this happened to me because I just found the big sattelite solar dish thing. 

I was trying to escavate the sattleite out but then i hear my car bashing around on something

I turn around to see my car flying around eratically just to freeze in mid air like so in the picture 

I did manage to retreive the car by building up the ground until i reached the vehicle. it was very fun falling the couple hundred feet in my car. twisting and spinning almost as eratically as when the car first took flight

 

20161219_214101.jpg

Share this post


Link to post
Share on other sites

I am not sure if this is true to the same extent in single player, but it is a huge problem in MP right now for me and my friend. Trucks are the spawn of satan when you start loading them up with large storage modules/small storage modules/equipment/research artifacts. This issue gets progressively worse as you connect trucks together. What ensues is trucks driving by themselves, flying, trying to be "Jumper", disassembling and reassembling in 11 dimensions at the speed of light. When they get to stay still they are usually either in the sky or below ground.

This seems to happen because the game is trying to simulate "weight" or "suspension" on the vehicle chassis. I.E. when i take the "weight" off, the trucks/rovers perform just fine. Put it back on one thing too many and hell ensues.

So can we please just remove the "weight" thing or whatever changes to the truck handling mechanics that happens when you add something on it's back? Things like storage modules are currently worthless if they cause more trouble than the benefits they create. Just make all the truck handling as if thought it's empty, until the code for trucks is better.

Edited by FlameRiot

Share this post


Link to post
Share on other sites

I had the exact same thing happen to me yesterday too except it was also my entire stockpile of supplies.  Game was buggy all night.  Thinking I'm going to restart as a result of it.

Share this post


Link to post
Share on other sites

My 2p

 

Built truck with large storage on top. Was working fine until I put 3 'research pods' that you find underneath the gas spewing plants, on it. Then, it started being undriveable, flipped, kicked m out, then drove off. Every time I came near, it drove off!! Most amusing, apart from some spiky, spear things killed me when I got too near :( sadface

Share this post


Link to post
Share on other sites
56 minutes ago, FlameRiot said:

This seems to happen because the game is trying to simulate "weight" or "suspension" on the vehicle chassis. I.E. when i take the "weight" off, the trucks/rovers perform just fine. Put it back on one thing too many and hell ensues.

Are you sure? When it happened to me I was thinking about collision, like if two things are trying to push each other away.
I had one truck with a vehicule storage + 1 seat and 1 solar panel. When I added one research pod a weird noise started and the truck was going sideways. Moving the research pod just changed the direction it tried to go. Adding a second one in the opposite direction made more noise and my truck going forward. I tried to have them both on the same side and it started going in circle. At one position it started going up (I just had the time to remove one pod to stop it).

The game was also quite laggy. Did it happen without the large storage? (I'm guilty of not reading all of the posts in here :s)

Share this post


Link to post
Share on other sites
12 minutes ago, Sirdec said:

Are you sure? When it happened to me I was thinking about collision, like if two things are trying to push each other away.
I had one truck with a vehicule storage + 1 seat and 1 solar panel. When I added one research pod a weird noise started and the truck was going sideways. Moving the research pod just changed the direction it tried to go. Adding a second one in the opposite direction made more noise and my truck going forward. I tried to have them both on the same side and it started going in circle. At one position it started going up (I just had the time to remove one pod to stop it).

The game was also quite laggy. Did it happen without the large storage? (I'm guilty of not reading all of the posts in here :s)

 

Astroneer is using the PhysX SDK.  There was some similar behavior in launch physics in that other game (No Man's Sky) that caused the ship to immediate launch into orbit and it had to do with a PhysX code collision problem (interaction between ship and ground.)  

I suspect the same type of thing with this this problem in Astroneer-- physX coding problem with vehicle add-ons being given too much 'weight' in the code causing collision problems between the truck and the ground.

No doubt the Wonderful Wizards of Systemera are all over it by this time :D

Share this post


Link to post
Share on other sites

I am playing on Xbox one and I have had nothing but issues with the Rover and the Truck. They worked fine for about 2 hours of gameplay and the rest of the time have crashed my game just by entering them. Once the vehicle is entered the frame rates drop tremendously and then the game crashes. every once in a while I will manage to exit the vehicle and move away from it but the frame rates are still terribly low and then it inevitably crashes within a few seconds. Since entering a vehicle saves your game I am no longer able to load my saved game because every time I do, the game crashes just as I'm loading in (most likely due to the game trying to process me being in the truck and whatever glitch is coming with that.)

 

Does anyone know of a fix or work around for this bug?

Share this post


Link to post
Share on other sites

My Rover and Truck are stuck in Space. Driving them and then I got tossed into the Air died from the fall. And the car was gone. Looked around and found the beacon then built a tower to it. 4 hours of going up and I didn't get half way.

Share this post


Link to post
Share on other sites

i cant chase the ruck everytime i try to get close it flies i little bit more away. this has happen to me 3 times in a row and everytime happends when im driving for some research capsules and a cave ddint charge in time or i crash into a rock, it begins with some glitching not letting me drive and then it flies away so high. for me its likely a collision physics problem also the vehicles are soo light that they can not even pass through a little rock without overturning the whole car  and the acceleration its not appreciate in game i recommend to put any particle light wind behind the car so it says "hey man you going  200 KmH slow or you will have problem with that rock right there" XDDD.

First image is the bug and then the second one is the car overturned because i was too fast and it overturn (yeah somehow waiting 1hour to see if the truck  drop to the ground worked somehow)

 

5e40662fb2505a4f8ed889485a01d222.jpg

edd0a241b0bad54a9e21a2e32d893bc3.jpg

Share this post


Link to post
Share on other sites

I didn't have mine glitch out and leap into the air but while trying to drive a rover up a ramp into the sky I lost control and it went over the edge.  I bailed and managed to stay on the ramp but it started to fall.  After a certain distance it stopped, I assume because for optimization it chose to stop applying physics to the vehicle because it was too far away.  For now, I enjoy having a rover in orbit.

Frozen Rover.jpg

Share this post


Link to post
Share on other sites

Observations(may have already been said):

  • Truck has issues with Storage.
  • Truck appears to have no weight when equipped with storage
  • Truck appears to have it's center of mass shifted(which it should) when equipped with storage. With a weightless truck, it can only be loaded balanced to an extent to counter the off balance.
  • Truck with storage will continue to drive, mainly the rear wheels, after exited.

Theory:

  • Truck with storage is either possessed or controlled with AI hell bent on ending its drivers life (As mine did during a sand storm)
  • Truck needs to weigh more when equipped storage but use modern science to auto calibrate the center of mass shift

There is a small chance to stop Truck with Storage if you move counter to the direction Truck wants to go.

Pondering how Truck with Storage would work if Chuck Norris was driving.

Share this post


Link to post
Share on other sites
3 hours ago, Torgado said:

Astroneer is using the PhysX SDK.  There was some similar behavior in launch physics in that other game (No Man's Sky) that caused the ship to immediate launch into orbit and it had to do with a PhysX code collision problem (interaction between ship and ground.)  

I suspect the same type of thing with this this problem in Astroneer-- physX coding problem with vehicle add-ons being given too much 'weight' in the code causing collision problems between the truck and the ground.

No doubt the Wonderful Wizards of Systemera are all over it by this time :D

Oh I see. Thanks for the explanation!

Share this post


Link to post
Share on other sites

1) - tethers disappear instead of storing in the backpack when you put them there

2) - power stacks don't actually power anything. that is extremely annoying, in fact

3) - toxic plants and those things underneath them respawn every time you restart the game. 

4) - some terrain changes cancel on the exit even though the game was saved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now