ApoNono

[Merged] Vehicle Issues

Recommended Posts

My large shuttle sporadically flipped over and landed upside down. I went and entered the enclosed 1 seat and it spazzed and flung into the sky throwing me out. Now its just stuck up there.

20180401183103_1.jpg

Share this post


Link to post
Share on other sites

My truck doesn't allow me to enter so I have to finagle with it and when I finally get in and decide to get out, it will fling itself 300 hundred feet away. I think its because my character will leave the vehicle from underneath and will glitch halfway into the ground.

Share this post


Link to post
Share on other sites
14 hours ago, ZARANOUS said:

My truck doesn't allow me to enter so I have to finagle with it and when I finally get in and decide to get out, it will fling itself 300 hundred feet away. I think its because my character will leave the vehicle from underneath and will glitch halfway into the ground.

same. tried deleting the save and uninstalling/reinstalling (fresh start)...no change, exiting the large rover invariably causes it to jettison away from the player and now it glitches the player character into the ground...was able to recover, but large rover (multiple configs tested) is glitched. It will perform as intended once you're in the vehicle, its just entry/exit that seems to be problematic. Thanks!

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry, let me try again...

Summary:
0.6.7 - Steam - Truck entry/exit glitch

Description: 
exiting the large rover invariably causes it to jettison away from the player and now it glitches the player character into the ground

Platform:
Steam

Version / Build Number: 
?

Specifications:

  • OS: Windows 10 Pro x64 | 10.0 | Build 16299
  • CPU: Intel i7 4790 3.6GHz
  • GPU: R9 290x OCII 4GB
  • RAM: Corsair 4x8GB DDR3 1600Hz 
  • Drive: Samsung 850 Evo 250GB
Edited by What

Share this post


Link to post
Share on other sites

I have a single open seat on a truck, and whenever I get out, My character's in the ground and The truck is flung  around a bit. It never ends up to far but is really annoying when I try to fix it

Share this post


Link to post
Share on other sites

мои роверы постоянно пропадают, то изчезают, то залипают и отпружинивают, нахожу я их высоко в небе, играл вчера 1 час следующие два пытался достать ровер, строил дороги в небо, очень обидно когда так получается. иногда ровер совсем не возможно найти.

Share this post


Link to post
Share on other sites

I find the large rover with a second one attached does not allow me to exit without absolutely launching the rover train many lengths away. It makes exiting the rover in difficult places impossible as the rover ends up in places which are impossible to get out of. That is the second issue with the rovers since the addition of the third set of wheels. The rovers are grossly underpowered. There are many places in every world that the rovers require dozens of minutes of gameplay trying to get them over steep hills the old four-wheeled rovers would easily climb. Spending half an hour carving a ramp out of a hill is boring and really no fun at all. I am so not impressed with the new rovers. It has taken much of the fun out of the game for me. Thankfully, the darned things have stopped floating away though. PLEASE PLEASE PLEASE give them more power!!!

Share this post


Link to post
Share on other sites
Posted (edited)

Sigh... Windows/Xbox live 0.6.5.0 on windows 10 pro.

I am going to link a short still clip I done to show my failure due to the haunting glitch of the shuttle, pod and or seat. I am exhausted at "trying" to play any more.

I have noticed that steam has received several small updates since last received one. Has this issue been addressed and or fixed? I sure hope so!

I just want to add that this is a new save after the 0.6.5.0 drop. Enjoy the still clips and maybe get a laugh. :)

Edited by £ɨɳʂʈɛɨɳ™ Cordle

Share this post


Link to post
Share on other sites
Posted (edited)

I've suddenly got the large rover exit glitch on Steam Version 0.68.

Things that glitch:

  • Large rover, open seat
  • Large rover, closed seat
  • Large rover, drilling platform

Doesn't glitch:

  • Small rover, any configuration

I've noticed that being displaced into the ground (and the rover subsequently being launched upwards as a reaction) is slightly different between the closed and open seats. With the closed seat you tend to get trapped under the vehicle. Probably as the closed seat aligns sideways as it's really meant for the shuttle vehicles.

As a separate bug I can't seem to enter the seats or drilling platform without several attempts and moving about (any vehicle.)

For the removable open seat if I take it off and put it back on the vehicle I can enter straight away.

Edited by CrouchingBadger

Share this post


Link to post
Share on other sites

Try mounting your control seats to the front of the rover instead of on top of the rover. Yes it looks funny but it does seem to stop many of the rover issues when you enter and exit.  

Share this post


Link to post
Share on other sites
On 06/04/2018 at 3:04 AM, VT_Mongo said:

Try mounting your control seats to the front of the rover instead of on top of the rover. Yes it looks funny but it does seem to stop many of the rover issues when you enter and exit.  

Confirmed: driving from the front doesn't make the large rover bounce. I suspect it's something to do with what happens when you exit (or the height above the vehicle you're exiting.)

Share this post


Link to post
Share on other sites

This is with the new large vehicles. This is just the worst example so far. I cannot exit a new vehicle without it rocketing into the air. This beauty can actually be driven. I am really enjoying the new mobile base update. But the janky vehicles need to be fixed asap. It has neen an issue from day one. 

Cheers 

5aca33cf131f0_ASTRONEERScreenshot2018_04.08-09_06_51_09.thumb.png.f8e467a3e74a151e07b2bb79272832f5.png

Share this post


Link to post
Share on other sites
Posted (edited)

It's because they made the large rover model bigger, but didn't bother to update the position you're placed in when you exit a seat mounted on top of it, so what used to clear the model, now has you intersecting it, where the physics interactions between character and vehicle launches one into the air, while ramming the other into the ground.

It's an unbelievably simple problem to fix (increasing a single value in the exit position relative to the vehicle), so I can't believe how long it's taking SES to get around to doing it.  And so what if it doing that places players further away from medium rovers too, because they haven't got around to giving them their own separate exit positions based on their size?

This should have been hotfixed in a matter of hours, not weeks.

Edited by polarity

Share this post


Link to post
Share on other sites

Win 10

Vehicle Issues I have found:

Large truck flies through the air on exit

Large truck jumps on entry

Large truck can put player in ground on exit

Large truck can burry it self for no reason at all on exit or over time when away from it

Large truck will not move unless its unhooked from all other cars/attachments then hooked back up

Large and small truck wheels stretch on initial take of for a period of time

All trucks need parking break for exit, they drift for no reoccurring reason after exit

The truck issues are the single most agitating issues affecting game play at this time. All of the other bugs at fairly insignificant compared to the frustration of the trucks. I tend to lose over all interest once I reach a point of attempting to explore and use them do to the number of very frustrating actions that the trucks, especially the large truck exhibit. I tend to put off researching, building, and using them because of the issues related to them in order to extend play time on a particular save. Playing a saved game, for me, because of the issues, after trucks are finally researched and built signals the end of time for a game I have in my saved list. I tend to gravitate to other games in my collection until a major patch occurs that affects or attempts to affect the vehicles.

 

Keep up the good work, you guys are doing really well despite our complaints and bug reports.

 

 

Share this post


Link to post
Share on other sites
23 hours ago, D Roope said:

Large and small truck wheels stretch on initial take of for a period of time

With this screenshot I show what happens to me, talking about the same topic

20180415030644_1.thumb.jpg.d270289cedfae5bb29e72f4b08e9a3b0.jpg20180415235331_1.thumb.jpg.9eb874d5f30611e7bb4c4a27cd5d2c05.jpg

Share this post


Link to post
Share on other sites

I needed to make a hole and park on it when I reach my moon base, so the vehicle does not catapult me into the air, nor does the vehicle fly off, I appear below and walk out, as if I were a mechanic, ha ja

20180415235642_1.thumb.jpg.8e4cd30814c6023030516ce2e083954e.jpg

Share this post


Link to post
Share on other sites

Hi!

When i exited my rover it flew away. Bugged in the sky and didnt fall down. Any way to retrive it?

Tried raising the ground.  Can not go that high :(

361420_screenshots_20180417183825_1.jpg

361420_screenshots_20180417182958_1.jpg

Share this post


Link to post
Share on other sites

Something happened to me that had never happened before, I got off my Rover, then my two trailers merged into one!

20180417211328_1.thumb.jpg.7dd367c6b57cb81415fd423ee302be1c.jpg

20180417211503_1.thumb.jpg.36adb7a4eadf02345e12d844f216a398.jpg

Share this post


Link to post
Share on other sites

Recently another bug occurred to me regarding the vehicles (I'm unintentionally experiencing all the possible bugs haha, I see that I'm a good alpha tester !!)

This Rover is completely in the air, and I can not move it, I tried to hit it with another Rover, I also tried to pull with a winch, there is no way to detach it from ... air ...

20180417230617_1.thumb.jpg.0ba92ca9b76fd82074a5865efbc2388e.jpg

20180417230716_1.thumb.jpg.ea6195247bced205f5b496b5f3135d89.jpg

Share this post


Link to post
Share on other sites

It has been said before in this thread. If you mount your seat to the FRONT of the large rover it will not catapult into the sky every time you get off. Spread the word until the physics are fixed

 

Share this post


Link to post
Share on other sites
21 hours ago, Thunder Melon said:

It has been said before in this thread. If you mount your seat to the FRONT of the large rover it will not catapult into the sky every time you get off. Spread the word until the physics are fixed

 

This is a new bug, the two screenshots are from the same Rover which is continuously floating, it is not the case when it flies away, because the Rover is permanently in the air and I can not get it out.

If you re-read my post, I said in the same that I tried to move it by hitting it with another Rover, I took all the ground under it, I tried to hook it with the winch and I tried to tow it, I do not know what else to do.

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/22/2018 at 2:25 AM, Danielbetu said:

This is a new bug, the two screenshots are from the same Rover which is continuously floating, it is not the case when it flies away, because the Rover is permanently in the air and I can not get it out.

If you re-read my post, I said in the same that I tried to move it by hitting it with another Rover, I took all the ground under it, I tried to hook it with the winch and I tried to tow it, I do not know what else to do.

It is no new bug but another variation of rover interaction with terrain or items issue. We ale know that rovers have a lot of issues. Until DEV's fix physics we can't help.

I would try to put more ground under and around the rover. Maybe it will stick to the ground. Personally i did not experience 90% of all issues described in forum.
My rover used to sink into ground through too thin ceiling and dropped to cave. To be more specific the small trailer was sinking and it was one trailer hooked to small rover.
It pulled whole train under ground. Fortunately oxygen was pumping to my Astroneer so i was able to dig underground and build platform to drive rover to the surface.

Every time there is a workaround but it take time. Problem is when your oxygen is running out ....

I play on Steam, version 0.6.8 on Win10 64bit.

Edited by termos22

Share this post


Link to post
Share on other sites

Greetings! 
I whent out on an expedition with my Large Rover with a single seat, Medium Wind Turbine and storage stuff etc. 
Started to dig a road leading to an unknown cave system a bit from my base, but when I decided to move the Rover into the cave I couldn't enter the seat..
Whenever I held "E" to enter the seat the character put up the "digging tool" instead, I tried to use "E" on the Rover, then on the seat etc - various combos.
Nothing worked, but I could enter the seat when I removed the seat from the rover and put it on the ground, so I was able to save the game atleast.
I relogged - Whent to the Main meny and then back, I put the seat back on the rover and was able to move it.. but then the bug came back again, after I dug up another road, to a lower section.

Yuesterday everything worked like clockwork, didnt experience any mentionable bugs.
(New character since yuesterday, because I wanted to experience the recent updates)

I hope you fix this soon, because needing to relogg everytime I wanna relocate my Rover aint fun :c ..

GLHF

Share this post


Link to post
Share on other sites

you are using Windows or Steam version. If you can't enter your rover just use key combination "left ALT + LMB" on a seat. This will allow you to enter rover in any situation.

This was mentioned many times on forum.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now