ApoNono

[Merged] Vehicle Issues

Recommended Posts

Weight distribution seems important here.

The moment you put 2 "artifacts" on one big storage plate it starts to glitch on the rover.

Haven't tried this with the truck, but I'm suspecting the same might happen although the truck is a lot sturdier than the roover.

So my conclusion is that weight distribution is key here.

 

Share this post


Link to post
Share on other sites

I left my home base to explore another section of the planet, explored a little then decided to take a break. After loading my save i returned to my home base to find that both my rovers have disappeared, also any materials i had on the ground. Also noticed that every tether i placed was now disconnected. Besides that the game isnt really too laggy and is still playable. Have had no issues with freezing.

on a side note these 2 objects also randomly appeared lol

Astro.jpg

im playing on PC windows 7, using the beta patch.

Share this post


Link to post
Share on other sites

Have you dies before those appeared? I think they might be grave stones.

Yeah sometimes stuff sinks into the ground ... you will probably find your vehicles and stuff somewhere underground in a cave

Share this post


Link to post
Share on other sites

I can report that the big storage modules (build by vehicle bay) causes the physics of the vehicles to bug out, sometimes if you attach stuff to it it might even fly away.

Clear case of phantom forces. Solution: don't calculate physics to attached stuff (may cause wired clipping, but still better that it is now)

Share this post


Link to post
Share on other sites

Happened to me with a truck on a small moon.

 

Truck, 1-seat, battery and the cargo bay at the back.

I put one of the 8 slot cargo thingies to the cargo bay and weooooooooooweh the car jumped all over the moon, flying high to like 50m.

Share this post


Link to post
Share on other sites

Not just the rover but the truck as well. TAB will not fix the problem. Just float. ESC sometimes fixes the problem but it didn't for this time. Going to lose my truck falling through the terrain.

Share this post


Link to post
Share on other sites

Someone on the ASTRONEER Discord said that pressing f12 (The default Steam screenshot button) will pull your character out of the ground, next time this happens, give that a try, and post your results here please.
Thanks.
Peliex

Share this post


Link to post
Share on other sites
  1. Playing on mouse and Keyboard
  2. on Steam
  3. What were you doing leading up to this bug? I was traveling to find items to research. i have crafted a truck and a storage platform. it is a three seater with the storage attached to the back. so the issue happens when i place i seed or container on the back of the truck. when doing this my truck glitches into the ground.
  4. Any steps that we can take to reproduce the bug on our end is appreciated. not sure about any steps not familiar with coding

Share this post


Link to post
Share on other sites

So I added storage to truck, expanding 4 of the slots to 8.

When adding certain items on the modified truck (don't seem to be fixed items)  the item seems to create a huge torque on the truck, actively trying to flip it.

So such issue when placing items on unmodified truck.

Share this post


Link to post
Share on other sites

I would like to report a bug regarding the use of trucks, especially in the transportation of strangers.

Specifically, after attacking a stranger storage truck starts to twirl in the air or run alone.

 

 Steam/mouse, keyboard

 

 

Edited by WALTER34

Share this post


Link to post
Share on other sites

Version: windows (steam)
Control: mouse and keyboard

 

I just "seen" my truck disappear, here it is sitting in my base...

20161219211939_1.jpg

I went for a stroll (on foot, truck stayed where it is) and came back a bit later (about 10 minutes realtime) and it was gone

20161219213009_1.jpg

is this something that is supposed to happen due to sandstorms or something?

(this is single player, so no chance of it being griefing)

Edited by mozair

Share this post


Link to post
Share on other sites

Tris happend to me when i try to load: 2 storage, 1 big battery and 1 big solar panel,  on a truck with 8 slot attachment.

 

Share this post


Link to post
Share on other sites

Dig unter your base :-)

I bet the rover waits at the exact spot one level deeper. 
I found a bunch of resources under my base which I lost within my base lying around. 

Share this post


Link to post
Share on other sites

There's a chance that whats happening is as the level of detail on your terrain decreases (this happens the further away you are from terrain) that the Truck fell through the world when that happened. It's a known issue that our team will be working on, for sure.

Share this post


Link to post
Share on other sites
Just now, SES_Adam said:

There's a chance that whats happening is as the level of detail on your terrain decreases (this happens the further away you are from terrain) that the Truck fell through the world when that happened. It's a known issue that our team will be working on, for sure.

Anyone tell you you look like a chimp with that picture..

Share this post


Link to post
Share on other sites

I did try to quickly look around one level below that one, but couldn't find it... but that makes a lot of sense.

will try to literally dig deeper  later haha

 

thanks for the quick replies

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now