ApoNono

[Merged] Vehicle Issues

Recommended Posts

12 hours ago, WarriorneX said:

Ok, guys. Please check if this work for you, because for me it did. When I had all the problem with my truck was when I printed a 1 seat from the printer and attached it to my truck. With that sit that I attached to it, the truck started to do a lot of nasty things whenever I installed extra stuff or added like 6 scientific unknown experiments, somehow the rear wheels were getting stuck on the ground, making the truck to start moving on its own, why ? because the game is programmed like that. So the work around for that bug, at least for me, was to create the single seat, from the vehicle pad itself. 

With the seat created after the truck from the vehicle pad, the seat is permanently attached to the truck, which means that you can't get it off. After I did that I proceeded to add a small solar panel, a small generator,  4 of the 4x4 storage and after getting ready I set on my voyage into the cave that I prepared for my truck. I came back with 16 malachite, 16 lachalazite ( the red one, which is aluminum) and 2 scientific unknown research. I didn't had any glitch or problems with my vehicle. 

So for me it worked. Make sure to check if your problem is fixed as well with creating the seat from the vehicle pad, and do not attach a single sit created from the printer or found in crashed spaceships it will be a nightmare if you do.

 

ps: for the crane I created another truck, this time, I didn't attached another seat, I just created a crane on it, then added 2 extra 4x4 storages, and I added a drill head to the crane. Attached it to my cargo truck, and OMFG the best thing ever now I use my crane to gather materials sooooo freaking fast is amazing. So I also created a new truck which is my mobile power station, with a big solar panel, big wind turbine, and a big extra battery.... is the best thing ever.

I can confirm this doesn't fix it. Jut did it to my truck, and I'm getting glitching and collision noises all the time.

The only difference between the vehicle bay seat and the printer seat, one is permanent and the other isn't. There is technically no item property difference, besides that one is removable and one isn't. I don't see how crafting it permanently vs. removable would make the difference. Try attaching another truck to your setup and towing it, you will see the issues start to become very paramount.

If you're interested in the power stuff, check my thread out here. Shameless self promotion ahoy!

 

Share this post


Link to post
Share on other sites
3 hours ago, Whitedog44 said:

If you play on steam version, you may try this :

Go to C:/users/*your_username*/AppData/Local/Astro/Saved/SaveGames/

Sometimes you can find a save file that is older than the one you're using. Try to copy/paste the most recent elsewhere ( so you can recover it later ). Then launch the game and see what happens. Never tried it myself, but I already seen that I have 2 savefiles though I've started only one ( and I delete all save files everytime there is a new release ).

Thank you. I am on stream, checking now. I'll let u know if it works. 

Share this post


Link to post
Share on other sites
3 hours ago, Whitedog44 said:

If you play on steam version, you may try this :

Go to C:/users/*your_username*/AppData/Local/Astro/Saved/SaveGames/

Sometimes you can find a save file that is older than the one you're using. Try to copy/paste the most recent elsewhere ( so you can recover it later ). Then launch the game and see what happens. Never tried it myself, but I already seen that I have 2 savefiles though I've started only one ( and I delete all save files everytime there is a new release ).

Ok, took me a while to find it, there's only three recent ones, (which I think won't work) but when I click on them, they don't work. Even when I "open with"and choose astroneer it does not allow the file to open properly.

Share this post


Link to post
Share on other sites

I don't encounter these bugs too often when playing the game single player. Maybe an occasional bug from the truck every few hours, but they easily solve themselves by getting off the truck and back on. While in multiplayer, they seem to happen every time we get into the trucks. 

Screenshot (19).png

Screenshot (21).png

Share this post


Link to post
Share on other sites
4 hours ago, StuartF said:

I can confirm this doesn't fix it. Jut did it to my truck, and I'm getting glitching and collision noises all the time.

The only difference between the vehicle bay seat and the printer seat, one is permanent and the other isn't. There is technically no item property difference, besides that one is removable and one isn't. I don't see how crafting it permanently vs. removable would make the difference. Try attaching another truck to your setup and towing it, you will see the issues start to become very paramount.

If you're interested in the power stuff, check my thread out here. Shameless self promotion ahoy!

 

Been playing for like for like 24 after after my post, with a truck attached to a truck crane, and a fully cargo truck. No problems at all. 

Share this post


Link to post
Share on other sites

PC version, windows 7 with  Astroneer version 0.2.115 

First game. No troubles with my first truck, which is a basic model that I slapped a found seat, a solar panel and 2 storage made from the printer.

Made a second truck, on which I put a crane (with drill) and a storage from the vehicle bay. Didn't realize I can't drive it from the crane seat, so it is effectively a trailer. It's a little unwieldy to trailer, but mostly behaves normally.

Made a third truck, on which I put a crane (with winch), a seat and solar panel made from the printer. As soon as I got into the seat to drive it away, it started being floaty and hard to maneuver. I cannot drive it in a straight line. I sort of sidehopped it over to my Graveyard For Failed Vehicles and left it.

(My Graveyard for Failed Vehicles currently consists of a shuttle made with a storage on top so cannot take off; a spaceship with 2 storage on top so cannot take off either. Now the new truck with crane/winch attached).

Edited by Xanthippe

Share this post


Link to post
Share on other sites
3 minutes ago, Xanthippe said:

(My Graveyard for Failed Vehicles currently consists of a shuttle made with a storage on top so cannot take off; a spaceship with 2 storage on top so cannot take off either. Now the new truck with crane/winch attached).

I fly a spaceship with 2x storage on top. I put a habitat on the storage and TAB into it.

Share this post


Link to post
Share on other sites

when i leave the planet in a shuttle and go back if there was a rover on the planet it will disaper xbox one

Edited by deathman801

Share this post


Link to post
Share on other sites
1 hour ago, deathman801 said:

when i leave the planet in a shuttle and go back if there was a rover on the planet it will disaper xbox one

I had a similar issue. I was driving my rover to base and it flipped into the center of my habitat. After I researched a plant I had brought from the rover, my rover completely disappeared. (PC, Win 10, Steam)

Share this post


Link to post
Share on other sites

I have actually found in a couple of instances where the rover actually didn't disappear, but fell through the surface to the next solid level... I have had this happen a couple of times now and my solution until this gets fixed is to make a "garage" for my trucks... it is basically just a spot on the ground that I can park at that has a hollowed out cave underneath to "catch" my falling trucks.

Share this post


Link to post
Share on other sites

I played on PC and got this problem. When I landed my Shuttle on a Vehicle bay, which on that time was having a Truck. The Shuttle literally landed on the truck And then I launched my Shuttle again to see if it could detach from the truck. But it draged the truck with in to the sky.

15826124_1197742650311915_3780702345879222684_n.jpg

Share this post


Link to post
Share on other sites

No, I told you to move the most recent file elsewhere ( for example, create a "backup" folder in savegames ), then, try to launch the game, clicking on the astroneer icon as usual.

Share this post


Link to post
Share on other sites
22 minutes ago, Bryan Chung said:

My truck decided to leave my planet and explore on it's own. :P

 

1

no when you go into orbital view the waypoints are off

Share this post


Link to post
Share on other sites
15 hours ago, ETwhisperer said:

That sucks cuz I already did. I wonder if the creators would give us chance in the newer build to have the last two, three, or five saves be there in case we wanna go back. Some peppers say that's no fun, but it would help a lot. 

 

I have fix for this haven't tested it yet so it might not work
rover prevention system.png

Share this post


Link to post
Share on other sites
9 minutes ago, dutch said:

no when you go into orbital view the waypoints are off

I did lose one truck. And that's the one that is lost.

Share this post


Link to post
Share on other sites
4 minutes ago, Bryan Chung said:

I did lose one truck. And that's the one that is lost.

I can see at least 3 waypoints in space it most likely has glitched underneath the ground
my waypoints do the exact same thing.

Share this post


Link to post
Share on other sites

After I build the spaceship but before I am able to install a seat it gets thrown around and ends up upside down detached from the vehicle bay.

I have tried flattening the ground in a wide are around the vehicle bay and used different vehicle bays at various bases all with the same result. 

There is no way to return it to the vehicle bay and with no seat installed I cannot take off and land it somewhere safe. The rover seat or hab do not allow take off or set the spaceship back on its feet.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now