ApoNono

[Merged] Vehicle Issues

1,039 posts in this topic

I had a seat on the side of my Truck. It was attached to the large storage you can put on the back.  When I walked up to the truck to enter it I was put in the seat in the storage and could drive the truck.

 

Video of bug

Share this post


Link to post
Share on other sites

Playing on Steam.

Built the Truck then put the large storage from the vehicle bay on it and tried to attach research projects which caused the truck to start glitching into the ground.

Edited by Wyvyrias
Adjusted title

Share this post


Link to post
Share on other sites

I found that still only happens with certain types of research items..  So i made a buggy with cab and had a trailer buggy with large storage rack, with that i planed to go out and harvest a bunch of research node. cuz my buggy w/ trailer in total could hold 5 research items.

The one place i found this happens is the bumby grey research items that come from trees, the other green ones from the same trees don't seem to cause this bug.

Share this post


Link to post
Share on other sites

Hello, 

I've been playing for several hours now on Steam Version. I had my first travel into space via the shuttle. Landed on the moon, picked up an unknown research item, flew back to my home planet only to find my truck and rover gone.

They were connected to my base. Truck had that large storage unit built onto the back and the three seats attachment. Rover had nothing on it at the time, but it was connected to the truck.

Love the game so far, but the my missing truck and rover are super sad face :(

DxDiag.txt

Share this post


Link to post
Share on other sites

I noticed that this seems to happen due to physics reloading. I have gone off on an adventure and come back to find my buggy is stuck halfway in the ground, then hops back up into the air when I get near it. I flew my first shuttle, had a truck and rover. The rover was parked ontop of one of my station parts, the truck was out in the open. I launched, chose a new site, landed and checked the place out, and then went home with the shuttle. My rover was almost swallowed by the ground, I could only see a single tire sticking above the terrain, held up by the base piece. However, my truck was completely gone and I have yet to find where it is and (maybe) dig it up. (vehicles seem to be recoverable, so digging might reveal it and it can jump back to the surface)

Share this post


Link to post
Share on other sites

It is also worth noting that the Truck seems to have a funky suspension, causing it to shake and make odd noises even when still. This could have worsened the sinking glitch as I had an experience with a particular cave entrance in which I went in at a bad angle, and got the truck impaled through the ceiling of the cave. It was not happy, and was shaking VERY violently.

Share this post


Link to post
Share on other sites

Happened to me also. Xbox one version.

rover appears to have glitched through the ground when reloading the base, found it about 50 meters below my base in a cave!

Share this post


Link to post
Share on other sites

PC version for me. I just tested a theory, attaching the vehicles to the base appears to lessen the chance that they'll sink into the ground. I did this before leaving for the moon and my Truck and Rover are both above-ground, safe and sound!

Share this post


Link to post
Share on other sites

So I made a Truck (had a 1-seat, habitat & 2 storage on it), which was attached to 3 rovers in a daisy-chain.  I reloaded the game since it was stuttering horribly (3-5 seconds of freezing for 2 seconds of 40 FPS) and when I loaded back in this happened.

4013df1d9c.jpg

You can see the 3 rovers attached to the...landmass, which is the truck.  I tried chasing after it, and managed to detach the rovers, along with all of the addons except the habitat.

As of writing this, the truck has disappeared into the distance, my FPS is fine, but at least I know it's space worthy.

System info:

  • Windows 10 Pro 64 bit
  • Geforce GTX 960 (4GB)
  • Intel i7-4790k 4.0GHz
  • 16GB Ram
  • Steam version
Edited by Rominiust

Share this post


Link to post
Share on other sites

As the title states, the truck has been trying to fly away for me.  This happens when, after building the vehicle storage module on the truck you try to attach further storage created by the printer.  Placing 2 makes the truck extremely unstable, attaching anything further after that will make the truck begin clipping and flying away.  This occurs regardless of whether or not you are tied to another vehicle.  Using the game with Mouse/Keyboard, Steam version of the game running on Windows 10 x64.  Untested on the rover but the two vehicles behave similarly so it may also attempt to take flight.  While humorous at first it does tend to become a bit obnoxious not being able to move properly xD.  Best way to avoid the problem i found is to just avoid placing the extra storage modules on.

Share this post


Link to post
Share on other sites

I can report that it works fine with the rover. I've attached two rovers together with a big storage unit on back rover. No clipping or jumping/flying. 

It is a pain to drive though, it gets stuck on the stones all the time. 

Edited by bj0rnis

Share this post


Link to post
Share on other sites

I have that clipping and jumping with vehicles too. some even disappear after a while.

Share this post


Link to post
Share on other sites

I have the same problem, but I found it with research. At first, I thought that the research glitches on the back of the storage on the truck. After a while, it became apparent that this happens with any big object on the back of a storage unit on the truck. What I think is happening is the trucks have an auto-balancing system or something, and when you put something that overweighs that the truck just goes full throttle until it is again balanced. I have found out that you can drive it when it is in crazy state, but you have to get in and use arrow keys and not let it over wheelie. 

Share this post


Link to post
Share on other sites

Oh and quick fix i found. Only use your front 2 storage modules on the storage piece for big things

Share this post


Link to post
Share on other sites
22 minutes ago, Redferrari1225 said:

Oh and quick fix i found. Only use your front 2 storage modules on the storage piece for big things

I actually tried that and it did not help me. I guess you thought about weight distribution? :-) 

Share this post


Link to post
Share on other sites
3 hours ago, bj0rnis said:

I actually tried that and it did not help me. I guess you thought about weight distribution? :-) 

It helped me

I also notice that storage pieces do not affect the rover.

Also do not keep your trucks and rover connected when u leave the planet they may get stuck in the upper atmosphere

 

Share this post


Link to post
Share on other sites

I have a truck with a seat and storage, connected to a second truck with 2 large storage parts on the back. I then started to attach the smaller storage platforms on the triangle storage, and the truck keeps bouncing up and down slightly. Once in awhile it goes berzerk and shoots off in a random direction.

Share this post


Link to post
Share on other sites
8 minutes ago, Lady Athena said:

I have a truck with a seat and storage, connected to a second truck with 2 large storage parts on the back. I then started to attach the smaller storage platforms on the triangle storage, and the truck keeps bouncing up and down slightly. Once in awhile it goes berzerk and shoots off in a random direction.

yeah, you actually aren´t allowed to put these "research" things on the storage sides of the truck. just use the truck itself. u can use the storage for ore and things but the research things will crash it.

i also found out (or maybe it just feels like) if u put another single seat (like two seats) on the rover, it at least feels like it drives more stable.

Share this post


Link to post
Share on other sites

maybe thats the issue I had also. Fully Laden truck with research thingies, Drives like its on crack and keeps sprinting away when it force dismounts you.

Share this post


Link to post
Share on other sites

My truck was bouncing up/down/shaking with a storage area on it as well, but the storage was empty.  I kept looking around to see what the noise was.

Share this post


Link to post
Share on other sites

Confirmed this just now as well, built a Truck, Added a Storage onto it, then put 4 smaller storage units on it, when I drove it the wheels inverted and the thing shot off like a rocket and hit a cloud, then vanished without a trace lol, wish I had caught a video of it. 

Share this post


Link to post
Share on other sites

Confirmed. Attaching 'large' items to the triangle vehicle storage causes the rover/ truck to bounce& roll& fly and if you ave two of those attached together they will rocket into the sky.

Edited by NekoApocalypse

Share this post


Link to post
Share on other sites

So I was driving my truck with a habitat/shelter attached to it to place the shelter in a distant location. Saved the game by getting in and out of the truck and then exited the game. After loading the game my character appeared underneath a big black block floating in the sky. As I walked a little from it I could see that it was a big, moving, rotating blob of ground (maybe) with the truck and all its goods attached to it, spinning in the air. I watched it spin and move away from me until it finally stopped after digging itself half way into the ground. As I approached it and started moving again - apparently in relation to my movement. I started running and was able to catch up to it. I tried to dig away at the big black blob but nothing happened. Hitting TAB when the truck was in range only plopped me out a second later - usually into the upside-down. Anyway, I'll try to make a video of this bug and post it.

Edited by spec24

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now