Talleh

Multiple Multiplayer issues

Recommended Posts

Hi everyone,

 

I have had high hopes for multiplayer since release but we are still running into many issues with playing. A bit of background I have been playing since EA and shelved the game for release in hope some of the niggling bugs in MP were fixed. Alas, the game is a lot more unplayable than it was in EA.

 

I have sent in multiple crash reports, but I thought I would collate all the issues in this thread.

 

MAJOR ISSUES:

  • The host launching a shuttle can cause players connected to crash out of the game
  • Sometimes, when a player is in orbit (not host) they cannot land their shuttle, here is a screenshot of what this looks like; I would like to add, this is a common occurrence, we have around 7 large shuttles in space with a lot of materials and what not.unknown.png
  • The player (again not host) will crash in orbit, again leaving a rouge shuttle in orbit 
  • The game becomes virtually unplayable, with the clients only sitting on arounf 1FPS, this makes the game extremely awful to play. Quitting and re-entering the MP game may or maynot alleviate the issues... and if it does it is only temporary.
  • Many desync the clients will run into, soil/rock floating in the air (which you cannot drive through on a rover) or entire chunks of the environment re-appearing, which in turn will cause loss of equipment and death. Picture as follows;image.png.4ff2ee09699143fa83ac78c340cf01f3.png
  • Storage/items will spontaneously disappear and never return
  • When client crashes, you may or may not come back with your inventory/mods. It seems to be the luck of the draw.

 

MINOR ISSUES:

  • Random Graphical stuff and things, similar to the image you see below. To be honest, these crack me up but I would like to see them fixedimage.png.a852e31905f50619dc62a12032a36ea8.png

 

 

Please let me know if anyone else is experiencing things like this, I would like to know that I am not alone out there in the various things that are keeping me from fully enjkoying the shit out of this game!


Thanks friends~

Tal

 

 

Share this post


Link to post
Share on other sites

I'm hosting this particular game, and this has happened when one of our other friends hosts too. It only seems to start happening deep into the game, once we start doing a lot of terraforming (digging for resources etc).

It used to be in early access that the host was the one that suffered the performance hit, but since the latest update, this has been reversed so that the clients are experiencing massive performance hits as opposed to the host (weird).

I'm running the game on a Ryzen 5 1600X, GTX 1080, 16GB of RAM. I do experience some performance loss when there are 2-3 other players, but the game is still playable at around 20-30 FPS.

Share this post


Link to post
Share on other sites
Posted (edited)

Apologies, I would like to mention this in Windows 10, Steam version of the game. Excuse my typo's it wouldn't let me edit xo

Edited by Talleh

Share this post


Link to post
Share on other sites
Posted (edited)

How fast is your internet connection up and running down? Joe's mentioned recently that connection (and how the game deals with it) appears to be a key factor. 

 

Ed; just saw on Discord you're on 100/40. Between two of your that's 50/20 at maximum, but that's still a decent speed. Looks like they'll have to find more excuses... 

Edited by Blind Io

Share this post


Link to post
Share on other sites
Posted (edited)

Yup, we are on a 100/40 Fibre to the Premises connection!

Adding to this, just experienced falling from space back to the planet (and surviving). If I'm not the queen of multiplayer issues, I don't know who is HAHA.

unknown.png

 

Edited by Talleh

Share this post


Link to post
Share on other sites
Quote

Many desync the clients will run into, soil/rock floating in the air (which you cannot drive through on a rover) or entire chunks of the environment re-appearing, which in turn will cause loss of equipment and death.

Been having this issue since 1.0, entirely client-side, everything works fine for the host

Does NOT appear to be due to any form of latency or network issue. The exact same spots will be "desynced" every time we load up the same save.

On the surface it is most often only a "spotty shell" orbiting an area of terrain (As in the photo in OP). The "shell" can be dug through, but will pop back in after a few seconds. The terrain underneath can still be dug as normal.

Under the terrain there is the occasional large chunk of desynced terrain, all of which will respawn after a few seconds

Share this post


Link to post
Share on other sites

To add to the issues listed above, cables between rover and trailer will sometimes just break (client only, again, host is fine). Always fun seeing your friend coming back and asking what happened to their 3rd trailer.

Share this post


Link to post
Share on other sites
16 hours ago, Blind Io said:

How fast is your internet connection up and running down? Joe's mentioned recently that connection (and how the game deals with it) appears to be a key factor. 

 

Ed; just saw on Discord you're on 100/40. Between two of your that's 50/20 at maximum, but that's still a decent speed. Looks like they'll have to find more excuses... 

Even when it's just me hosting and a remote client (not Talleh), same problems happen, so it can't be the fact that there's two of us on the same connection. The remote client is on 50/(20?) mbps.

Share this post


Link to post
Share on other sites

Other issues in MP:

  • We have found that keeping the object count down allows MP to work as intended, bit of a shame because it is fun to have awesome, sprawling and huge bases sometimes!
  • When joining the host in orbit you might crash and end up launching back into the game back to Sylva (always the starting point), sometimes you will have inventory, sometimes not.

Share this post


Link to post
Share on other sites

In my Multiplayer i have the Problem that the other Player see not the same as i.

i have a rocket that is full with objects but for him is the rocket empty

Share this post


Link to post
Share on other sites
Posted (edited)

Windows 10 Steam, we've seen all the issues you mentioned except the shuttles stuck in orbit - although we have several up there because of clients (never the host) crashing whilst they're in orbit. 

Most issues seem to be reduced by:

* staying close together, in particular on the same planet

* not using tethers

* not using vehicles

* not building too much stuff

* having fast internet

* being the host

Like you say, those things are all anti-fun (apart from the last couple).

Edited by willypimpernel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now