Sign in to follow this  
TAG_Animus

1.0.13.0 - Steam - Terrain Regeneration Bug

Recommended Posts

https://youtu.be/4FL6ADe7su0

 

I don't know if that YouTube link will embed properly. Just figured I'd reiterate this bug - the terrain regenerates in multiplayer (connecting to host - host is fine) when doing deep-cavern dives which subsequently makes mining deep planet minerals impossible.

It makes me not want to play the game.

Share this post


Link to post
Share on other sites

I've done a lot of experimentation with this bug. It's 100% reproducible and happens across multiple saves, multiple planets.

Near as I can tell, it seems like the problem is that the host machine and clients disagree about the placement of a specific type of small cave; the host says the tunnel is located about ten meters away from where the clients generate it, and that disagreement makes certain locations behave very strangely, as in the above clip. It also leads to one player phasing through the ground, or appearing to hover in midair above a hole that doesn't exist for them.

The specific type of cave that causes this problem is generated on most planets, but seems to be much more rare on Calidor, and much more common on Vesania. Vesania is basically unplayable in multiplayer as a consequence, but other planets that generate this cave more rarely can be navigated by dodging that particular style of tunnel and avoiding the glitchy patches.

Share this post


Link to post
Share on other sites

I had no idea that it was related to tunnels or that it was being affected some distance away (like 10m)

This is brilliant that you've researched it so well - but you're right, it does make the game basically unplayable in terms of resource gathering... you know, the stuff you use to build everything.

 

Just had a respawn glitch happen yesterday too where when I connected to the host, I saw the opening animation play again and it started me with nothing on Glacio... it's just awful networking code

Share this post


Link to post
Share on other sites
Posted (edited)

100% happens in all the saves I've had in multiplayer (on steam) for the clients connected to the host. Super annoying when you need to go down into a cave with a path you have carved out and need to get a vehicle down there!

P.S. It can also cause random death since we can't see some of the holes created!

Edited by Talleh

Share this post


Link to post
Share on other sites

Unplayable in MP because of this bug, which was introduced with the 1.0 release. Happens on surface and in tunnels all the time. New after the update 1.1 is, that after the client was digging the terrain not only regenerates, but there ist new terrain added and the client is suddenly trapped the newly added ground and then is falling or flying to another cavern...

This is getting worse, please fix this, so the game is playable in MP again 😞

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this