Trapped in my shelter


Recommended Posts

version 1.0.9

steam

I wanted to print something with my medium printer. My rover was in the way.

I jumped into the rover, pressed S to move it in reverse, and jumped out after doing so, before the rover was stopped.

The rover moved on just a little more, and my astroneer landed on/in the shelter.

My view of the world became enlarged and very limited.

I could see half my astroneer, from inside my astroneer, which was also inside and outside my shelter.

I tried to move, but all I got was a running animation in standing place.

I could jump upwards, and fall downwards, but not move in any direction at all.

I cannot enter my shelter, or the nearby rovers.

I even tried to dance, which was slightly amusing from the viewpoint of the hands at the waist level.

I took three screenshots to prove how bad it is.

I quit to main menu, and reloaded the game, but I am still stuck.

 

So I quit the game and came here :(

My single player save game is ruined, and my progress will be lost.

20190305231824_1.jpg

20190305231926_1.jpg

20190305231934_1.jpg

Link to post
Share on other sites

I can dig, and I can raise the ground, but neither frees me.

I can emote, but I don't move from the spot, even in a dance.

I can run on the spot, forward or backward, and I can sidestep on the spot.

I can look around. I cannot interact with any rovers or buildings.

If I click, I seem to bring up my backpack, but all I can see of it is a huge black circle.

If I click again, it restores to my previously messed up state.

Link to post
Share on other sites

Oh crap. It would be better not to leave the game because he always saves there. I'm surprised that you can not get into the rover. Normally, it works at a distance very early and if you zoom far out. Suffocation is of course not synonymous. The only thing I can think of is inviting a friend in multiplayer and bringing the rover closer, or putting a seat within reach or where it works. If that does not help maybe with the Terrain Tool try to glitch out of it. Maybe with a wall or ramp then press up. If you already have dynamite he can place one of them, that should be enough. The habitat nothing happens so no fear.

Link to post
Share on other sites

cant zoom in or out. Cursor cannot interact with rovers or other objects. Digging and building under me didn't affect me.

But inviting a friend might be worth a try. Thanks. Maybe he can kill me with dynamite.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

×   Your link has been automatically embedded.   Display as a link instead