Sign in to follow this  
Bomoo

1.0.7 - Rover Movement/Handling

Recommended Posts

As of the 1.0.7 patch, whatever you did to the physics has improved some things, like dislodged debris falling through the world, and just generally seems to have made things much weightier. However, what it's also done to my rovers, all of them, is made driving them like trying to ride a jittery crack mongoose. They move way way WAY too fast over the terrain, like they're skidding over a greased linoleum floor. Doesn't make for a satisfying driving experience to put it mildly.

Share this post


Link to post
Share on other sites

SES has had vehicle issues from day one. They have never been able to get them to perform as designed. It is my bet, they never will. 
Until

They change to tracks or hover

Tires filled with air on planets with varying degrees of gravity is a disaster. Obviously. It has been a part of my game since 12/16/16 (the date I purchased). I just passed the 900 hour threshold.


I just unlocked all cores. I unlocked all the gateways. I unlocked that alien thingy. I did not use a single vehicle to do so. I created the tractor just to see what it looks like but never used it. 

Maybe last summer(?) there was a video I saw with someone working on a vehicle with tracks rather than wheels. However, like most things SES, updates/changes/additions/improvements/fixes take forever if they come at all.

Example:
I can remember way way way back to the early days when people were complaining about tethers just magically floating in space when placed. I can remember dozens upon dozens of posts about it. I can remember SES stating it would be fixed. 2 plus years later........................

Share this post


Link to post
Share on other sites

Rover handling was just fine between the rover update and 1.0.7. Tracked vehicles were never a thing, not even a WIP, so I'm not sure where you saw that. Might be some fan model. And hover vehicles or any other star trek far future sci-fi technology doesn't belong in this setting. Who says the tires are filled with air? I have never once had my tethers magically floating up into space and I've been playing since day one of SEA.

Not that the bug report forum is the place for this kind of discussion. I'm simply reporting erratic and unexpected behaviour that's appeared as of the latest patch.

Edited by Bomoo

Share this post


Link to post
Share on other sites

Still hasn't been addressed as of 1.0.9.

If this jankiness and reversal of all the gains to vehicle handling made since the rover update is intentional, it's going to be the final nail in the coffin, finally eradicating every aspect of Astro that made it enjoyable for me to interact with. I used to love this game, but since the beginning of the so-called "v1.0" beta, you seem to be trying your hardest to make me reconsider that position.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this