SES_joe

Patch 1.0.7 - February 21, 2019

Recommended Posts

Patch_Notes_Poster.png

UPDATE: 2/21/2019

Fixes for the backend service that would have unlocked all customization unlocks have overwhelmed our services and caused performance drops while the game continues to try and connect. We have implemented a fix and hope to have a hotfix out ASAP. 


The primary focus of this release was to address as many major gameplay issues as possible that have been reported over the last couple of weeks, as well as a fix for Xbox / Windows 10 players who could no longer access cosmetic items they have unlocked through progression. 

BUGFIXES

  • Fixed more of our most commonly reported crashes increasing overall stability. 
  • [AS-6164] - Fixed a major issue where vehicles would decide to take an unwelcome nap, and would remain stationary despite being powered. 
  • [AS-5572] - Fixed a major issue in Multiplayer that would cause Client Player’s camera to be launched into space if the "Enter" command was pressed multiple times when entering a seat. 
  • [AS-6127] - Added some guards and performance improvements to address the issue which occurred most often on lower end machines causing picked up and dropped items to fall through the terrain. There may still be some visible stuttering on lower end specs, but items should no longer be irretrievably lost. 
  • [AS-6103] - "Up By the Roots" achievement should now become unlocked by unearthing Popcoral
  • [AS-6243] - Fixed a major issue where Players on Xbox / Win 10 would no longer see their unlocked cosmetic options as of version 1.0.6.0. The underlying issue had to do with the platform not properly communicating with our backend service and therefore not being able to pull down a player’s inventory. Actual player inventory was not affected and all items should be rightfully restored in the UI view as of version 1.0.7.0.
  • [AS-6070] - Fixed a major issue in Multiplayer that occurred when a Client Player disconnected a rover train the Host was driving, the towed vehicle could no longer be driven by any players. 
  • [AS-6218] - Remove the use key quick stow capability (Edit: Clarification = We removed the 'hover over something + press F to Quickstow because it was causing some usability issues... namely for gamepad users who had something accidentally proximity selected that would wind up stowed.)
  • [AS-5857] - Fixed an issue in Multiplayer games where Terrain would be briefly invisible for Client Players when joining a Multiplayer game. Included in this fix are other improvements to the load / join experience which should result in a more consistent experience throughout the game. 
  • [AS-6180] - Fixed a rare Multiplayer issue that would cause a rover train to become disconnected when Client Player drove the train.
  • [AS-6233] - Fixed an issue which would cause clouds to z-fight to death when viewed from distance and turn into a flickery soup. 
  • [AS-6190] - The required resource icon at the subterranean Engine on Glacio has been changed to match the resource’s tool tip. 
  • [AS-6114] - Removed the erroneous mention of Oxygen on the gas resources tab of the Astropedia
  • [AS-5902] - Removed erroneous smoke effects on the Shuttle Wreckage Thrusters.

KNOWN ISSUES

  • Client desync and performance drops on all platforms. (Update: We are working furiously to ease the pressure on the host machine in order to fix this. Turns out MANY non relevant items were being rendered (items below ground in caves for example) so we are working on implementing an unreal engine feature that will help this issue tremendously)
  • Exiting Tractors will sometimes cause clients to catapult into space and subsequently suffocate. (Update: Verified that is happens when pressing "enter" twice before entering. Should be fixed in next week's update)
  • Vehicles will sometimes not respond to input, causing repeated enters and exits before resuming normal operation (Update: turns out this might happen when other inputs are held while entering. Should be fixed in next week's patch)
  • Some modified terrain nodes will sometimes lose collision, causing players to quicksand into them. (Still debugging this issue. Seems like deformation is causing terrain node math to get into a weird state. Hoping to have this fixed next week)
  • Crashing on loading before the start menu (This seems to impact players on windows 7. If you are having this problem there is a workaround you can use while we work on the fix.
  • If you crash while in a shuttle in orbit, the shuttle will remain in orbit and your starting point might get broken. We have a solid repro of this and are tracking a fix. 

UPDATE: 2/21/2019

Fixes for the backend service that would have unlocked all customization unlocks have overwhemed our services and caused performance drops while the game continues to try and connect. We have implemented a fix and hope to have a hotfix out ASAP.

Glad we got some of the gameplay bugs that impact the most players! Looking forward to continuing to squash gameplay bugs and get performance in line with what what we expect on all platforms!

-jt

Share this post


Link to post
Share on other sites

Your amazing for fixing the napping vehicles it was a definite inconvenience to reattach cables or replace the seats just to get moving again. Thank you so much.   

Share this post


Link to post
Share on other sites
2 minutes ago, Quackyrole_GC said:

now please fix the scrap glitch

Heretic, the scrap glitch must live on!

Share this post


Link to post
Share on other sites
3 minutes ago, Quackyrole_GC said:

FINNALLY THE VEHICLES WONT MISBEHAVE
now please fix the scrap glitch

It won't last another week.

Share this post


Link to post
Share on other sites

Appreciate the vehicles and item clipping bugs! I have a few bugs I've encountered myself that I'd like to put forward

- Yellow power level on cables flickers rapidly (along with extender cables) for some unknown reason? I only encountered the error on Sylva.

- Player being ejected into the air while exploring on foot for no clear reason (and perishing from fall damage). Very Frustrating.

- Atrox has some minor general movement issues where the player stutters and gets caught on seemingly nothing.

- Stereo audio does not seem to work some times (Inverts, is based on the models direction, not the viewport.)

- In the galaxy map, Beacons and other indicators can be seen in open space, pointing to nothing.

Share this post


Link to post
Share on other sites

Glad to see a few fixes especially one for joining a multiplayer game I remember joining a game and getting stuck inside the starting/menu rocket for a few seconds. Not sure if its because my wifi is bad and going online is not recommended; the fact that he was streaming; or a combination of the two but something happened and had me in space for awhile/ also I encountered a glitch or bug where 2 wind turbines and a solar panel on a large rover would produce a infinite power like visual glitch at the moment I'm not sure if any extra power comes out of it but it does happen randomly when the wind is at full power

Edited by Anthony Matyjasik
Remembered a bug/glitch

Share this post


Link to post
Share on other sites

Is this patch now live for Microsoft Store and Xbox One users yet?  Amazing work BTW.  If you have some time, please review the following bugs we've produced so far: 

 

Edited by VipeNess

Share this post


Link to post
Share on other sites
3 minutes ago, VipeNess said:

Is this patch now live for Microsoft Store and Xbox One users yet?  Amazing work BTW.  If you have some time, please review the following bugs we've produced so far: 

 

Starts rolling out in about half an hour. 

Share this post


Link to post
Share on other sites

Please.

PLEASE

PLEASE DON'T FIX THE SCRAP GLITCH !

It is FAR too useful. And it not like you are gonna do it accidently. If you don't want to do it, fine, don't do it. But for people that want to do it, PLEASE keep it in !

Share this post


Link to post
Share on other sites
2 minutes ago, Papabreezyswag said:

Does anyone know when the xbox update might happen?

Roll-out starts in a few minutes. I noted that two posts above your question. 

Share this post


Link to post
Share on other sites

I see no mentioning of this:

Which is kinda game breaking for those affected by it, unless random deaths and not being able to go where friends go don't count for that :/

Share this post


Link to post
Share on other sites
2 minutes ago, bubbas said:

I see no mentioning of this:

Which is kinda game breaking for those affected by it, unless random deaths and not being able to go where friends go don't count for that :/

Maybe check 'known issues' again... 

Share this post


Link to post
Share on other sites
1 hour ago, Quackyrole_GC said:

nice i killed the scrap glitch

No worries fam, I killed it long ago...it was too awesome to not make videos about it...RIP Scrap glitch, you will be missed.

15 minutes ago, josh schulze said:

How about giving back the retro suit to the people who games crashed and lost it

That's just a sync bug, it'll appear again soon enough.

Share this post


Link to post
Share on other sites
2 hours ago, kingo said:

- Player being ejected into the air while exploring on foot for no clear reason (and perishing from fall damage). Very Frustrating

I had this happen to me, but it turns out there was a bouncevine just underneath the surface. It was deep enough that it wasn't visible without digging, but shallow enough that walking over still triggered it. Maybe that's what happened for you, too?

Edited by Collin

Share this post


Link to post
Share on other sites

The newest update made my game unplayable on Xbox one. It was working fine three hours ago but I updated it and now it runs at an unbearably low frame rate, making it virtually impossible to play.

Share this post


Link to post
Share on other sites
1 hour ago, Collin said:

I had this happen to me, but it turns out there was a bouncevine just underneath the surface. It was deep enough that it wasn't visible without digging, but shallow enough that walking over still triggered it. Maybe that's what happened for you, too?

I've been randomly launched into the air as well, but I'm not so sure about that. When it happened to me, I was shot up vertically; but from my experience, those plants launch me more horizontally than vertically. Plus when you step on one of those plants, they make a sound when they throw you. When I was shot up, there was no sound. It's as if I was just teleported into the sky.

Share this post


Link to post
Share on other sites
18 minutes ago, Heather Harper said:

The newest update made my game unplayable on Xbox one. It was working fine three hours ago but I updated it and now it runs at an unbearably low frame rate, making it virtually impossible to play.

Same here (Xbox one S) testes with old and new save.

and i can't get the achievements at all 0/54

Clearing cache, delete saves/preferences and new syncing from cloud doesn't helps

Share this post


Link to post
Share on other sites
29 minutes ago, Heather Harper said:

The newest update made my game unplayable on Xbox one. It was working fine three hours ago but I updated it and now it runs at an unbearably low frame rate, making it virtually impossible to play.

Same here, Xbox One X. It's legitimately unplayable. Tried everything to get it to run faster. Thought it might be the 4K, changed to 1080P, runs even worse. Devs, PLEASE ROLL BACK THE 1.0.7.0 UPDATE!!! We just want to play : (

Edited by JohnnyBK

Share this post


Link to post
Share on other sites

I really hope the bug between xbox to a windows 10 store host bug gets squashed, it would say invalid session or unable to resolve host, something along those lines. I'm unsure if it has been fixed with these recent patches, but ill reply if it is. If not, I really hope this can get fixed because it is impeding me and a friend from enjoying the galaxy!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.