SES_joe

Patch 1.0.7 - February 21, 2019

Recommended Posts

Any ETA on next patch? Waiting on this one before I jump back in.

 

  • Some modified terrain nodes will sometimes lose collision, causing players to quicksand into them. (Still debugging this issue. Seems like deformation is causing terrain node math to get into a weird state. Hoping to have this fixed next week)

Share this post


Link to post
Share on other sites

Love all the bug fixes but if it becomes possible to reintroduce the quickstow hotkey please do. Not being able to quickstow seriously hinders efficiency. Especially if I’m picking back up a long line of tethers now I have to drag each one individually

Share this post


Link to post
Share on other sites

Please at least make the quick pick up key an option. I use this constantly and I have no issues without this. Especially for gamepad users this makes picking up a lot of items very slow. This feels like a punishment. Please return this option. Please. 

Share this post


Link to post
Share on other sites

Really impressed you got the patch out for xbox so quickly.  However the 1.06 patch made frame rate drops worse and this patch has made it worse again.  Nearly unplayable.  Quiting, restarting the app and re-entering seems to help for a short time.  

 

Share this post


Link to post
Share on other sites

Please get on fixing the gateway bug. It is a pain for me that I now live on desolo instead of sylva, and it prevents completion of the game.

 

Share this post


Link to post
Share on other sites
5 minutes ago, Encursed said:

Please get on fixing the gateway bug. It is a pain for me that I now live on desolo instead of sylva, and it prevents completion of the game.

 

A small shuttle and solid rocket thrusters can be constructed on any planet.  How are you stuck on Desolo?

Share this post


Link to post
Share on other sites

Any timeline on when the first "known issue" on the list will be patched?

Quote

Client desync and performance drops on all platforms. (Update: We are working furiously to ease the pressure on the host machine in order to fix this. Turns out MANY non relevant items were being rendered (items below ground in caves for example) so we are working on implementing an unreal engine feature that will help this issue tremendously)

 

Edited by corbu

Share this post


Link to post
Share on other sites

Ok, I have narrowed down that the research chamber is having a massive negative impact on performance on xbox.  

Share this post


Link to post
Share on other sites
5 hours ago, SES_joe said:

[AS-6218] - Remove the use key quick stow capability (Edit: Clarification = We removed the 'hover over something + press F to Quickstow because it was causing some usability issues... namely for gamepad users who had something accidentally proximity selected that would wind up stowed.)

First off, thank you for the time and effort all have put into this neat game!

Would have been nice if this feature was added to the menu and allowed for us to enable by choice. At first I didn't like using "F" for USE and Quickstow, but it quickly grew on me. Using Shift + Click for picking up tethers and swapping items to/from the Terrain Tool is kinda a pain.

Just my 2 bytes...

Share this post


Link to post
Share on other sites

BCatalytic, it is your research chambers.  They are killing your performance.  Best bet is to let the current research run out and then hold off researching while playing.  

Share this post


Link to post
Share on other sites
1 minute ago, Kalli said:

BCatalytic, it is your research chambers.  They are killing your performance.  Best bet is to let the current research run out and then hold off researching while playing.  

Ahhh. Will do. Unfortunate as I just got the medium shuttle and was on my way to get hematite and lithium. 🤤 when will the fix be able to be downloaded? Does it take a day or so to push through Microsoft or are these things instant from when you upload them?

Share this post


Link to post
Share on other sites
1 minute ago, Kalli said:

BCatalytic, it is your research chambers.  They are killing your performance.  Best bet is to let the current research run out and then hold off researching while playing.  

I mistakenly quoted you but can't delete it. Sorry!

 

Performance has taken a massive hit in this patch, old school Xbone. Its not playable, on an established save at least. No desire to test a new game. 

Share this post


Link to post
Share on other sites

Ahhh, still not working for me.  Tried it twice, first time got 20 minutes, second time only got 10 minutes. Keeps crashing.

Share this post


Link to post
Share on other sites

bugs  crane / rover  will not collect dirt with the drill attachment  

bug geting in seats or base to save game  crash`s game and lose 2 hours of work

and major lag in mulit player co op  / lag wen entering  rover  

 

Share this post


Link to post
Share on other sites

Just a quick heads up regarding performance. 

 

It has been identified that the achievement/unlock fix has an error that's jamming up communication to the SES servers, which is also impacting performance. 

Share this post


Link to post
Share on other sites

Confirmed...if you are running any research on Xbone the performance will drop to unplayable levels. Cancel your research for now and wait for an update I guess. Guess I'm glad I had 40K+ banked up.

Edited by Cotacia

Share this post


Link to post
Share on other sites
6 hours ago, SES_joe said:

Patch_Notes_Poster.png

UPDATE: 2/21/2019

Fixes for the backend service that would have unlocked all customization unlocks have overwhelmed our services and caused performance drops while the game continues to try and connect. We have implemented a fix and hope to have a hotfix out ASAP. 


The primary focus of this release was to address as many major gameplay issues as possible that have been reported over the last couple of weeks, as well as a fix for Xbox / Windows 10 players who could no longer access cosmetic items they have unlocked through progression. 

BUGFIXES

  • Fixed more of our most commonly reported crashes increasing overall stability. 
  • [AS-6164] - Fixed a major issue where vehicles would decide to take an unwelcome nap, and would remain stationary despite being powered. 
  • [AS-5572] - Fixed a major issue in Multiplayer that would cause Client Player’s camera to be launched into space if the "Enter" command was pressed multiple times when entering a seat. 
  • [AS-6127] - Added some guards and performance improvements to address the issue which occurred most often on lower end machines causing picked up and dropped items to fall through the terrain. There may still be some visible stuttering on lower end specs, but items should no longer be irretrievably lost. 
  • [AS-6103] - "Up By the Roots" achievement should now become unlocked by unearthing Popcoral
  • [AS-6243] - Fixed a major issue where Players on Xbox / Win 10 would no longer see their unlocked cosmetic options as of version 1.0.6.0. The underlying issue had to do with the platform not properly communicating with our backend service and therefore not being able to pull down a player’s inventory. Actual player inventory was not affected and all items should be rightfully restored in the UI view as of version 1.0.7.0.
  • [AS-6070] - Fixed a major issue in Multiplayer that occurred when a Client Player disconnected a rover train the Host was driving, the towed vehicle could no longer be driven by any players. 
  • [AS-6218] - Remove the use key quick stow capability (Edit: Clarification = We removed the 'hover over something + press F to Quickstow because it was causing some usability issues... namely for gamepad users who had something accidentally proximity selected that would wind up stowed.)
  • [AS-5857] - Fixed an issue in Multiplayer games where Terrain would be briefly invisible for Client Players when joining a Multiplayer game. Included in this fix are other improvements to the load / join experience which should result in a more consistent experience throughout the game. 
  • [AS-6180] - Fixed a rare Multiplayer issue that would cause a rover train to become disconnected when Client Player drove the train.
  • [AS-6233] - Fixed an issue which would cause clouds to z-fight to death when viewed from distance and turn into a flickery soup. 
  • [AS-6190] - The required resource icon at the subterranean Engine on Glacio has been changed to match the resource’s tool tip. 
  • [AS-6114] - Removed the erroneous mention of Oxygen on the gas resources tab of the Astropedia
  • [AS-5902] - Removed erroneous smoke effects on the Shuttle Wreckage Thrusters.

KNOWN ISSUES

  • Client desync and performance drops on all platforms. (Update: We are working furiously to ease the pressure on the host machine in order to fix this. Turns out MANY non relevant items were being rendered (items below ground in caves for example) so we are working on implementing an unreal engine feature that will help this issue tremendously)
  • Exiting Tractors will sometimes cause clients to catapult into space and subsequently suffocate. (Update: Verified that is happens when pressing "enter" twice before entering. Should be fixed in next week's update)
  • Vehicles will sometimes not respond to input, causing repeated enters and exits before resuming normal operation (Update: turns out this might happen when other inputs are held while entering. Should be fixed in next week's patch)
  • Some modified terrain nodes will sometimes lose collision, causing players to quicksand into them. (Still debugging this issue. Seems like deformation is causing terrain node math to get into a weird state. Hoping to have this fixed next week)
  • Crashing on loading before the start menu (This seems to impact players on windows 7. If you are having this problem there is a workaround you can use while we work on the fix.
  • If you crash while in a shuttle in orbit, the shuttle will remain in orbit and your starting point might get broken. We have a solid repro of this and are tracking a fix. 

UPDATE: 2/21/2019

Fixes for the backend service that would have unlocked all customization unlocks have overwhemed our services and caused performance drops while the game continues to try and connect. We have implemented a fix and hope to have a hotfix out ASAP.

Glad we got some of the gameplay bugs that impact the most players! Looking forward to continuing to squash gameplay bugs and get performance in line with what what we expect on all platforms!

-jt

My biggest issue on xbox 1.0.6 was performance near my base with almost every machine built it really started to drag, havent tried the .0.7 yet so here's hoping 

Share this post


Link to post
Share on other sites

When starting game in x box speed was SUPER SLOW. I had 4 research modules going and stopped them from operating. Seemed to fix the slowness but now I can't research :( 

Share this post


Link to post
Share on other sites

I host a server for a few friends to play.  After the patch to 1.0.7, a friend is now unable to play.  That friend has tried logging in and out of the server to no avail solution.  Previous, he logged out of a shuttle last night while playing on 1.0.6.  When he reconnected today using 1.0.7, he could not connect to the server.  In-game, the first time, I watched his character model jiggle around glitching in place forever while he said his screen said loading solar system.  He still is unable connect to the game, but interesting enough, he can hear in-game sounds while the screen still says loading.  He can hear my footsteps, pretty much everything besides playing the game.

We are running the Microsoft Store 1.0.7.0 version.

Edited by VipeNess

Share this post


Link to post
Share on other sites
7 hours ago, Xiarno said:

Please.

PLEASE

PLEASE DON'T FIX THE SCRAP GLITCH !

It is FAR too useful. And it not like you are gonna do it accidently. If you don't want to do it, fine, don't do it. But for people that want to do it, PLEASE keep it in ! 

Me too, please don't fix it 🙌

Share this post


Link to post
Share on other sites
4 hours ago, JohnnyBK said:

Same here, Xbox One X. It's legitimately unplayable. Tried everything to get it to run faster. Thought it might be the 4K, changed to 1080P, runs even worse. Devs, PLEASE ROLL BACK THE 1.0.7.0 UPDATE!!! We just want to play : (

I have reinstall the game on my XBOX ONE X and let playing it on a external SSD (Samsung 850 EVO Basic 500GB). Testing time today morning a half hour around the base on Sylva with no problems, fps ok (better as 1.0.6) 😉

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.