Recommended Posts

My Retro Suit has vanished from the list of available suits to choose from. It was there after the 1.0.4.0 patch, but now it's gone. Not sure if it's a continuation of the known issue of it being sometimes unavailable, or something else, but figured it should be mentioned.

Oh, and my current suit changed palette colours on its own. On 1.0.4.0 I was rocking the Exo Red Palette, but after the latest update i found it had reset to Exo Standard (Blue). Have been able to change it back, no problem, but thought it was worth mentioning.

Share this post


Link to post
Share on other sites

Does this include players who haven't had the retro suit appear since upgrading to 1.0?

It appeared briefly on my Xbox One X whilst in preview then vanished.

Share this post


Link to post
Share on other sites

it doesn't appear to be confined to Xbox. I've discovered the same issue on WIN 10. retro suit is gone and unlocked stuff is now locked.

Share this post


Link to post
Share on other sites
1 hour ago, Joshua Cox said:

it doesn't appear to be confined to Xbox. I've discovered the same issue on WIN 10. retro suit is gone and unlocked stuff is now locked.

Wait, this issue also effects unlocked items? Do you mean the other locked suits and the locked palettes? Now that is extra annoying.

Share this post


Link to post
Share on other sites

Earlier just before the update launched started the game and the retro suit was gone.  Played for about an hour then the game quit and forced the update. You're supposed to get suits from unlocking cores correct? If that's the case I never got one from sylva

Share this post


Link to post
Share on other sites

After 1.06 I have lost my retro suit and my unlocked suits and pallets, I play Xbox and have already been told it’s being looked into, bit of a pain admittedly but more so is the fact I’ve hardly noticed much in the way of performance, still painfully slow can’t bear playing my main save which is five planets in :(

started a new save couple days ago, was doing well, game running smooth, now activated the core and game has become noticeably slower again. 

Not sure what is being done to make this work but something isn’t right.

Share this post


Link to post
Share on other sites
15 hours ago, Ghostwolf93 said:

Wait, this issue also effects unlocked items? Do you mean the other locked suits and the locked palettes? Now that is extra annoying.

Just the suits yes. Stuff unlocked from the catalog in your pack does not seem tp be effected.

Share this post


Link to post
Share on other sites

I also have lost ALL of my unlockable things (suits, pallets, visors, and my retro suit). i also completed the radiated planet, and it crashed immediately. i got the Xbox achievement, but not the suit i work for for almost 12-13+ hours. please fix this. 

Edited by Eric Neel

Share this post


Link to post
Share on other sites

I've just discovered that lost my vintage stuff having found the lander last week.

This is on top of my still missing retro suit which has never reappeared despite these fixes.

I'm on Xbox and have been playing this since in Game Preview (btw it is still called that on my machine in places even after all the updates).

And for those you collect the Microsoft Reward Points the Achievements in Astroneer do not register despite being acquired within the active time window. The irony being Astroneer is actually a shown as the lead game on the reward graphic.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now