SES_joe

Patch 1.0.6 - February 15th, 2019

Recommended Posts

patch106.png

This patch should already be deployed on Steam, and is in Xbox cert but because of the holiday on Monday, will likely not be deployed till Tuesday 2/19. You should expect our next patch on 2/22/19.

The primary focus of this release is addressing the top crashes we are seeing out in the wild. This patch also contains some performance improvements and other bug fixes. 

  • Fixed several of our most commonly reported crashes increasing overall stability. Most notably, we have fixed crash which would occur when saving a game, causing that save game to be corrupted. Saved games affected by this issue should once again become playable after installing this update. 
  • Made additional performance improvements to the Terrain system, specifically when deforming a lot of terrain. 
  • [AS-5878] - Fixed a bug where Research Samples attached to the bottom of Hazards would fall through terrain when the Hazard was dug up. 
  • [AS-5925] - Fixed an issue where Clients would not see the appropriate Oxygenator state in Multiplayer games. 
  • [AS-5931] - Fixed a bug where undermining large EXO wrecks would cause them to jitter around wildly while they look for a stable resting spot.
  • [AS-6062] - Fixed a collision issue on some of the larger rocks and formations found on Vesania. 
  • [AS-6088] - Fixed a bug where Hazards would be destroyed too quickly when dug up. The fix changes unburying behavior across the entire game to be more consistent for all objects. 
  • [AS-6124] - Fixed a bug that caused foliage to shrink in place when harvesting with the Terrain Tool at maximum range
  • Made a few more small changes to how often we report back Achievement progress to our back end service. This should have no outward impact on the game, but will stabilize the connection to the service. 

KNOWN ISSUES

  • Client desync and performance drops on all platforms. (Update: We are working furiously to ease the pressure on the host machine in order to fix this. Turns out MANY non relevant items were being rendered (items below ground in caves for example) so we are working on implementing an unreal engine feature that will help this issue tremendously)
  • Exiting Tractors will sometimes cause clients to catapult into space and subsequently suffocate. (Update: Verified that is happens when pressing "enter" twice before entering. Should be fixed in next week's update)
  • Vehicles will sometimes not respond to input, causing repeated enters and exits before resuming normal operation (Update: turns out this might happen when other inputs are held while entering. Should be fixed in next week's patch)
  • Some modified terrain nodes will sometimes lose collision, causing players to quicksand into them. (Still debugging this issue. Seems like deformation is causing terrain node math to get into a weird state. Hoping to have this fixed next week)
  • Crashing on loading before the start menu (This seems to impact players on windows 7. If you are having this problem there is a workaround you can use while we work on the fix.
  • If you crash while in a shuttle in orbit, the shuttle will remain in orbit and your starting point might get broken. 

Share this post


Link to post
Share on other sites

Thanks System Era! Astroneer 1.0 is great, and would love couch coop for the Mrs.

Edited by cmadison

Share this post


Link to post
Share on other sites
58 minutes ago, SES_joe said:

Vehicles will sometimes not respond to input, causing repeated enters and exits before resuming normal operation (Update: turns out this might happen when other inputs are held while entering. Should be fixed in next week's patch)

Can't wait for this one to get patched it's driving me nuts.

Share this post


Link to post
Share on other sites

Was wondering if and when there will be a fix for the mass tether disconnect and reconnect lag? Love the patch notes!

Share this post


Link to post
Share on other sites

Any efforts on fixing the tether frame drops for host? Once you reach a certain amount of tethers placed, each time you place a new one the host will freeze for around 5 seconds and so will the whole server. Seems like every time you place a tether it updates every single one and causes lag.

Share this post


Link to post
Share on other sites

I have a reoccurring issue, sometimes when I am having a stroll in my tractor and trailer, they fall through the floor and disappear, and it sucks because I had equipment and stuff on them most of the time so yeah, if I could get some confirmation about that issue that would be great thanks!

Share this post


Link to post
Share on other sites

Glad to see you are working on this but I think top preference according to all the posts I'm seeing should be fixing the load on the primary machine because multiplayer is still unplayable even at specs listed for the game being met on all machines.

If you are reading these responses it would be great to get some info from you on what is more important, faster connection or higher spec computer as host.

Share this post


Link to post
Share on other sites
8 minutes ago, Korkee said:

Glad to see you are working on this but I think top preference according to all the posts I'm seeing should be fixing the load on the primary machine because multiplayer is still unplayable even at specs listed for the game being met on all machines.

If you are reading these responses it would be great to get some info from you on what is more important, faster connection or higher spec computer as host.

The top known issue directly relates to the first point. 

As for the second part, 'faster' and 'higher' compared to what? The same spec will be better on a better connection, to a point. A better spec will be better on a set connection, to a point. Most signs indicate the CPU is the weakpoint in a decent system with good internets. Optimisations are coming! 

If you and your friends have very similar specs, the one with the best upload should probably host. If you were referring to minimum specs, well... 

Share this post


Link to post
Share on other sites
2 minutes ago, Blind Io said:

The top known issue directly relates to the first point. 

As for the second part, 'faster' and 'higher' compared to what? The same spec will be better on a better connection, to a point. A better spec will be better on a set connection, to a point. Most signs indicate the CPU is the weakpoint in a decent system with good internets. Optimisations are coming! 

If you and your friends have very similar specs, the one with the best upload should probably host. If you were referring to minimum specs, well... 

Okay so one of us has much more RAM, another one of us has a faster CPU. and the third one has the fastest internet by a large margin... particularly upload.

8gb 3.7ghz 30 upload
16gb 2.8 ghz 10 upload
16 gb 3.7ghz and much newer processor but 4 upload


Which would host in your opinion?

Share this post


Link to post
Share on other sites
18 minutes ago, Korkee said:

Okay so one of us has much more RAM, another one of us has a faster CPU. and the third one has the fastest internet by a large margin... particularly upload.

8gb 3.7ghz 30 upload
16gb 2.8 ghz 10 upload
16 gb 3.7ghz and much newer processor but 4 upload


Which would host in your opinion?

The last one. Upload doesn't mean much on lower RAM, and the newer CPU beats the middle spec. 4mbps should be plenty of upload speed. 

Share this post


Link to post
Share on other sites
3 hours ago, Blind Io said:

The last one. Upload doesn't mean much on lower RAM, and the newer CPU beats the middle spec. 4mbps should be plenty of upload speed. 

I would say the number of logical threads is important here if the 2.8 has 8 logical threads and the other 3.7 has only 4 then it should be the host

there's a lot to be said about processor family as well, wife's fx 8350 has more raw power and more threads than my ryzen 5 but i seem to be a better host likely due to the fact my processor has more bells and whistles

Edited by Hexi Hamaski

Share this post


Link to post
Share on other sites

Is there a date for when 1.0.4 and 1.0.6 will be out for Windows 10? I'm still running 1.0.3 and there are no updates for the game in the Microsoft store. Just was wondering why Windows 10 is behind on updates from the other platforms.

Share this post


Link to post
Share on other sites
4 hours ago, JMW197 said:

Is there a date for when 1.0.4 and 1.0.6 will be out for Windows 10? I'm still running 1.0.3 and there are no updates for the game in the Microsoft store. Just was wondering why Windows 10 is behind on updates from the other platforms.

Steam has been on 1.0.6 since at least last night.

Share this post


Link to post
Share on other sites
4 hours ago, JMW197 said:

Is there a date for when 1.0.4 and 1.0.6 will be out for Windows 10? I'm still running 1.0.3 and there are no updates for the game in the Microsoft store. Just was wondering why Windows 10 is behind on updates from the other platforms.

Microsoft Store and Xbox versions are updated together. As the notes say, it's expected Tuesday. 

Microsoft require that releases are put through 'certification' to test stability etc. - Steam doesn't have that quality control step, so devs can push updates immediately. Unfortunately the cert team only works business hours, so a weekend and a public holiday immediately after the patch was submitted causes a delay. 

Share this post


Link to post
Share on other sites
19 minutes ago, Blind Io said:

Microsoft Store and Xbox versions are updated together. As the notes say, it's expected Tuesday. 

Microsoft require that releases are put through 'certification' to test stability etc. - Steam doesn't have that quality control step, so devs can push updates immediately. Unfortunately the cert team only works business hours, so a weekend and a public holiday immediately after the patch was submitted causes a delay. 

Okay, good to know. Thanks for letting me know! :)

Share this post


Link to post
Share on other sites

I tried the game again on my Windows machine and it still crashes after 20 to 30 minutes of play.

Wait for the next patch.

Share this post


Link to post
Share on other sites
On 2/16/2019 at 11:06 AM, Korkee said:

Glad to see you are working on this but I think top preference according to all the posts I'm seeing should be fixing the load on the primary machine because multiplayer is still unplayable even at specs listed for the game being met on all machines.

If you are reading these responses it would be great to get some info from you on what is more important, faster connection or higher spec computer as host.

+++ to this, multiplayer being playable should be considered an essential for a fully released game. It's a bit insulting that 1.0 is here and multiplayer performs so poorly.

I see it's their top priority, which is great (before I get pounced on by advanced members).

Looking forward to it improving in the next patch so hopefully my friends who have already refunded the game will consider giving it another go.

Share this post


Link to post
Share on other sites

So I loaded a new game after the update. And ALL of the little bushes that used to have research nodes on them have not spawned the research. The bushes are there with the holes in for the research but no research.

Is this intended as i cannot see it in the notes?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.