Recommended Posts

 

I can't seem to be able to download the game. There's no option to do so. I've made screenshots of the problem, and what it's supposed to look like. This is however working for my friends. I've tried resetting my downloadcache, and changing my download directory. I've also tried restarting steam and my pc multiple times. When I go to the game  in the steam store, it sais I can't download it because i'm on the wrong platform, which shouldn't be the case, since I'm using Windows 10. I hope to hear from you soon, since I'm very excited to play your game. I have the same problem with Wolfenstein the new order, but all of my other 20 games are just fine.

LOL.png

my friend.png

Share this post


Link to post
Share on other sites

If it says you're using the wrong platform, that means you are using a 32bit OS. Unfortunately Astroneer only supports 64bit, sorry!

If you are actually using a 64bit OS, please report his as bug.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now