Sign in to follow this  
Bluebehir

Broken game is broken. Many issues incurred. Problems listed, and also feedback

Recommended Posts

Summary:
More problems than I can honestly portray. I will do my best to keep an even temper, because I completely lost it tonight while playing.

Description: 
I really want to love this game. I do. I ignore them for the most part, but sometimes they get so big, it breaks the enjoyment. Below is a list of the problems I can remember having in the last two to three days. There were probably more, but once you get a list like this, things get lost. I didn't write them down as they occurred, because I hoped 1.0 would be a polished product. I am sorely disappointed.

Platform:
Steam

Version / Build Number: 
1.0.4.0

Specifications:

  • OS: Windows 10 Home x64 - not sure how to find my version or build number
  • CPU: Intel Core i9-9900 CPU @ 3.60 GHz
  • GPU: NVIDIA GeForce RTX 2080  (Driver version 24.21.14.1163 dated 18/9/18)
  • RAM: dunno how to look it up specifically, but 64 GB
  • Drive: I believe: WDC WDS500G2B0A-00SM50  - at least that's what's listed in my device manager. (It's a 500GB SSD)

-----------------------------------------------------------------------

MULTIPLAYER

Let's start with multiplayer issues first; because 1.0 did not include servers, my friends and I were forced to host and join each other's games. We mostly used one player's game as the game, however, due to internet stability issues, and other (listed below) multiplayer issues, today we moved the host to another player (me) and this showed me more issues we were having.

I hope when servers are introduced that a) these problems are gone and b) are not replaced by new problems. It's like Obi Wan Kenobi. It's my only hope.

- When I play single player I get upwards of 178 fps. As soon as another player joins I get 17-25 fps. Once everyone leaves it returns to 55 fps.

- When I host, and any other player gets in a shuttle or rover, etc, my PC is forced to save the game, and I get a half second lag, or stutter, which totally kills my action when I'm getting 17fps already.

- Terrain issues of every type. Terrain plates misaligned, or quicksand, or just walking or driving along and falling into the earth's core. Some of these disappear after a game close/relaunch. Some disappear after the host closes and reopens the game, but some have even persisted beyond that. In a 3 player instance, some are visible to player 2 but not player 3, but some are visible to both player 2 and 3. None are visible to player 1. One that was visible to player 2 before the host closed and saved, and was still there the next day when we rejoined, and was visible to player 3, (worst case scenario.)  I don't care too much about this getting fixed if it no longer exists in server multiplay - even if we did raise the issue pre-alpha.... (It was in fact the reason we stopped playing in the first place.

- What I've noticed in regard to these sorts of issues is that they build up over time, and restarting your client often fixes it - as if the game is bleeding memory or something. When I mentioned this, my friend noticed that Astroneer does not get recognised as a "game" and does not receive proper treatment in CPU allocation rules, etc. 

- Falling into the core of the planet used to be less of a problem because you used to float back to the surface. Now it dumps you deep within the earth and that's it. If you were prepared for a long walk (but not with tethers, only with oxygen filters) you might have a chance, otherwise you're dead and your gear is lost.

- Sometimes when your friend joins your game, they will join you on whichever planet you're on. Other times, however, they start at your home planet (Sylva) no matter where you are. No consistency has been found, although this problem only occurred twice.

- Sound crossover. Oh my lord. Now, when any of us open the research tab, someone else will hear it from their game as if they opened it themself. Sometimes we all hear it together. It just started happening. Then we noticed we were getting other sounds from each other, like if he ran out of power I might hear that as if I ran out of power.

- Crashing client. This didnt happen to any of us for two days straight, but today one of my friends (joining me as host) crashed 7 times in three hours and yet my other friend (nor I) didn't crash once. It's good to restart and everything because of the desync problems, but we really should have the final say on when.

- Leaving and rejoining when my friend hosts randomly decides if you will keep items in your inventory or not. It also sometimes remembers a starting location for you and sometimes not.
I won't discuss what happened when I took over hosting duties, because that shouldn't be a problem normal people have, but ok. I will. When I took over the save file, I opened up with my friends inventory gear. This only happened once, even though I hosted twice, but we kind of understand what happened here - it has to do with allocation of player numbers. (Player 3 becomes player 1, takes over player 1 inventory, and then the previous player 1 has no save location as player 2, etc)

So that's the multiplayer stuff. Now let me vent all the problems that I have had independently.

-----------------------------------------------------------------------

Vehicles

Vehicles in this game are so frustrating they are what finally drove me to a) quit the game and b) write this post.

I have driven the tractor, the buggy (couldn't have chosen a better name), the medium rover, and the large rover.

I have driven the tractor with no trailer, one trailer, two trailers.

I have driven the medium rover with no trailers, and one trailer.

I have driven the large rover with no trailers, one medium rover as a trailer, one or two trailers, and also two trailers and a medium rover <-- the worst decision I ever made.

I will use the word "truck" to describe my vehicle because it didn't seem to matter which one I was in.

Sometimes when you get into your truck, you cannot drive. I have "fixed" this several ways. Sometimes, the power indicators were "broken" (ie displaying power when the vehicle possibly had none - in fact on one occasion it showed as none to the host). Applying power fixed it in that occasion. On other occasions I was driving with an RTG attached and this could never be the issue.

Sometimes I get back out, and get back in, and sometimes that just works. Other times, it does not. 
Sometimes I get back out, and get back in four or five times, and then it just works. Other times that still doesn't work.

Sometimes I disconnect one trailer. Then the truck will drive. Then I get out and reconnect the trailer, and then sometimes the truck will drive, and other times it will not.

Sometimes i diconnect more than one trailer. (Picture every combination of disconnecting and reconnecting trailers that is physically possible. I have done them all, and all of them have had BOTH results.)

Sometimes you get into the truck, and when it doesn't power (ie, you press W), it rolls backwards down the hill.

Sometimes when you roll backwards down the hill, you run over your own trailer, which causes more problems I care to list. I almost threw my keyboard at my monitor. I DID wake my girlfriend up with my vigorous angry vocals.

Sometimes when you try to recover your truck it bounces into the sky and gets stuck in the air. Then you can't get it to drive.

On one occasion, I had the following setup: Large Rover, one trailer, (one Drill strength 2, one medium battery on the front), one rover seat, one RTG, one large shredder, and one medium storage on the trailer. My friend and I drove to four gateways and the only problem I had was that drilling downward was incredibly easy and drilling up was virtually impossible. Otherwise, zero problems (that we didnt make for ourselves.)
Tonight, however, I flew to Sylvana, and my rig was similar but not the same. Large Rover, trailer, trailer, medium rover. Medium Rover had large storage with two medium storage. The drill bit was drill strength 3 instead of drill strength 2. Here's what happened.
At first, it worked. I could drive, I could tow the trailers, I could drill through hills and trees alike. However, tonight I needed to use V to activate the drill, when prior it worked on C. What the actual heck.
but.
after the first time I got out, things changed. Now I could drive forward, OR I could drill. If I activate the drill I no longer had control of the truck. Not even to turn. Gravity affected it, and momentum affected it, and that is all. So I had to take a run up at the trees, then activate the drill, then turn off the drill, then counter steer, etc.

Also, we worked out that if I angled the camera so that I am looking upward from underneath the truck, I can drill upward. I can't see where I'm going, I can only see the undercarriage. As soon as I bring the camera back up, I drill a big hole in front of me and drive into it, and then I have the same problem I just had.
Whoever thought this was a great system needs their head checked. Sorry for the aggression, but this woke my girlfriend up.

And then, when I got out to do some shredding, that was just the end. I couldn't get the truck to work. I got in an out 19 times, trying to get the truck to tow those trailers, and it wouldn't. I had to tow each one individually to a new location, and then rehitch them. And if I ever had to get out of the truck, which you always have to do for trees that get missed by the drill and you drive onto the trunk, at that point the tree can't be drilled. If you put it in reverse, the trailer backs into a hill and then you can't drive.

Get out of the truck and then you can't drive

I nearly flipped my desk

And then I rolled down a 3-way hill into the vertice at the bottom and rolled over one of the trailers. 53 minutes later, I towed them out one at a time, after hand digging various ramps and such.

There are so many issues in this.

1. All the problems where the truck loses drive control.
2. The drill control.
3. The drill not working simultaneously as the driving
4. Trying to drive forward and you roll backward down a hill
5. Not being able to drive if you are on top of your trailer
6. Not being able to drive if - even if it looks like they are fine - there is some problem with your tyres connection with the soil. 
6a. It's a 6 wheeler. It doesn't need 6 wheels on the ground.
7. Connecting and disconnecting trailers to make them 'movable objects'
8. Not being able to move a trailer by any means if you can't get the cables to connect
9. Those cables just refuse to connect. They are cables. They have ONE JOB. Connect to the plug. It shouldn't be so hard. They should do it systematically. You grab one, it hooks into the closest plug. Why do we have to struggle with them SO MUCH?

Driving trucks is meant to be a major part of the fun in this game. It was so incredibly, unbelievably, unfathomably, unforgivingly frustrating. Worse than pre-alpha.

And to make this issue twice as bad, when you are hosting and your FRIEND is having truck trouble? Every three seconds you get "saving game" stutters. If you're having truck troubles at the same time, it's enough to lose your sanity.

Another problem we had was when you connect a trailer, then get in the truck to drive off, the trailer becomes unmovable, the cable extends to its limit, then disconnects. Reverse up, reconnect, drive off, disconnect, reverse up, reconnect, drive off, disconnect, reverse up, connect using the other cable (ie instead of using the cable from the truck into the trailer, go the other way - use the trailer into the truck) - oh wait, that works. What?

Another problem when I was getting in and out of trucks as often as I had to tonight, sometimes I press F and enter the truck. Other times I press F and pick up the seat. Thinking on it now, maybe I held shift, but if I really wanted to pick up the seat, I click the mouse. Not Press F. Pressing F gets in the truck, not picks up the seat. I mean, oh MY GOD.

I really want to reiterate that driving with a drill on it needs a new system of drill control. You need to be able to control it AND see where you're going. Please.

Another problem, when you get out of the rover seat you get flung into the sky. Most of the time you land on the seat and you're ok, but occasionally it kills you. And it shouldn't need to do this at all. Just put me next to the truck. I don't have an ejector seat or a cannon. 

Another problem I touch on later on is when you have a (large rover) with a drill, and you drive through resources, and it harvests those resources, it places it on every location it can except storage. It's in the name: Storage. It should be where those resources go.
I expect it to prioritise like this:
- Medium storage placed on large storage
- Medium storage placed on back of vehicle
- Medium storage placed on any trailer vehicles
- Medium storage placed on front of main vehicle
- Medium storage placed on end of rear vehicle
- Anywhere else.

The game seems to think the reverse is better. I've even seen it DROP resources rather than place it on medium storage.

SHUTTLES

Still coming under vehicles, so not a new section, but a subheading

I built a large shuttle. I placed a rover seat on the second rung from the top. I got into it. I got out of it. It puts me on top of the shuttle. I almost died getting down.
I moved the seat to the fourth rung from the top (ie the bottom rung), and got in. When I got out, it sent me to the earth's core.

What am I supposed to do with my small shuttle and my medium shuttle once I build my large shuttle? I tried to shred, too big. I even packed it. Too big.
Bury it? I mean, really?

-----------------------------------------------------------------------

BUILDINGS

In my single player game, when I press F for my researching table, the display flickers up, but then it goes black. I close it, reopen it, it flickers up, and then it goes black. Eventually I do it enough that I can read each piece of information that I'm looking for.

Cable plugs. I touched on this for vehicles, but they really deserve their own category. Why oh why will they not snap to the nearest plug? They flicker around like an unhooked hose with too much water pressure. You just can't get them to click into place. And then when you least expect it to work, it just does.

Other times, you can't for the life of you click A into B. It looks like it reaches, even goes past. It has a good angle, almost straight, but it just won't go in. But B goes straight into A.

Sometimes it feels like two way cables are one way cables. On that note, why do one way cables even exist? 

I had one occasion when A wouldn't go into B, B wouldn't go into A, even though they were right next to each other, and as straight as a pin. I had to move one of the tables to make it work.

Cables, man. They have one job. They really don't have multi function options, just cable into plug. Why doesn't it just work?

The Large Storage colour system is horrible. The dark grey looks so bleak and hides darker resources such as zinc or carbon, especially in dim light after dusk.

And then the medium storage has the same colour scheme making the problem twice as bad. Please make the bases white again.

Speaking of medium storages, why are they not the default deposit location?
If I place a medium storage on a building, say the smelter, and then place a laterite on the smelter itself, it will ALWAYS dump straight onto the one slot on the other side, rather than place it on the medium storage.  So frustrating. I refer you to the last point of vehicles, also. 

Soil Centrifuge
Sometimes the canister outline disappears and you have to place the canister manually, instead of just single clicking the outline.

Trade Platform
The trade platform does not automatically pick up and place back down scrap as you scroll through the options. The printers can do it for variable resources. The trade platform only has to deal with scrap!

Having said that, I have seen one occurrence with a problem with the printers picking resources: If you have the medium printer and the small printer both on the same Large Platform B, and both printers need resin for their print, the medium printer seems to take the resin in priority over the small printer, even if you're trying to print from the small printer.

Clicking resources onto buildings 
This has been a problem since pre-alpha, how is this still in the game? Why is it so hard sometimes, to place a resource onto a building?
You move it across, it looks like it will snap to point, you click, and it drops on the ground. Or it just moves to seven different snap points instead of the one you're clearly trying to highlight...

Smelting Furnace
Three problems I've seen so far with the smelter.
1. There was a partial smelt left on the nozzle, and when it came off it became a permanent physics object that could not be interacted with
2. A partial smelt that landed on a medium storage that could not be removed
3. On several occasions smelts that landed under a medium storage instead of ON the medium storage, taking my point even one step farther. 

Medium Shredder
What's the point of a medium shredder? Genuinely? It shreds only the tiniest things. Does it have better scrap output or anything? Because otherwise, what's the point of a medium shredder?

Extra Large Platform A and B
This is really more of a feedback than a problem, but I was seriously disappointed with their versatility options. They seemed SO limited, given they are at the top of the platform food chain.
I was disappointed with B, firstly, because it wasn't flat. But at least it still has some purpose.
I was extremely disappointed with A because it seems that the only value added was with placing an Extra Large Storage, which I haven't even built yet because it's all single and huge and angular - making it (seemingly) hard to access.

I really hoped that I could put two buildings on ELP A and those two buildings would interact with each other, but they did not. Like, if I put a soil centrifuge next to a smelter, I wanted the smelter to take the clay from the soil centrifuge..... but nothing worked at all, and if you have two buildings on it there's no room for medium storages. Also, two large storages on it just get in each other's way once you put medium storages on. So, huge disappointment.

------------------------------------------------------------------------------

OBJECTS

Tethers
Sometimes when you place a tether it just disappears
It's possible to place two tethers within  each other.
When you're walking you have no idea if a placed tether will place behind you or in front of you. Consistency is key.

Beacons
I haven't used beacons as much as I would have liked, but typically they're really hard to see, and this is both at close and short range.
Yet, you can see your beacons on another planet just fine
Corpse beacons? Don't even get me started. You need some kind of directional beacon to find your corpse, please.

Backpack
Last night when I was in my solo game, my backpack printer just started flickering, and wouldn't stop - no matter how many times I opened or closed it or changed print choice.

Small Wind Generators
No matter how you try, you cannot line up the cable/plugs on these things. You can't see how much you're turning it and half the time after you put it down if you pick it up again it just resets the position. Huge time waster.

Small Generator
Same problem as above, but also sometimes when you press F to turn it on, you pick it up instead. I want click to be my pickup, shift click to be pick up to backpack, and F to be my activate key. Please don't mix the three by having shift F the same as shift click.

Extenders
Why the heck are they one way transfers? I wasted so much power because I didnt recognise that quickly

Winch
Ignoring the difficulty of working out how to connect a winch to anything - it runs contrary to all other items in the game, and there is NO clue whatsoever - sometimes it also won't let go.
And trying to pick up a winch when it's connected to something? Well I hope you didn't spend twelve minutes lining that huge solar panel JUST perfectly.......

----------------------------------------------------------------------------

GENERAL ISSUES

Walking on the ground can fling you into the sky. I can't work out why. Sometimes it happens even in your base. It usually flings you high enough that you die.
On one occasion it flung me INTO ORBIT, and I had to try and navigate a good place to die.
I originally assumed I had walked on something bad, like a lashleaf. But this proved incorrect.
Then I assumed maybe I had walked onto ground that once held those vents (maybe I dug it, it exploded, but the effect remained on the soil.)
This was not the case.
Maybe there was something just UNDER the soil. Also not the case.

It is absolutely, completely, absurdly, random. It has happened to me and my friends. It has happened in singleplayer and multiplayer.
Please do NOT advise me this is a feature. If it is a feature, please kindly remove it.

Detritus Platforms
Love them. Hate them. Can't trash em. Can't destroy em. Can only bury them. I hate them. I love finding stuff on them, but I hate the thing itself.
Let us throw them into large shredders PLEASE
Also, always medium B. No variety at all!

 

Camera Viewpoint
So I have a few issues here.
1. Sometimes it just changes for no reason. I set it, I walk around, I don't do anything outrageous, it changes viewpoint. I change it back. Urgh.
2. If i am in a confined space it has no idea what to do. If I am digging in a confined space I always end up digging downward when I dont want to.
3. Windowed fullscreen - if I touch the edge of my screen, especially if I am digging, it spirals out of control. 
4. I like to scroll out, fully zoomed. I constantly have to zoom out again, and again, and again, and again, and again, and again, and again, and again.

Please give us some way to set a preference or something? Battling with the viewpoint gives me complex issues, and a sore mouse hand.

Sound Issues
I mentioned in the multiplayer section some sound issues (sound crossover), but I have also experienced other sound issues.
One memorable problem occurs in caves, where you hear a sound, say in your left ear, but if you turn a full circle you still always hear it in your left ear. Directional sound is broken.
I use Bose QC25's (they are not wireless). It's not the headphones.

I've also noticed volume issues with some sounds coming in much louder than usual in niche situations (which I can't begin to outline)

 

That's all I can recall for now. Please appreciate that I put a lot of time and effort into this.

Share this post


Link to post
Share on other sites

I want to add an extra problem that I have encountered. I was in a subterranean terrain, and I was digging my way up a mountain by smoothing a trail along the ridge line.

I got to a certain point and I hit an invisible wall. I had already been past this point prior, and come back down. I managed to move sideways until the wall was gone, and proceeded past the point. On a future journey, I encountered the same invisible wall, but also a second invisible wall just beyond. In both cases I had to move sideways until I was past it.

I have only encountered this problem in EXACTLY that location. (The mushroom cavern on Sylva)

Bizarre. Not game breaking, but when you add it to the list above........

 

Also, I need to edit a line about the FPS, I want to say "when I play single player OR JOIN A MULTIPLAYER GAME, I get upwards of 178fps...."

Edited by Bluebehir

Share this post


Link to post
Share on other sites

I need to expand on two things, and add one more.

Debris

It is so hard to transport debris. It has no way to click to socket, and you can't group things like that together. You have to carry them all independantly, or............

put the shredder on the truck and bring the shredder to the debris.

A medium rover can only take a medium shredder but what is the point of that? You can only scrap half the debris, and you have to come back with a large rover and a large shredder anyway.... And don't forget that the scrap won't end up on your medium storage, it will be on the front of your rover, or next to your seat, or on the ground instead.

Why put debris in the game that can't be shredded? Just give us an extra large shredder.

So the two things I need to expand on are the Extra Large Platform B and Extenders.

What I said about ELP B...

"I was seriously disappointed with their versatility options. They seemed SO limited, given they are at the top of the platform food chain.
I was disappointed with B, firstly, because it wasn't flat. But at least it still has some purpose"

What I should have said next was... but it only has 2 port connectors and a bank of those above another, so if you use them for medium storage, it really gets quite cluttered.

You can't use them for any functional buildings, like printers, because of the angle, height, and other obstacles on the actual platform. You can't put 4-point buildings on them at all - which would have made a nice bank of functional buildings.

you can put batteries on them, but no better than anywhere else. Same goes for wind turbines, which are no better or worse. Solar panels might be better, if you angle the platform always into the sun, oh wait, you can't.

The versatility of that building is seriously lacking.

 

As for extenders what I said was 

"Why the heck are they one way transfers? I wasted so much power because I didnt recognise that quickly"

This problem is exacerbated because sometimes you can't extend the cable the way you need to, and you think - like everything else - it's ok just to snap it in reverse.

If it doesn't fit one way and does fit the other way, what the heck is happening with the cable system? And then you throw a one way power cable into the mix.

When you combine a feature with a problem it becomes a confusing problem :(

 

As you can tell, this is burning me up. I really want to love and play this game, but I have to quit for my own health.

Share this post


Link to post
Share on other sites

Damn...a lot of these problems I have noticed as well...maybe not as often as you but...let’s not forget that sometimes after making a 25-30 HOUR SAVE you realize that gateway chambers just don’t fucking work...which impedes actual progress...which could possibly be more frustrating than a lot of these problems depending on the time spent in the save.

Share this post


Link to post
Share on other sites

If you want to get this stuff solved, you are unfortunately going to have to break it up into a hundred separate posts for each separate problem. It's really hard for developers to respond to a wall of issues like this.

Lots of the problems with mating of cables is that you have to see the front face of an object to plug into it. And unless your camera is positioned between two widely spaced source and target plugs, this is almost always impossible because one or the other is hidden from view.

The plugs need to be "magnetic attractive" with a huge sphere around them (1+ meter radius) to allow for sloppy connections even if you can't directly see the front face of the target. The only time this should not occur is if two target plugs are near each other, and then the radius is reduced to be split at half the distance between the two adjacent target plugs.

I have found plugs won't mate if the two connectors are within about 0.5 meters of each other. Apparently there is a bounding box around each platform that is bigger than the plug itself and blocks mating.

Share this post


Link to post
Share on other sites

I found out by experience that for a 100% satified and guaranteed plugs connection one must point the mouse dot at the yellow part of the receiver plug.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this