RabidFlea

Terrain tool constantly stutters.

Recommended Posts

Hi there. Let me start by saying I've played Astroneer for quite a while and I very much enjoy the game. On the release of 1.0, I was very eager to jump in and start exploring the new worlds and new changes that were released with the update, however I have run into a very peculiar issue. All the time, no matter what conditions I am in in the game, when I am attempting to mine, flatten, or construct new terrain using my terrain tool, the tool, as well as my character, stutters very badly. It is almost as if I am rapidly clicking my mouse to try and perform tasks. I've tried a lot to fix this issue, change graphical settings (my computer is not the best so I get a fair amount of frame rate lag, I thought the game may be throttling itself by slowing down some operations like mining), I've rebound my left click button to a key on my keyboard to ensure it isn't hardware related, I've uninstalled and reinstalled the game, restarted my computer, everything I can think of to resolve the issue and nothing helps. What's more, my little brother, having a fairly better computer than me, doesn't get this issue when he is trying to play co-op with me on my world. Anything anyone can offer that may help this issue? is anyone else having this problem? Thanks, hopefully this will resolve soon because it may not be game breaking, but it slows down all of my resource gathering and makes mining into a mountain nearly impossible with the ground being harder. Thanks for your time.

Share this post


Link to post
Share on other sites
14 minutes ago, jason allan sander said:

i Take it the two of you are playing the steam version cause that is a bug with the steam version only

I Sure am.

Share this post


Link to post
Share on other sites

I have this same bug. Nonexistent pre 1.0. I've had to stop playing all together because it makes mining anything 3 times longer/harder.

Share this post


Link to post
Share on other sites

I have the same issue; it seems to be less pronounced the further the terrain cursor is from the player, though. I think it might be caused by the terrain recalculations interfering with where the player is standing. I've found that flattening is a lot smoother, and causes less jitters in the player.

Share this post


Link to post
Share on other sites

I get the same bug on my Laptop, the character is constantly replaying the dig animation causing it to stutter and you can hear the sound from the tool that it is turning on and off i rapid successions. My Desktop which is much more powerful does not have this issue.

Laptop spec:

i7-6500U 2.5GHz dual core with HT

12GB ram

GTX 940M 2GB dedicated ram

Share this post


Link to post
Share on other sites

+1

I've tried all sorts of screen resolutions to try to resolve this out of game.  All my settings are Low in game. 

Laptop I'm playing on is 

OS Name    Microsoft Windows 10 Home
Version    10.0.17134 Build 17134
Other OS Description     Not Available
OS Manufacturer    Microsoft Corporation
System Name    DESKTOP-SL0PDME
System Type    x64-based PC
System SKU    Z6L01EA#ABU
Processor    Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz, 2904 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date    American Megatrends Inc. F.10, 19/04/2017
SMBIOS Version    2.8
Embedded Controller Version    9.40
BIOS Mode    UEFI
BaseBoard Manufacturer    HP
Secure Boot State    On
PCR7 Configuration    Elevation Required to View
Windows Directory    C:\WINDOWS
System Directory    C:\WINDOWS\system32
Boot Device    \Device\HarddiskVolume1
Locale    United Kingdom
Hardware Abstraction Layer    Version = "10.0.17134.556"
Installed Physical Memory (RAM)    16.0 GB
Total Physical Memory    15.9 GB
Available Physical Memory    8.19 GB
Total Virtual Memory    18.3 GB
Available Virtual Memory    7.39 GB
Page File Space    2.38 GB
Page File    C:\pagefile.sys
Kernel DMA Protection    Off
Virtualisation-based security    Not enabled
Device Encryption Support    Elevation Required to View
Hyper-V - VM Monitor Mode Extensions    Yes
Hyper-V - Second Level Address Translation Extensions    Yes
Hyper-V - Virtualisation Enabled in Firmware    No
Hyper-V - Data Execution Protection    Yes
Name    Intel(R) HD Graphics 620
PNP Device ID    PCI\VEN_8086&DEV_5916&SUBSYS_82C1103C&REV_02\3&11583659&1&10
Adapter Type    Intel(R) HD Graphics Family, Intel Corporation compatible
Adapter Description    Intel(R) HD Graphics 620
Adapter RAM    1.00 GB (1,073,741,824 bytes)
Installed Drivers    C:\WINDOWS\System32\DriverStore\FileRepository\ki120732.inf_amd64_63d56bbca5d03c0a\igdumdim64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\ki120732.inf_amd64_63d56bbca5d03c0a\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\ki120732.inf_amd64_63d56bbca5d03c0a\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\ki120732.inf_amd64_63d56bbca5d03c0a\igd12umd64.dll
Driver Version    21.20.16.4590
INF File    oem38.inf (iKBLD_w10_DS_B3 section)
Colour Planes    Not Available
Colour Table Entries    4294967296
Resolution    3840 x 2160 x 59 hertz
Bits/Pixel    32
Memory Address    0xDB000000-0xDBFFFFFF
Memory Address    0x70000000-0xDFFFFFFF
I/O Port    0x0000F000-0x0000F03F
IRQ Channel    IRQ 4294967287
Driver    c:\windows\system32\driverstore\filerepository\ki120732.inf_amd64_63d56bbca5d03c0a\igdkmd64.sys (21.20.16.4590, 10.55 MB (11,060,184 bytes), 20/03/2017 12:44)
Name    NVIDIA GeForce 940MX
PNP Device ID    PCI\VEN_10DE&DEV_134D&SUBSYS_82C1103C&REV_A2\4&3537B846&0&00E0
Adapter Type    GeForce 940MX, NVIDIA compatible
Adapter Description    NVIDIA GeForce 940MX
Adapter RAM    (2,147,483,648) bytes
Installed Drivers    C:\WINDOWS\System32\DriverStore\FileRepository\nvhm.inf_amd64_9172c4e962e5b3ee\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvhm.inf_amd64_9172c4e962e5b3ee\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvhm.inf_amd64_9172c4e962e5b3ee\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvhm.inf_amd64_9172c4e962e5b3ee\nvldumdx.dll
Driver Version    24.21.13.9836
INF File    oem44.inf (Section030 section)
IRQ Channel    IRQ 4294967289
Driver    c:\windows\system32\driverstore\filerepository\nvhm.inf_amd64_9172c4e962e5b3ee\nvlddmkm.sys (24.21.13.9836, 16.40 MB (17,200,384 bytes), 04/07/2018 02:39)

https://i.imgur.com/5VZ32ol.mp4

Share this post


Link to post
Share on other sites

have you update your g force drivers  and the g force  experince app  on  pc 

Share this post


Link to post
Share on other sites
On 2/15/2019 at 8:38 PM, xbox said:

have you update your g force drivers  and the g force  experince app  on  pc 

Yes all my drivers are up to date and I have tried different screen resolutions also.

 

How do I get the windows store version without paying for it.  This seems to not have the issue and I already paid for the version in steam store which is unplayable.

Share this post


Link to post
Share on other sites

The chance of you phasing through the ground also increases when the terrain tool stutters, which makes this is even more annoying.

Share this post


Link to post
Share on other sites

I also have this issue. Just installed the latest driver, didn't resolve the issue. Below are my system specs, I don't have another computer to try it on. I also want to add that the game doesn't stutter, just the animation and actual tool/modification process stutters.

System:

Mouse/Keyboard, Steam,

Core i7 5500U @ 2.4 GHz CPU,

Nvidia 930m GPU with 2 GB video memory,

12 GB system memory.

Share this post


Link to post
Share on other sites
On 2/15/2019 at 2:38 PM, xbox said:

have you update your g force drivers  and the g force  experince app  on  pc 

it's not a driver issue the windows store version doesn't have this problem it's only the steam version that does.

And i have both steam and windows store versions. i have ran both versions on the same computer

Edited by jason allan sander

Share this post


Link to post
Share on other sites
On 2/16/2019 at 9:35 AM, PoxyLoxy said:

How do I get the windows store version without paying for it.  This seems to not have the issue and I already paid for the version in steam store which is unplayable.

You can't.

If you want the Windows version, you'll have to pay again.

Share this post


Link to post
Share on other sites

It actually still happens but so far I've only encountered it when I was very deep down in a rather big cave.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now