JustInsane3014

Xbox One and Windows 10 crossplay not working

Recommended Posts

Whenever my friends join me, they get a message saying something like "Failed to connect to host" or "Could not find session." I can join their games just fine, but they cannot join me. I am on the Windows 10 store version, and my friends are on Xbox One.

Share this post


Link to post
Share on other sites
On 2/9/2019 at 5:09 AM, JustInsane3014 said:

Whenever my friends join me, they get a message saying something like "Failed to connect to host" or "Could not find session." I can join their games just fine, but they cannot join me. I am on the Windows 10 store version, and my friends are on Xbox One.

This sounds like a firewall issue, but there's so many variables it's difficult to troubleshoot...

Share this post


Link to post
Share on other sites
15 hours ago, Blind Io said:

This sounds like a firewall issue, but there's so many variables it's difficult to troubleshoot...

Yeah this screams like a firewall, antivirus or port forwarding issue. 

Try disabling your firewall and antivirus. 

I have no idea which ports need to be open, but maybe someone more knowledgeable can chime in. Theres probably a forum somewhere for Windows/XB1 that has what ports should be open for cross-play. 

A possible solution (I highly do not recommend leaving this on) is to put your PC in the ‘DMZ’ if its an option on your router. This will open the flood gates to your PC and likely solve port forwarding issues, but will also make your PC extremely vunerable to malicious attacks.

Share this post


Link to post
Share on other sites
16 hours ago, Blind Io said:

This sounds like a firewall issue, but there's so many variables it's difficult to troubleshoot...

I’ll try disabling my firewall next time I play. Thanks for the suggestion!

Share this post


Link to post
Share on other sites

I’ve done all these fixes and non of the are working. 

Xbox one invite to Win 10 in same network. Vise versa

PLEASE FIX THIS ISSUE!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites
11 hours ago, JustInsane3014 said:

I’ll try disabling my firewall next time I play. Thanks for the suggestion!

 

On 2/14/2019 at 6:10 PM, Blind Io said:

This sounds like a firewall issue, but there's so many variables it's difficult to troubleshoot...

We shouldn’t  be trouble shooting shit here. 

We are not the developers. If they are going to preach cross play multiplayer blah blah and how awesome it will be to play with your friends then for fucks sake make that shit work before you put on the shelf. 

Share this post


Link to post
Share on other sites
7 hours ago, Gonzo said:

 

We shouldn’t  be trouble shooting shit here. 

We are not the developers. If they are going to preach cross play multiplayer blah blah and how awesome it will be to play with your friends then for fucks sake make that shit work before you put on the shelf. 

Crossplay worked fine for me last night. I was able to connect to a game, hosted on a Windows 10 PC, with my XB1X.

The problem very well could be on your end. 

It is extremely common in PC gaming to have MP connection issues. It has become increasingly common to have MP connection issues on consoles of late as well. Unlike console gaming, in PC gaming, there is a vast amount of different hardware out there. Sometimes hardware doesn’t play nicely together. The developers only have so many test rigs in the office to run different configurations.

It is often useful for developers and the community trying to help you if you provide more info like what specs you have. 

It is extremely likely that your issue is a port issue. The ports used to connect for crossplay are likely closed or blocked by something. This is almost always your firewall (windows and router), antivirus, and certain ports not being ‘forwarded’. Could be you just need to update your router firmware. 

95%+ of the time I have found it to be a port forwarding issue. 

Is there any other crossplay games that you can try? This would verify the issue is with Astroneer and not a setting on your end. 

The community around this game is trying to help you enjoy it. Blowing up here on the forums and using vulgarity, likely isn’t going to get you very far. Good luck though! 👍

 

 

Share this post


Link to post
Share on other sites
1 hour ago, CaptKaspar said:

Crossplay worked fine for me last night. I was able to connect to a game, hosted on a Windows 10 PC, with my XB1X.

The problem very well could be on your end. 

It is extremely common in PC gaming to have MP connection issues. It has become increasingly common to have MP connection issues on consoles of late as well. Unlike console gaming, in PC gaming, there is a vast amount of different hardware out there. Sometimes hardware doesn’t play nicely together. The developers only have so many test rigs in the office to run different configurations.

It is often useful for developers and the community trying to help you if you provide more info like what specs you have. 

It is extremely likely that your issue is a port issue. The ports used to connect for crossplay are likely closed or blocked by something. This is almost always your firewall (windows and router), antivirus, and certain ports not being ‘forwarded’. Could be you just need to update your router firmware. 

95%+ of the time I have found it to be a port forwarding issue. 

Is there any other crossplay games that you can try? This would verify the issue is with Astroneer and not a setting on your end. 

The community around this game is trying to help you enjoy it. Blowing up here on the forums and using vulgarity, likely isn’t going to get you very far. Good luck though! 👍

 

 

I’ve tried games like Forza Horizon 4, Rocket League, and Minecraft and all of those work fine, it’s probably just a problem with astroneer.

Share this post


Link to post
Share on other sites

I discovered that my network settings were preventing part chat ect. My icon showed disconnected. 

Did evrything to get that fixed. 

Still non-resolve in playing multiplayer tho.  

Share this post


Link to post
Share on other sites

Still trying to work this out. 

Do my versions of the game have to be the same in win 10 and Xbox 1?

win 10 is version 0.10.5.0

xbox is 1.3.0

fresh install from Xbox store on both platforms.  

Im able to see my co-op game hosted on win 10 from Xbox 1 astroneer menu but if I click join or accept any form of invite it’s the same “unable to find session”

 

how are we supposed to have matching versions if that’s not available?

Edited by Gonzo

Share this post


Link to post
Share on other sites
1 minute ago, Gonzo said:

Still trying to work this out. 

Do my versions of the game have to be the same in win 10 and Xbox 1?

win 10 is version 0.10.5.0

xbox is 1.3.0

fresh install from Xbox store on both platforms.  

Im able to see my co-op game hosted on win 10 from Xbox 1 astroneer menu but if I click join or accept any form of invite it’s the same “unable to find session”

 

how are we supposed to have matching versions if that’s not available?

Go into the downloads section of the microsoft store on your PC and click “Get Updates”

Share this post


Link to post
Share on other sites
8 minutes ago, JustInsane3014 said:

Go into the downloads section of the microsoft store on your PC and click “Get Updates”

No, that’s been done. Win 10 version is newer than xbox1. Both are new downloads.  🤷🏼‍♂️

Share this post


Link to post
Share on other sites
3 hours ago, Gonzo said:

Still trying to work this out. 

Do my versions of the game have to be the same in win 10 and Xbox 1?

win 10 is version 0.10.5.0

xbox is 1.3.0

fresh install from Xbox store on both platforms.  

Im able to see my co-op game hosted on win 10 from Xbox 1 astroneer menu but if I click join or accept any form of invite it’s the same “unable to find session”

 

how are we supposed to have matching versions if that’s not available?

This shouldn’t be the case.

What ‘store’ did you purchase Astroneer from on the PC? 

The Windows Store and XB1 should both be 1.0.3.

Steam should be 1.0.4.

I was told in a different post that the game files that are submitted to the Microsoft for both the Windows Store and XB1 are identical. There shouldn’t be a version difference there.

Steam users got a newer update, but it is my understanding that this is because Steam has little to no verification of updates before they're released. 

Version 0.10.5.0 is a pre 1.0 release version. No idea how youre stuck on that, but that is very likely an issue on why you can’t crossplay. 

Hopefully all the platforms are updated to the same version soon. Im led to believe this is a hangup with MS and not the folks at Astroneer. 

*edit* i did not verify version numbers today if a patch was released. But as of yesterday my Microsoft store and XB1 versions were both 1.0.3

Edited by CaptKaspar

Share this post


Link to post
Share on other sites
1 hour ago, CaptKaspar said:

This shouldn’t be the case.

What ‘store’ did you purchase Astroneer from on the PC? 

The Windows Store and XB1 should both be 1.0.3.

Steam should be 1.0.4.

I was told in a different post that the game files that are submitted to the Microsoft for both the Windows Store and XB1 are identical. There shouldn’t be a version difference there.

Steam users got a newer update, but it is my understanding that this is because Steam has little to no verification of updates before they're released. 

Version 0.10.5.0 is a pre 1.0 release version. No idea how youre stuck on that, but that is very likely an issue on why you can’t crossplay. 

Hopefully all the platforms are updated to the same version soon. Im led to believe this is a hangup with MS and not the folks at Astroneer. 

*edit* i did not verify version numbers today if a patch was released. But as of yesterday my Microsoft store and XB1 versions were both 1.0.3

I could be wrong on version on pc, im going with what im reading at the bottom of the game screen.
UPDATE:  I installed astroneer on a 2nd xbox in the same house, hard wired and wireless I am experiencing the same results.
I think I'm done for the day.  We shouldn't have to cope with this to just have some fun.  :/

Share this post


Link to post
Share on other sites

We were able to finally get the two xboxes to multiplayer lastnight after rebooting both , host was on "home" xbox.
So some success at least.  Had fun!

Share this post


Link to post
Share on other sites
2 hours ago, Gonzo said:

We were able to finally get the two xboxes to multiplayer lastnight after rebooting both , host was on "home" xbox.
So some success at least.  Had fun!

I was able to play crossplay a game last night. I hosted the game on Windows 10 PC (version 1.0.3) with a player 1/3 of the US away using a XB1. Only issue we ran into was a CTD that erased about an hour of progress because neither of us had saved during that time. 

Performance hosting on a Windows 10 PC was fantastically better than hosting on XB1X. 

i5 9600k, Nvidia Titan XP, 16gb Ram, Windows 10 home. Game installed on NVMe M.2 Samsung 850. 

XB1s are pretty wimpy machines and even the XB1X (the most ‘powerful’ gaming console) is pretty weak in comparison to most ‘gaming’ PCs. Im curious to see how they optimize and resolve the performance for XB1 hosting. XB1s have pretty weak processors and aren’t well suited for hosting servers. 

Share this post


Link to post
Share on other sites

Still unable to host or join a game from Win 10 machine to xbox or vs versa.
Had higher hopes with 1.6 patch....

:(

Share this post


Link to post
Share on other sites
16 hours ago, Gonzo said:

Still unable to host or join a game from Win 10 machine to xbox or vs versa.
Had higher hopes with 1.6 patch....

:(

 

Sorry to hear that 😔

Cross-play has been working for me hosting on a windows 10 machine since 1.0.3 🤷‍♂️

Accounts are ‘adult’ and not ‘child’?

Sorry im running out of ideas if you did all the above suggestions and they didnt work

Share this post


Link to post
Share on other sites

it seems to be an issue with the firewall policy i did this and i worked for me .

its kinda like putting your fire wall down but only while you're playing just remember to do the second part when your done to put it back up

to turn on astroneer mulitplayer

part 1.

open command prompt

enter the command below

netsh advfirewall set currentprofile firewallpolicy allowinbound,allowoutbound

part 2.

when you're done playing

repeat but enter this command instead its kinda like putting your fire wall

netsh advfirewall set currentprofile firewallpolicy blockinbound,allowoutbound

 

i hope this helps it worked for me 

Edited by robert gomez

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now