Sign in to follow this  
Uriel-238

Medium rover won't go forward with re-bound forward key

Recommended Posts

 I am playing the steam version of the game on a PC with Windows 7 using a mouse and keyboard.

I am left-handed and use my system in a left-handed configuration, as such, I have my controls bound to the number pad, accordingly. But while my Astroneer will walk forward with <Num8> (as configured) my medium rover will not, rather it likes to move forward with <W>. Neither <Num2> nor <S> will allow the rover to back up, though I can move it the other way by moving the seat in the other direction and going forward.

Is it part of the game that the rover is so difficult to maneuver?

Anyway, otherwise enjoying the snot out of the game.

Edited by Uriel-238
Trying to fix markup

Share this post


Link to post
Share on other sites
2 hours ago, Uriel-238 said:

my Astroneer will walk forward with <Num8> (as configured) my medium rover will not, rather it likes to move forward with <W>. Neither <Num2> nor <S> will allow the rover to back up, though I can move it the other way by moving the seat in the other direction and going forward.

You may want to edit the "GameUserSettings" file. Look for "VehicleThrottle", just change the Key=W to Key=NumPadEight and Key=S to Key=NumPadTwo. Save it.

But be warned, edit this file at your own risks. You might want to make a backup copy just in case.

Share this post


Link to post
Share on other sites

Thanks! Making the changes worked perfectly!

For other users, my path to GameUserSettings.ini was: C:\Users\#USERNAME#\AppData\Local\Astro\Saved\Config\WindowsNoEditor\GameUserSettings.ini

Share this post


Link to post
Share on other sites
On 9/20/2018 at 8:31 AM, Uriel-238 said:

Thanks! Mxwaking the changes worked perfectly!

For other users, my path to GameUserSettings.ini was: C:\Users\#USERNAME#\AppData\Local\Astro\Saved\Config\WindowsNoEditor\GameUserSettings.ini

 

On 9/20/2018 at 8:31 AM, Uriel-238 said:

Thanks! Making the changes worked perfectly!

For other users, my path to GameUserSettings.ini was: C:\Users\#USERNAME#\AppData\Local\Astro\Saved\Config\WindowsNoEditor\GameUserSettings.ini

For me it dosen't work. I edit the file but no change. I can go backward with key: S, I can turn right with key D and other. But can't mouve forward in vehicul with key Z.(AZERTY keyboard) Help my astroneer. :-)

Share this post


Link to post
Share on other sites
6 hours ago, Neil amstrong said:

For me it dosen't work.

So if you press "W", does it move forward? If it does, you didn't change the right one.

In the GameUserSetting.ini file, look for this line.

AxisMappings=(AxisName="VehicleThrottle",Key=W,Scale=1.000000)

Then change it to Key=Z instead of Key=W. Like in the example below.

AxisMappings=(AxisName="VehicleThrottle",Key=Z,Scale=1.000000)

 

 

Share this post


Link to post
Share on other sites

Hello,

I've tried your solution but every time I restart the game it reset the command, so it doesn't work, anybody have another solution ?

Share this post


Link to post
Share on other sites
On 9/9/2018 at 12:15 AM, Mak-a-Face said:

You may want to edit the "GameUserSettings" file. Look for "VehicleThrottle", just change the Key=W to Key=NumPadEight and Key=S to Key=NumPadTwo. Save it.

But be warned, edit this file at your own risks. You might want to make a backup copy just in case.

I know I post this post a lot of time after the submiting of other (I am sorry if my english is bad, I am frensh) but I don't have the file "saved"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this