jbundles

Game will only launch on secondary monitor

Recommended Posts

Since the 5/8/18 update, the game will only launch on the secondary monitor on the PC version of astroneer running windows 10. Attempted unsuccessfully to switch the game to windowed mode to switch monitors, as well as restarting the game several times. in order to get the game to launch on the primary monitor, I had to disable the secondary monitor, start the game, then re-enable the secondary monitor. 

Share this post


Link to post
Share on other sites

Same here, have 3 Monitors. Since patch 0.7.0, Astroneer starts on Monitor 2 (-> attachment). I can switch to windows mode inside the game, move the windows to the first screen und than change back to fullscreen. but on next start Astroneer ist back on monitor 2.

Would be nice if I could choose the monitor in the settings.

snip_20180509225851.png

Share this post


Link to post
Share on other sites

Same here - Windows 8.1, game version alfa 0.8.0.0.
Game lauch every time on second (not main) monitor.

Share this post


Link to post
Share on other sites

I would like to see the option to pick a default display for every app/program on every device

This is something that should be higher up the chain than the app itself, the OS should keep up with things like this so individual apps didn't have to all reinvent that wheel individually

BUT because they don't...

Share this post


Link to post
Share on other sites

Here's the workaround from Discord;

So I was having the 'launching on wrong screen/monitor' bug for the past few days, and while searching this channel i noticed that others here have had the issue occasionally too. But i think i found a permanent (-ish?) workaround that worked for me, so I'm gonna share it in case it helps anyone else.

 

1. Make sure your intended display is set as the primary monitor in your display settings. (right-click desktop, "Display Properties", click the monitor you want, scroll down and 'Make this my main monitor')

2. Use Win+P to select "PC screen only"

3. Do that again to go back to "Extend"

4. Profit. 

 

After I did that, my game launched on the correct screen every time afterwards. Hopefully it works for others too. Not sure why it happens, I can only think of two things. I recently moved my desk around so I re-plugged all my screens. Or it was my video drivers recently updating. 

Share this post


Link to post
Share on other sites

Still a problem in rev 1.0.7.0

Blind Io's fix didn't work for me. I want Astroneer to start on monitor 2 which is set as my main display. (Display Properties: "Make this my main display" checkbox) But the game still always starts on monitor 1. Tried switching main display and switching back, no dice.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now