Recommended Posts

So this is new...

I went to login to the forums via steam like I usually do, and with over 20 attempts, could NOT login to the forums via my steam account. I had no problem logging into my steam account, but when I returned to the forums, I kept getting the 'Something went wrong, please try again.' page.

Is there something you'd like to tell us, guys? Perhaps a little Steam hate? =P

Had to create a new account just to post this...

I'd kinda like to go back to my usual account posting, but... (T_T)

Share this post


Link to post
Share on other sites

The forum should be receiving some love soon. So assuming this is a forum issue (it could be Valve butchering the API...again...), it could be fixed soon. Otherwise it's either a Steam issue or your browser is blocking something (maybe an extension, I wouldn't know). 

I'll test it myself later.

Share this post


Link to post
Share on other sites

Personally, been having this problem from day one of joining this forum, to both greater (can't login with steam at all) and lesser (actually an error because yet another drunkard rammed the telephone pole leading to my street, resolved within the hour) extents.

I've allways suspected it was a database error in this site's backend systems (or Time Warner Cable being a colossal douche again), since it never mattered which of my three computers I was making the attempt from. (one of which I semi-regularly do a full nuke and reinstall on.)

I'll be happy to be proven wrong, of course, since these things usually aren't the fault of anyone running the forums, but it never directly hurts to suspect human/robot error.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now