0.6.5.0 - Inability to interact with anything might be caused by the work light?


misternice
 Share

Recommended Posts

After running into the (hopefully already well known) bug three times since the latest patch, I think I've finally discovered what triggers it.

The last time it happened, I had just built my first worklight and put it onto my backpack on one of the shoulder spots.

After that, I wanted to do some cleaning up in my base.

While moving around some materials from one place to another, it finally happened.

Only thing left I could interact with was the habitat.

I proceeded to save the game and suffocate my poor astroneer explorer next to the habitat.

After respawning, I noticed the bug still persisted, so I saved again and restarted the game.

Back in the game, the corpse of the old astroneer had already vanished.

All the items I had were there, except one. The work light, which, for some reason, disappeared.

Gladly I found that I can pick up all the items and the bug was gone!

Also, all the items on the ground had shrinked to mini versions of themselves, so it might be I just missed the worklight somewhere on the ground.

I searched very carefully though.

 

This has been the third time I had the bug happen. It was a new game with about 20 minutes of playtime.

The first time was on my main save game with many hours of playtime. I remember the bug happening after coming back to base from exploring the planet with my rover train.

I also remember I had a worklight on the front bumper of the rover. Like the third time, it happened when I started moving things (including the worklight) from the rover to some platforms.

The second time the bug happened was also about 20 minutes into the game. I can't remember exactly what caused it then, but I'm pretty sure I had also just built the worklight around that time.

All this makes me come to the conclusion, that in some weird way, it all has to do with the worklight.

 

TLDR: I think wearing a work light while moving items may cause the bug to happen.

Edited by misternice
Link to comment
Share on other sites

Interesting investigation, I'll check on my own save to see if this could fix it.

though my case of inability to interact with anything is a weird one though, Everything that is located on one side of my habitat is bugged and the bugged area extend out from that zone pretty far, I suspect that the entire half of my world is bugged out, 'cause when I go out scavenging on the other half, everything is fine.

Link to comment
Share on other sites

In my games the inability to pick things up persists through death. With nothing in my backpack or on my terrain tool, I am still unable to pick things up.

Link to comment
Share on other sites

In my case, I was charging my vehicle which hes two worklights on it. After done charging, I ran into the bug. The two worklights disappeared and I can't pick up the seat to put on the vehicle.(Then I found out that I can't pick up anyting)

On one siade of my base, I'm still able to interact with objects. Not able to do so one the other side or outside my base. Restarting game didn't help. 

I lost the two worklights. I kind of think the bug is cased by interacting with worklights and would appear when you are getting somewhere dar in the game.(Because I have another save in which I just barely started anything, nothing's wrong in this save. And this save was craeted before the one that glitched out.) 

Link to comment
Share on other sites

I've also noticed my vehicles acting oddly when i had work lights attached as headlights. I loaded in to see my rover stuck in reverse, before I had even entered it. I was able to chase it down and enter but couldn't move forward at all until I removed the light in an attempt to salvage what i could before letting it reverse forever. As soon as I removed the light the rover worked fine again. I also had a small rover act similarly.

Link to comment
Share on other sites

For me it's also half the world that's bugged: on one side of the habitat everything's fine, on the other I activate or pick anything up.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

×   Your link has been automatically embedded.   Display as a link instead

 Share