SES_joe

Update 0.6.5 - March 15th, 2018

Recommended Posts

R2.1.png

-------------------------------------------------------------------------

UPDATE : 4/2/18

We have deployed hotfix 0.6.8.0 to Steam to address these issues:

1. Fixed some crashes that were occurring upon loading saves. 

We are continuing to monitor crashes but this one was our worst offender and we felt it warranted a fix. Thanks to everyone who reported this issue and send crashdumps! 0.6.8 Will be deployed to Xbox Play Anywhere as soon as it gets through certification!

-------------------------------------------------------------------------

UPDATE : 3/30/18

We have deployed a hotfix 0.6.7.0 to address two issues:

1. Fixed a bug that caused bases on fabricators, solar panels, and worklights to not deploy. 

KNOWN ISSUE: 

Dropping the above items when not near terrain will cause them to teleport under the starting habitat. We will fix this issue in an upcoming update.

-------------------------------------------------------------------------

UPDATE : 3/29/18

We have deployed a hotfix 0.6.6.0 to address two issues:

1. Fixed the bug that caused players to lose the ability to pick up items in the world. This should also fix any saves previously impacted by this issue.

2. Fixed a big with fabricators created in 0.6.3 that caused them to not update their print lists with the new platforms

-------------------------------------------------------------------------

 

Steam 'Early Access' users will receive this update today, Thursday March 15th, 2018. 
Xbox 'Play Anywhere' players can also expect this patch to hit their consoles or Windows 10 machines Thursday March 15th, 2018. 

UPDATES
You can find these updates in 0.6.5.0, the current build of the game. As always, we recommend starting a new save when playing new updates. Older saves should work, but will definitely experience bugs.

VEHICLES

rover2.png

The Medium Rover and Large Rover have received a visual update. This includes new front and back slots which provide extra storage. These slots will only be active if the power line below them is unconnected. Once the power line is connected to another Rover or Platform base, the slots will fold down and drop any items attached to them. Old rovers should transfer over seamlessly.

The visual representation for Rover batteries has been changed. But their discharge and capacity is unchanged. 

Rovers have received an update to their suspension. Handling should be much better. Also, gravity on vehicle chassis has been adjusted so Mobile bases should be more stable. 

The power connection between Rovers and Platforms has been changed to directional. Now, you can very easily tell if your rover is consuming or providing power from your base. You can use this directional line to prevent the rover from mistaken power draw or discharge.

Research unlock costs relating to Vehicles have been reduced. This change has been made to encourage acquiring Rovers earlier in progression. Specifically:

  • The Vehicle Bay cost has been reduced from 1000 Bytes to 250 Bytes
  • The Medium Rover cost has been reduced from 2400 Bytes to 2000 Bytes
  • The Large Rover cost has been reduced from 8000 Bytes to 6000 Bytes
  • The Open 1-Seat cost has been reduced from 600 Bytes to 300 Bytes

POWER

splitter.png

A three port Splitter object has been added to the game. The Splitter takes in a power line and creates up to two adjustable directed streams. It is available in the Catalog for 1000 Bytes and prints from the Small Fabricator for 1 Copper. 

Directional power visualization has been updated for clarity. The previous version was just placeholder art. The marching chevrons should now be much more readable at a glance. 

Power Cells behavior has been changed. They now act as an on demand, single use battery which will only discharge when power is needed by the item they are attached to. Oh, they also no longer provide infinite power. 

BASEBUILDING

Modules can now be unpacked on top of Rover bases enabling a kind of Mobile base.

HighresScreenshot00012.png

You will still need immense amounts of power to operate a base on wheels, but this should allow for our nomadic players to continue base operations on the go. Also, be aware that once unpacked, base modules on rovers are linked forever. <3

Added new Platform and Storage variants to the game! (KNOWN ISSUE: OLD FABRICATORS WILL NOT UPDATE TO INCLUDE THE NEW PLATFORMS. UNTIL WE ISSUE A FIX, PRINT A NEW FABRICATOR TO SEE THE ENTIRE LIST OF PRINTABLE PLATFORMS.)

platforms.png

  • Medium Platform B - More compact version of the Medium Platform, costs 250 Bytes to research and 1 Resin to print. 
  • Large Platform B - More compact version of the Large Platform, costs 500 Bytes to research and 2 Resin to print. 
  • Large Platform C - Winged version of the Large Platform which swaps the Tier 2 side slots for 20 Tier 1 slots, costs 2000 Bytes to unlock and 2 Aluminum to print. 
  • Large Platform D - Two-tiered platform with 10 Tier 2 storage slots, costs 2000 Bytes to unlock and 2 Aluminum to print. 
  • Extra Large Platform - An octagonal platform with a single Tier 4 slot, and eight cable sockets, costs 3000 Bytes to unlock and 2 Aluminum to print. 
  • Extra Large Storage - A domed Tier 4 storage platform that prints on top of a Large Rover, or an XL Platform. It contains 31 Tier 1 storage slots, costs 3000 Bytes to unlock, and 2 Compound and 2 Aluminum to print.

The Vehicle Bay can now be operated by a Control Panel. 

Module Control Panels have received a lighting pass

INTERACTION 

A large number of the orange floating UI buttons have been removed from the game and replaced with interaction verbs. Your bases should look a bit less like a Las Vegas light show. 

The default Use verb has been replaced with contextual interaction verbs. For instance the Work Light now uses the verbs “Turn On” and “Turn Off,” while Drop Pods, Habitats, and Seats now use “Enter” and “Exit.”

AUDIO UPDATES

  • Update Smelter Audio, better end loops. Less Abrupt.
  • add variations for Base Building.
  • Hazard Plant SFX

OTHER UPDATES
Items in the Catalog have been slightly reorganized.
 

BUG FIXES

  • [AS-1831] - Fixed a longstanding bug where Tether lines did not go dark in Multiplayer games when disconnected from an Oxygen source. 
  • [AS-2237] - Fixed a bug where the Astroneer’s headlamp would turn off while dying inside a Drop Pod
  • [AS-2545] - Fixed an issue with cables twisting in strange ways in relation to the planet center.
  • [AS-2546] - Fixed an issue with power sockets on platforms twisting cables in strange ways in relation to the planet center. 
  • Due to the physics constraints of the world, vehicle chains have once again been limited to a maximum of 4 Rover bases. 
  • [AS-2567] - Power Nuggets once again charge batteries. Cave spelunkers, rejoice!
  • [AS-2570] - Drop Pods should no longer launch into space when invoking the Use command. 
  • [AS-2572] - Large Solar arrays can once again be moved by the Winch! 
  • [AS-2574] - Mineral Extractor and Smelter should once again auto-pull from and auto-deposit into connected storage. 
  • Fixed several recurring crashes on PC and Xbox One which should increase general stability. 

ROADMAP HIGHLIGHT

This update we are doing things a little differently, with an update of the roadmap: (view it here) directly from Veronica, our wonderful Producer: 

Greetings Astroneers!

Since we're nearing the end of March, and the first quarter of 2018, it's time for a Roadmap update! Our key features from Q1 have now been released: Basebuilding, Streaming Power, update to Vehicles including mobile bases and physics stability fixes. We also made big changes to the interaction system, modifying gamepad controls and introducing Examine and contextual Use verbs.

A few things we had that we started this quarter are not quite yet ready to move over to the "Released Features" column. The biggest ones to mention are Directional Steering for Vehicles and adding new Hazard and Discovery types to the game. The good news is, these things are in progress right now with Andrew working on steering, and our new Content Designer, Annie, working hard on bringing new discoverables into the world. You should see the fruits of their labor within the next couple of updates! 

Ahead of us in Q2 and beyond are the two remaining big systems - Terrain 2.0 and Dedicated Servers. I am happy to report that both are in full swing, with Adam working on the first new planet using the Terrain 2.0 tech, and Carl currently working on ensuring players on dedicated servers are able to preserve their game state when logging on and off. We're looking forward to sharing these features with you later this year!

Overall, everything you see in the Q2 column is already in progress and we are very pleased with how things are coming together. We can't wait for you to play with the new planets, vehicles, modules, resources, discoveries, and much much more. Thank you for your ongoing support and feedback!

-V

--------------------------------------------------

*EDIT* - KNOWN ISSUES! 

1. Fabricators and printers made in a previous save will not display the newly unlocked platforms. Create new fabricators and printers in version 0.6.5 to print new items.

2. Rovers and connected seats made in previous versions of Astroneer will display odd behavior, including bouncing when entering, and issues when using the "USE" action. To alleviate this issue, create new rovers & seats in version 0.6.5 or use the (ALT + CLICK) shortcut to immediately use something. 

-------------------------------------------------

Thanks for reading Astroneers! As always, thanks so much for the feedback, bug reports, & suggestions! This coming week we will be at GDC in the Epic Games booth showing Astroneer, so if you are headed to SF, and want to meet for a beverage, a high five or to talk business, drop me a line! joe@systemera.net

-jt

Share this post


Link to post
Share on other sites

But do you land on the landing pad when you respawn yet? (in Singleplayer)

Also, what else will the pad be used for?

It's got 3 slots (One for each basic module and another for pods) but will it have more uses soon? (Perhaps building our own that we can land shuttles on, the landing area being like red or something instead of blue)

Share this post


Link to post
Share on other sites

Hey, quick question. How do you actually make the new buildings? My mates and I cant find it :/

Share this post


Link to post
Share on other sites
58 minutes ago, Arobi485 said:

Hey, quick question. How do you actually make the new buildings? My mates and I cant find it :/

unlock them in the catalog, then use the medium fabricator to print them!

Share this post


Link to post
Share on other sites

I still thing the large solar panel array should be a researched item.

Find the crash site, bring a research pod back to base, unlock it on a research platform and build one (per research pod) on a special platform.

Share this post


Link to post
Share on other sites
On 3/14/2018 at 3:16 PM, Wyvyrias said:

P r e p a r e

My solar lord, prepare for the space ball of storage

 

Share this post


Link to post
Share on other sites
15 minutes ago, Pat4yczek said:

It's great you add new platforms, but I can't build anywhere after research

 Sorry, its a known issue, need to make new fabricators to print them!

Share this post


Link to post
Share on other sites

Oh great, I need to do long press Q for everything now. Can we have the option to bind "Examine" and "Backpack" separately, please? I have a keyboard; I have enough freaking keys that I don't need to have multiple "verbs" on the same key.

Share this post


Link to post
Share on other sites

Trying to get into a Vehicle on xbox keeps making me get out of my tool with holding down x, i have to unsnap the seat everytime to get in it

 

Share this post


Link to post
Share on other sites
54 minutes ago, CobraA1 said:

Oh great, I need to do long press Q for everything now. Can we have the option to bind "Examine" and "Backpack" separately, please? I have a keyboard; I have enough freaking keys that I don't need to have multiple "verbs" on the same key.

Excepting the tone of frustration, I agree.  My fingers don't want those two things on the same key for some reason.

Share this post


Link to post
Share on other sites

I am on Xbox One, and am having issues connecting with my friend on the Windows 10 pc version. When we try to connect, the game keeps telling is that one of us needs to update, even though we are both using 0.6.5.0

Share this post


Link to post
Share on other sites

PC users can ctrl+ lft click to open instead of holding Q not sure if there is an equivalent function on x-box.

Share this post


Link to post
Share on other sites

First time posting. 

 

I find the new rover great looking.. but doesn't function correctly. First it's still to low to the ground often getting trapped. Also having a train of 3 large rovers makes the rover impossible to climb small hills. consider that each of the rovers has power it should be reasonable that you should be able to get over a small hill easily. So far Its no longer playable for me. I can't travel anywhere with it.  

Share this post


Link to post
Share on other sites
2 hours ago, Sir Tubs said:

Trying to get into a Vehicle on xbox keeps making me get out of my tool with holding down x, i have to unsnap the seat everytime to get in it

 

I didn't have this problem at first but after I quit the game completely and restarted my savegame, it started doing it. I have to literally re-seed the seat then pressed E key right away to get in.

Share this post


Link to post
Share on other sites
1 hour ago, XBLToothPik said:

Downloaded the Update on XBox One, could not get it on Windows10.  Still 0.6.2 on Windows 10 Store.

I'm in the exact same place. the update is out for steam and xbox one and i know because  i tried both but the windows10 is still a no go

 

Share this post


Link to post
Share on other sites
Posted (edited)

Haven’t spent much time yet with this version but expecting great things as always, the basebuilding update certainly has been a pleasure so far! I wanted to stop by and mention something quickly, because I’m growing more concerned the artwork is expanding while perpetuating a gross inaccuracy in terms of scientific representation (which, based on statements by the Dev Team itself, including Adam, is something they care deeply about). If you do indeed wish to maintain scientific credibility in Astroneer, oxygen cannot be blue. Oxygen tanks most certainly CANNOT be blue. Oxygen, as a medical gas, is regulated extensively so as to minimize the risk of accidents in a variety of circumstances (such as ORs, ERs, home medical supply, you name it) just as all manner of gases supplied throughout industry are regulated. In accordance with these international regulations, tanks must meet certain labeling requirements which include (but aren’t limited to) having a “shoulder color” which in the case of oxygen is a dark green. It’s not the same green used in game as malachite green, it’s more like what I’d call a forest green (there are probably some suggested color “values” but I don’t think that’s important here, just that it’s incorrect to represent it as blue).

This is something that has always bothered me for a very long time. Obviously not to some horrible extent :P I do love this game :D I wouldn’t have hundreds of hours playing Astroneer if I didn’t. From the moment I first played Astroneer in January 2017, seeing the blue oxygen crystals, I really shook my head. “Why would they do that?” I wondered. In fact, at first I didn’t realize they represented oxygen :o Blue is traditionally an “aquatic-themed” color in games, although it’s not like there are hard & fast rules for this or even other colors (except maybe red for health, that’s rather universal). However there are some survival-oriented games that do use green as an oxygen indicator (iirc Subnautica is one). They have the right idea, and science is definitely on their side. I love the overall color theme of Astroneer. Blue is my favorite color, one of the most popular colors worldwide, a very soothing tone especially as used throughout the game. There’s no reason to change any of that. However, the light blue oxygen tanks look comical, I have to say. If anything they look like some cartoon character’s scuba tanks, which is kinda sad. After all, you’ve gone to great lengths to change materials in game to better approximate their real colors, so I’m curious did no one ever check to see if something like oxygen supply & delivery was accurately represented? I’m sure NASA utilizes the same oxygen labeling practices (including cylinder banding) that medical facilities use. I’m sure some company, no matter how exclusive and scrutinized, must deliver that oxygen and it must comply with labeling standards. Anyway, thanks for your time reading this. I know some (perhaps many) will read this and think this is stupid, I would bring this up. However I believe this is important, more so given the Devs have said themselves they want their game to have a certain amount of scientific accuracy, at least visually when it comes to resources in the game (oxygen is definitely a type of resource). While I do like the appearance of the shimmering blue crystals, it goes against the grain of scientific fact and years of medical experience. It doesn’t look right, basically. I hope the Devs will choose to make the game more accurately reflect oxygen and it’s storage so it’s better distinguished from the background “style” and aesthetic of Astroneer (which I do love) :) 

P.S. the blue tanks actually look like those aquatic nerf guns, something like that, I just realized :P anyone else recall running around with their kids (or still do), getting sprayed? Nice way to cool off on a hot summer day xD 

Edited by Shadow Echo

Share this post


Link to post
Share on other sites
2 hours ago, bryan davila said:

I'm in the exact same place. the update is out for steam and xbox one and i know because  i tried both but the windows10 is still a no go

 

I'm having the same issue. SES says it's available for windows10, I even uninstalled, and re-downloaded from the windows store, I still have 6.2.

Another interesting thing, is when I go to the updates section of the windows store, it shows Astroneer version 6.2.2, but the game itself says 6.2.0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now