Recommended Posts

Hello, 

I'm so glad I finally bought ASTRONEER and supported this developers by doing that. Now thing is, I'm having like these constand frame drops while playing, from the beginning while I arrived at the planet with my pod they began dropping. I optimized all settings (even with nvidea inspector) to performance. I've not build much in the world or gone exploring far. They aren't really "frame drops" because the game constantly plays at 60fps even when this lags are occuring. Is this a bug? Cuz my laptop can run bigger games. 

Is a video needed? 

 

Thnx! 

Seppe 

Share this post


Link to post
Share on other sites

i once had nearly unplayable lag spikes too, like SPIKE spikes, solid-wonderful-beautiful 60 fps when looking around but as soon as i took a step BAM, me no move for seconds at a time

i noticed that they occurred mainly when the game loaded in the decoration stuffs, like grass and whatnot, so i narrowed the limiting factor in my computer to the CPU and yep, that was it (at least for me) upgraded my 2-core 4-threaded 4.2ghz AMD fx-4350 to a 4-core 8-threaded 3.2ghz AMD Ryzen 5 1400, the lag is gone

on larger save games (like my main world with bases on at least 3 planets) the game is much more laggy when compared to a brand new world, but it is still very very much playable

basically i believe this game is a very CPU heavy game, most GPUs can "probably" handle it (i tested the game on an old Quadro card and it was no worse than my 1050ti). 

unfortunately, there is no real way around it, all the "lag fixes" i looked up and tried targeted easing GPU stress when in reality it was the CPU being stressed

and fortunately, the road-map:

(https://www.google.com/url?q=https://trello.com/b/UoZgKrd3/astroneer-development-roadmap&sa=D&ust=1517705801265000&usg=AFQjCNHvpbHbQirKMKE_S8h0nvPCLjj6hA)

says they plan to work on "in game performance issues" and "unreal engine version upgrade" in Q1 of 2018, so the performance-problem side of the game should hopefully be addressed quite soon...

 

until then... better processor i guess...

 

-

 

(i have a feeling that something i did to my pc messed it up cpu-wise, no proof, but worth a check)

press windows-key and "R" and then type in "msconfig" to the box of searchy runness, click ok, then make sure that (under "boot" tab and "advanced options" button) the number of processors checkbox is unchecked (and for good measure, max memory too)

i just remember that being the case when i experienced multiple problems with my PC, but its just an idea (regardless though, it would be best to have both boxes unchecked)

 

i hope at least some of this helps!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this