SES_joe

"Patch 0.5.1" - January 18th, 2018

Recommended Posts

Posted (edited)

R2.1.png

Steam 'Early Access' users will receive this update today, Wednesday January 17th, 2018. 
Xbox 'Play Anywhere' users got this update yesterday.

This update is a followup to the previous Research Update! The team took some much needed time off for the holidays and were going to hold off on updating till February, but decided to keep to the "update every month" schedule to spend time fixing some bigger crash bugs and add another feature to the Research system!

Updates
You can find these updates in 0.5.1.0, the current build of the game.

Research System now uses Multi-Phase rates
This release we've made a big update to the research system that debuted in our last update. Now every research subject contains multiple phases with different Byte values. Some items have their most valuable phase early, some much later, and some in between. So if you really want to maximize your research operations, you have lots of new decisions to make about what to research, when, and for how long. To help you make these decisions and figure out how much you want to min-max as a player, the Control Panel on the Research Chamber now shows a timeline of all the current item's phases.

giphy (2).gif

If your current research subject has moved into a lower-rate phase, and want to replace it something that's higher value, you can stop the current research operation and and load in the new subject right away. But be careful, stopping a research operation early means sacrificing any uncollected points! So don't be reckless, okay?

Update to the lighting system has been implemented
In this patch we included an overhaul to the lighting system. The main goal was to get the game running using the ACES tone mapper, so we could then get the game running in HDR in a future update. That meant spending lots of time recreating the look of Astroneer in a completely new system. We aren't completely done tweaking this, but overall this approach is a huge step in the right direction.

giphy-downsized-large.gif

If you want to see the other stuff that happened this month, check out our vlogs for weekly insight to what the team is doing. The most recent one shows off the new Basebuilding system:

FIXES

BUGS

[AS-1522] - Fixed a number of issues that were causing save files to be deleted when the game crashed or the application was closed. In the most common case, this occurred when very large saves took enough time to write out that the user had time to close the window before the file finished.
[AS-1958] - Fixed an issue causing inconsistent playback of Gas Hazard audio
[AS-2097] - Fixed a minor issue where the Astroneer could still walk around when scrolling through the pages of the Help screen.
[AS-2104] - Fixed an annoying Multiplayer bug which prevented the Client player from exiting a flipped vehicle in Multiplayer games.
[AS-2113] - By adjusting a few things in the engineering team’s favorite part of the code, local wind effects should now only spawn for the relevant player rather than all players in a Multiplayer game. 
[AS-2158] - Fixed a bug where the Research platform remained in the "completed" state if it lost power while in that state.
[AS-2172] - Base platforms no longer have "ghost" slots on the front that store only Compound. Goodbye, secret Compound storage.

CRASHES

With automated crash reporting coming online last month, during this release cycle we focused on fixing some of our most common crashes. There are a dozen or so more, but are pretty technical so I tried to summarize them here.

[AS-2148] - Fixed a crash that occurred when entering the pause menu
[AS-2150] - Fixed a crash that occurred while printing an item
[AS-2153] - Fixed a crash that occurred while opening your backpack in certain situations
[AS-2155] - Fixed a crash that occurred while loading a save game

ROADMAP HIGHLIGHT

We just completed a comprehensive overhaul to the roadmap! Now you can see projected time frames for upcoming content, as well as our ideas for free post launch content. The following major features are continuing during development, but are not included in this release. 

Dedicated Servers
We currently have a dedicated server running with a third party that we can connect to. There are plenty of bugs still yet to deal with, but we are getting closer and closer to public launch. 

Basebuilding
We have already completed a couple of playtests, but this is feeling really great right now. If you watched the above vlog, you can catch some glimpses of basebuilding in action, but here is an image that Spencer made during one of our recent playtests that sums up a lot:

basebuilding.png

(none of the above art is final*)

Research - Implemented & In Progress

We just keep going! This update  As with all of the new systems we are shipping, these are just base implementations that we will now work on expanding. Multi Phase items are now in, and the next steps include working on items that instantly grant you research points, and unlockable blueprints that can only be found out in the world and never be unlocked via the catalog. Expect this to keep getting more content for our next few updates. 

Terrain 2.0, Weather, and Hazards 

This is still in a similar place as last update. Zabir is working hard on ironing out some of the last authoring tools that the art team will use to create planets, biomes, and weather. The next step here will be generating one of the existing playable planets with the new system for testing!

Also, the first versions of aggressive flora were shown off in the last vlog. We are now working on making variations that utilize some of the cool behaviors Andrew created.

 

Edited by Wyvyrias
Fixed vlog hyperlinks

Share this post


Link to post
Share on other sites
On ‎1‎/‎8‎/‎2018 at 8:49 PM, SES_joe said:

...

Always good to hear from time traveling Joe... it shows he posted that on the 8th, but today is the 16th :P

Share this post


Link to post
Share on other sites

Yep, I'm on 0.5.1.0, and I can't save anymore. Always goes back to the same save game, even after I've saved several times in game, and exited. Save file is 19.8 MB. Originally it said reserved space of 256 MB. Playing on XBOX One, gamertag ARTEMUS7. If I have to delete and start over, I will. Still checking to see if I can get it to save a game. FYI, I deleted my other new game save, so now I just have this one game saved.

 

ASTRONEER (Game Preview).png

Share this post


Link to post
Share on other sites
8 minutes ago, Steve H said:

Yep, I'm on 0.5.1.0, and I can't save anymore. Always goes back to the same save game, even after I've saved several times in game, and exited. Save file is 19.8 MB. Originally it said reserved space of 256 MB. Playing on XBOX One, gamertag ARTEMUS7. If I have to delete and start over, I will. Still checking to see if I can get it to save a game. FYI, I deleted my other new game save, so now I just have this one game saved.

 

ASTRONEER (Game Preview).png

Could you try starting a save in a fresh slot and seeing if that saves your progress? We introduced some fixes to avoid loss of save data in this update. 

Edit: Also, sorry this is happening to you! Appreciate you posting on the forums about it. 

Share this post


Link to post
Share on other sites

Load times have been lengthened and sometimes cannot go from in-game to the main menu. Going to explorer some other weird happenings.

Share this post


Link to post
Share on other sites
8 minutes ago, SES_joe said:

Could you try starting a save in a fresh slot and seeing if that saves your progress? We introduced some fixes to avoid loss of save data in this update. 

Edit: Also, sorry this is happening to you! Appreciate you posting on the forums about it. 

I just started a completely new game (orange Astroneer). Going to do a couple of saves to check.

Share this post


Link to post
Share on other sites

Objects continue to float in air. 1 beacon floating in space. 2 large storages floating mountain height above base.

Share this post


Link to post
Share on other sites
12 minutes ago, Steve H said:

I just started a completely new game (orange Astroneer). Going to do a couple of saves to check.

Well, I just tried to save my game again. Last good save was made on Jan 15, 2018 at 8:45 pm. That's also shortly after my four vehicles fell into the caves, got stuck on the roof, and after I used the terrain gun to get them down, when I went to jump in the vehicle, all four vehicles in the train and my Astroneer got ejected or fell through the planet (Terran) and into deep space. Then my dude fell back to Terran, and died on impact (expected). I had just returned from off world (Arrid) and had brought back a huge supply of titanium, copper and lithium. Since then, it dumps me back to the save on Arrid, on the above date. I've played several hours in that game since, and every save says "Saving Game", yet the date or time doesn't change, and it also takes me back to the same exact spot on Arrid. As I posted before, save file on XB1 is 19.8 MB.

Share this post


Link to post
Share on other sites
12 minutes ago, Steve H said:

Well, I just tried to save my game again. Last good save was made on Jan 15, 2018 at 8:45 pm. That's also shortly after my four vehicles fell into the caves, got stuck on the roof, and after I used the terrain gun to get them down, when I went to jump in the vehicle, all four vehicles in the train and my Astroneer got ejected or fell through the planet (Terran) and into deep space. Then my dude fell back to Terran, and died on impact (expected). I had just returned from off world (Arrid) and had brought back a huge supply of titanium, copper and lithium. Since then, it dumps me back to the save on Arrid, on the above date. I've played several hours in that game since, and every save says "Saving Game", yet the date or time doesn't change, and it also takes me back to the same exact spot on Arrid. As I posted before, save file on XB1 is 19.8 MB.  I posted the "strikethrough text with video in the bugs forum.

 

Share this post


Link to post
Share on other sites

Have you tried a full shutdown (via the settings page) and reboot? That's previously fixed the save issue before the patch. Best to start a new game to try it out, and if it works you could then try loading into a previous save. 

Share this post


Link to post
Share on other sites

I'd really like someone to correct the title of this post. The year is wrong.

Share this post


Link to post
Share on other sites
43 minutes ago, Blind Io said:

Have you tried a full shutdown (via the settings page) and reboot? That's previously fixed the save issue before the patch. Best to start a new game to try it out, and if it works you could then try loading into a previous save. 

I shutdown after the patch installed and started a new game, it saved fine. 

I then tested a previous save and it saved too. 

Edit: game crashed after trying to load back into new game, but loaded ok on 2nd attempt. 

Edited by Blind Io

Share this post


Link to post
Share on other sites

I haven't tried using any old saves, but can report I've created new games on Xbox One, saved them by jumping in the hab, exited using the menu option, made a 2nd new game file and played on it for awhile then saved it as well in the same manner, went back to the in-game menu and loaded up the first game (I had deleted any old saves) and it loaded just fine. Just wanted to share that because it wasn't clear if there was an issue with any saves for this patch or just saved games people were trying to use that existed prior to this update (because those always run a risk of not working properly, and are never guaranteed any compatibility).

About the game, in absence of any patch notes, all I can say is wow the game looks pretty amazing y'all sure have done some cool work with how it looks (I've only been on Terran haven't made it anywhere else so far). Lots of neat detail I know I've never noticed before (some may just be I'm looking with a more heightened sense of awareness trying to see what might be different so idk) but some plants and research pods have silvery iridescent touches which look amazing, especially in low light situations. Really love the new (I think they're new) colorations and/or color touches and contrasts added to Ammonium and Lithium. Titanium looks the same; I think it would look much better if the shiny finish were extended to the outside of the "nugget" instead of it being dull on the sides, but that's just me.When underground in caves, textures really seem to "pop" although rendering times for stuff to come into view for my Astroneer seem quite sluggish (for example I might be almost on top of a Spiker or bunch of mineral before it decides to show up, that's not good). This has always been an issue but in the past it's been more of one when games get older, having played many hours on them. I worry because these are fresh games, ones I'm only playing 1- 2 hrs on and I'm having issues with rendering delay. Idk how the game tends to run on PC (probably a mixed bag depending on the specs) but we sure could use some performance upgrades on the Xbox One please.

As for the skybox, dawn and dusk really look amazing, at least I know I like how they look now (I liked them before too, but now they look less cartoonish I suppose?). Howver, night seems to have become even darker (yes, again) and day even brighter (again). The only issue I have beyond the darker night is the full daytime light, which is overall ok, but it's too washed out and somewhat hazy all around at least at the place where you spawn (seems less so as you move further away). Again I haven't played long enough to really wander all over the planet lol, but around the spawn the daylight is almost blinding esp around "high noon" and when you're looking for the home beacon it's still very difficult to see often in that level of brightness. Caves on the other hand are almost to the point I can't navigate without either tether or work light. My suit light just isn't cutting through the darkness anymore, it needs some buff, pronto. I'm sure there are many things I've noticed but haven't registered fully, not enough to write down anyway, but I wanted to say how amazing the game was looking so far!

Some of the things in the new tutorial pics, including the graph thing, don't really jive yet with what I'm seeing on the research machine (which depending on the pod, now looks more like one of those interval trainer exercise machines with all their steps and levels lol). I'm guessing the patch notes will explain all this further (I hope). My first research pod had me hopeful the daytime power issue had been fixed (I had observed some weird power numbers, almost like some arbitrary limit, on daytime power using mostly the solar panels but at night using just small wind turbines they would shockingly exceed by a significant amount the daytime energy production which just didn't make any sense). Howver, that hope was short-lived, as the next pod had a much smaller amount of power production associated with its run (for no apparent reason, as I had no base modules built yet, there wasn't anything drawing any power and solar units producing power and all other possible variables appeared the same as far as I could tell). Apparently there are still some oddities in power production and consumption with regards to the research complex. The colors and readability has improved, but y'all seem fixated on using that blue and pink huh? Still think there must be some better color combos out there ;) I was really hoping (from peeking at the new "help/guide" images) we'd be getting a power graph but it doesn't look like that's what is being depicted in the new research interface. What it actually does depict, like I said, I'll have to wait and find out. Research seems to run a bit faster overall, but that could just be my imagination.

Haven't built anything other than a research machine to see if anything else new is in store or has changed. One game I had died not far from base, but after I had picked up my things (they still show up sideways in the deceased body's backpack by the way) and returned to save in the hab, I saw a persistent message over the hab (for some odd reason idk why) that said "Suffocating" even though I clearly wasn't in the hab or suffocating. I haven't gone back to reload to see if it's still there, but thought I'd mention it in case it shows up as a repetitive bug.

Thanks for all of your continued hard work making the game great. I guess this is what you'd call an "early" Early Release :P 

Edited by Shadow Echo

Share this post


Link to post
Share on other sites
11 minutes ago, Shadow Echo said:

... As for the skybox, dawn and dusk really look amazing, at least I know I like how they look now (I liked them before too, but now they look less cartoonish I suppose?). Howver, night seems to have become even darker (yes, again) and day even brighter (again). The only issue I have beyond the darker night is the full daytime light, which is overall ok, but it's too washed out and somewhat hazy all around at least at the place where you spawn (seems less so as you move further away). Again I haven't played long enough to really wander all over the planet lol, but around the spawn the daylight is almost blinding esp around "high noon" and when you're looking for the home beacon it's still very difficult to see often in that level of brightness. Caves on the other hand are almost to the point I can't navigate without either tether or work light. My suit light just isn't cutting through the darkness anymore, it needs some buff, pronto. I'm sure there are many things I've noticed but haven't registered fully, not enough to write down anyway, but I wanted to say how amazing the game was looking so far!

Have you tried adjusting the brightness in the main menu? By default it's zero. I changed it to 25 and caves are much better to navigate. Having said that, the green layer of terrain can be blinding (when you're digging a tunnel).

Share this post


Link to post
Share on other sites

Xbox: Saves are working fine for a new game. Did not reboot.

 Love the new darker nights and caves.  Waiting for patch notes to explain the new graph on the research station.

Edited by deadcrow

Share this post


Link to post
Share on other sites

Yes I have used the brightness settings in-game since they were added. They do help a little, but I find the issue is whatever I do to make the cave areas brighter makes the outdoor areas so much more bright they're almost unbearable in full daylight. I've also tried different TV settings as well, but I've given up on that being a cause or issue. I don't have problems running other games, and my settings don't generally change (other than I do have one custom set I use when it's day at home and there is quite a bit of "ambient light" I suppose you could say, and a different custom setting for nighttime which is acutely when I play the most, as well as a "bias light" strip that's located behind my tv which is supposed to help decrease eye strain by reducing the relative intensity of light or something like that I'd have to read about it again tbh to know for sure. I just know it helps people who view tv or play games at night, reduces eye strain etc. Mine is just a simple cheap adhesive lighting solution that runs off a USB outlet on the tv itself so it turns on automatically whenever the tv is on, and shuts off automatically too. I don't tend to save games that spawn in the bright green terrain. Not only is the light intensity just too much, I also have found there is a sort of haze that is often seen during the day, at least there was in older versions of the game.

I can report there does indeed appear to be some sort of bug going on after you've died and reepwaned showing the word "suffocating" somewhere above or "inside" your hab at least this has been happening for me. Haven't been back into a save to see if it continues to be visible but I've had 2 games now in which I've died and the same message continues to be displayed.

At night in darkness I like how Resin has a neat bit of contrast too it, but I don't really notice so much Compound having the same effect? Laterite seems a bit more visible in caves, but I still believe Malachite needs a color better distinguishable from the "cave green" it simply blends in too well and should stand out more plus have better contast imho. And speaking of caves, Thruster is still misspelled ;) 

I know one thing that still hasn't been fixed, I know many like myself are hoping will eventually be fixed, is the problem of approaching for example a node on your base where you used have it actively select an item that was on that node you were next to. Since the last update, that behavior unexpectedly changed to where now when you're next to a node, instead it wants to actively select to extend the node in your direction, something most of us don't want it doing unless we select it to do so. Please fix this whenever you can. It's extremely annoying to have to move the cursor everywhere each and every time you need to pick something off a node (or sometimes even off a storage pallet) especaillly those of us on Xbox where using the cursor isn't as straightforward as simply pointing a mouse and rolling it about. It's a real pain. It was much easier before, and much more user-friendly, I know some have complained they're making mistakes because instead of grabbing an item they want, if there is resin in their pack the node is building a base module instead. Thanks!

 

Share this post


Link to post
Share on other sites
On 9-1-2018 at 3:49 AM, SES_joe said:

If you are viewing this page, its because the build has been published on Xbox early! Full patch notes will be published soon. As for Steam users, this patch will go live tomorrow!

If you are going to talk about tomorrow, it would be nice if your time would be right....now it says posted on 9th of jan....and the update comes 18 jan 2017 ?!

Please fix it, thank you.

Share this post


Link to post
Share on other sites

I died randomly from a storm while  inside a cave while paused. At least, thats what I think. I was paused while inside a cave and died. I lost all my backpack items as a result, as expected.  There's no beacon to my body, even though I am quite close to base. I was pretty far away and at a 90 plus degree angle from the cave mouth when I thought it was safe to be tethered and "pause" the game. Now, I don't care that I died, but I just need a marker to my body. There's goodies on there, ya know?

 

Oh, I  almost forgot also dying in my habitat during a storm and losing everything in my backpack. No body, no marker. Xbox one s by the way. I just bought a pc, and I can't wait to play this on it. just thought I'd toss that out there. 

Share this post


Link to post
Share on other sites
11 hours ago, Pi_ said:

Always good to hear from time traveling Joe... it shows he posted that on the 8th, but today is the 16th :P

NOT in Oz. (Australia) it is 17/1/2018(i cant delete,) nevermind

 

 

Edited by roger roger
trying to delete

Share this post


Link to post
Share on other sites
1 hour ago, DReaMoR said:

If you are going to talk about tomorrow, it would be nice if your time would be right....now it says posted on 9th of jan....and the update comes 18 jan 2017 ?!

Please fix it, thank you.

The posting time of a thread doesn't matter. We can make posts at any time, keep them hidden and edit them later.

Share this post


Link to post
Share on other sites
7 hours ago, Blind Io said:

Have you tried a full shutdown (via the settings page) and reboot? That's previously fixed the save issue before the patch. Best to start a new game to try it out, and if it works you could then try loading into a previous save. 

I'm using an Xbox One, so I have only one save game per Astroneer. I cannot select a different (earlier) save game, as of now, as far as I know. 

 

33 minutes ago, Zurisadai Escalante said:

Hi 🙂 im in xbox one (GT RavenLC), my game is saveing correctly

I uninstalled my game on XB1 and reinstalled it. Oddly it only shows as 1.7 GB, but should be 3.2 GB after the 0.5.1.0 update. Anyway, I'm also happy to report that I can now get saves to update for the game I had played before and the game I played after the 0.5.1.0 update! Yeah!

Share this post


Link to post
Share on other sites
11 hours ago, SES_joe said:

Could you try starting a save in a fresh slot and seeing if that saves your progress? We introduced some fixes to avoid loss of save data in this update. 

Edit: Also, sorry this is happening to you! Appreciate you posting on the forums about it. 

After uninstalling the game, and then reinstalling it, while keeping my game save data, I was able to load my first and longest played game, and the save updated correctly! So I can now access and get updated saves on both my games! FYI, my game is installed on my external 2 TB, the game saves are on my Internal. I can't move my game saves to external. Originally, my first install was on the internal, my second was on the external. Now both updates were installed on the external. Hope that makes sense. Thank you for your reply!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now