SES_Adam

How to change your in-game language.

Recommended Posts

Here's how to change the game's language to another without having to open any system settings!

Right Click Astroneer -> Properties -> Set Launch Options

And type:

-culture="VALUE"

And use the following list for your preferred language!

VALUE's to choose from: 

-culture="de" for German language.

German - de
English - en
Spanish - es
Catalan - es-ES
French - fr
Italian - it
Japanese - ja
Korean - ko
Dutch - nl
Polish - pl
Portuguese - pt
Russian - ru
Chinese - zh-hans

Share this post


Link to post
Share on other sites

Hm, I am on Windows 10 and the above and the Launch options mentioned in the first post worked very well.

You need to set them in the Steam client. In Library view right click on Astroneer in your games list, select Properties of the shown menu, and follow the instructions as given in the first post.

Hope this helps. 9_9

Greets,

Jan

Share this post


Link to post
Share on other sites
17 minutes ago, Jananton said:

Hm, I am on Windows 10 and the above and the Launch options mentioned in the first post worked very well.

You need to set them in the Steam client. In Library view right click on Astroneer in your games list, select Properties of the shown menu, and follow the instructions as given in the first post.

Hope this helps. 9_9

Greets,

Jan

You're talking about the steam client, I'm talking about the windows store version of the game, so nop it's not working.

Share this post


Link to post
Share on other sites

In that case have you tried making a shortcut to the Astro.exe file and add the commandline command -culture="xx" to the path of the executable?

I feel that might work when you use that shortcut to start the game on Windows 10.

Greets,

Jan

Share this post


Link to post
Share on other sites
20 hours ago, Veltox said:

I'm wondering if this option is going to be added in-game?

Definitely there will be an easier way at some point! For now this serves as temporary solution to make up for the lack of this feature.

Share this post


Link to post
Share on other sites
1 hour ago, Wyvyrias said:

Definitely there will be an easier way at some point! For now this serves as temporary solution to make up for the lack of this feature.

And i'm fine with this at the moment. It's just one time. Not that we need to do this again every update.

Share this post


Link to post
Share on other sites
16 minutes ago, Veltox said:

And i'm fine with this at the moment. It's just one time. Not that we need to do this again every update.

The launch parameters are basically a Steam-side thing (well, probably more OS side). You don't have to change or redo this unless you reinstall Steam without backing up it's settings.

Share this post


Link to post
Share on other sites

I don't know about other languages translation but spanish need a bit of improvement and some words are still in english in the  controls section of the menu

Share this post


Link to post
Share on other sites

So nearly two and a half years on, and I'm still unable to change the language of the Windows Store version of the game. I found the ini that even contains the line "language" in the hidden AppData folder (the ini that also allows remapping the buttons), but adding "en" to the "language" line there doesn't do anything. In fact, the game adds another "language" line above it as soon as it boots.

The Dutch localization is horrible, and Dutch people in general prefer to play their games in English. Just give me the option to switch! It's working fine in English on my Xbox One! Getting quite frustrated with this now; I feel like I paid for something I cannot use, as it's useless for me on PC now and I'm still unable to play it with my girlfriend on Xbox and me on PC, simply because of the language.

Share this post


Link to post
Share on other sites
15 minutes ago, Koen van den Wijngaart said:

So nearly two and a half years on, and I'm still unable to change the language of the Windows Store version of the game. I found the ini that even contains the line "language" in the hidden AppData folder (the ini that also allows remapping the buttons), but adding "en" to the "language" line there doesn't do anything. In fact, the game adds another "language" line above it as soon as it boots.

The Dutch localization is horrible, and Dutch people in general prefer to play their games in English. Just give me the option to switch! It's working fine in English on my Xbox One! Getting quite frustrated with this now; I feel like I paid for something I cannot use, as it's useless for me on PC now and I'm still unable to play it with my girlfriend on Xbox and me on PC, simply because of the language.

Have you tried adding the line "Culture=en" to the engine.ini? 

Engine.ini is in %localappdata%\Packages\SystemEraSoftworks.[random] \LocalState\Astro\Saved\Config\UWP\

You may need to set it to read only after adding the line. This will prevent the in-game menu making changes too. Weird it seems to have been Dutch players with this issue. 

Share this post


Link to post
Share on other sites
On 7/14/2019 at 3:15 AM, Koen van den Wijngaart said:

So nearly two and a half years on, and I'm still unable to change the language of the Windows Store version of the game. I found the ini that even contains the line "language" in the hidden AppData folder (the ini that also allows remapping the buttons), but adding "en" to the "language" line there doesn't do anything. In fact, the game adds another "language" line above it as soon as it boots.

The Dutch localization is horrible, and Dutch people in general prefer to play their games in English. Just give me the option to switch! It's working fine in English on my Xbox One! Getting quite frustrated with this now; I feel like I paid for something I cannot use, as it's useless for me on PC now and I'm still unable to play it with my girlfriend on Xbox and me on PC, simply because of the language.

Hello, in order to launch Astroneer in another language your computer must also be in that language, hopefully these steps can help you out.

 

First time Set Up to Install Language Packs

  1. In the Language Windows Settings menu, select "Add a language".
  2. In the pop up window that appears, type in the search bar at the top or scroll down to the desired language in the list.
  3. Select the desired language.
  4. Select "Next".
  5. Select "Install".

Launching Astroneer Using an Already Installed Language Pack

  1. Click the Start button in the taskbar or press the Windows key on the keyboard.
  2. Type "language" and press the Enter key to open "Language Settings" within Windows Settings.
  3. Under "Windows display language", select the dropdown menu and select the desired language from the list.
    1. The warning message that appears stating "Will be display language after next sign-in" can be ignored - just make sure to select English from this list again after testing is done before locking the computer, or the display language will be non-English next sign-in.
  4. Launch Astroneer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now