Recommended Posts

196

Xbox One

Not sure if this is intended, but i just had a fun joy ride inside a sandstorm while in my large rover. (I included a 30sec clip of it) I was 20 ft away from my base when it hit and it was like I weighed nothing as I blew me across the surface of terra hit some space junk and started to tumble. Plus it will do the same if you are deep underground in one of the massive caverns too. 

Second thing is, the white line that was below any beacon (including the home base one) does not show up. This is a problem when you have the clouds above the base and the home beacon is covered up by them, got lost for an hour yesterday because of it and I wasn't that far, I just didn't see it because of the clouds. Including screenshots

Also the performance has dropped severely after the game crashed on me yesterday while I was out exploring in my large rover. Load in of objects take up to several seconds sometimes and the rover comes to a dead stop till it loads in. And walking around large clusters of objects makes it worse. Plus when moving the camera around to look lags pretty bad now too. 

Just a few things I am currently experiencing, still love the game though ?

7-24-2017_1-17-34_PM.mp4

7-24-2017_1-13-27_PM.png

7-24-2017_1-14-27_PM.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now