epikto

Astro-Win64-Shipping.exe not responding on start.

Recommended Posts

Machine:  1 year old Alienware 15
RAM: 8 GB
Proc: Intel Core i7-6700HQ CPU @2.60Ghz (dual core)
Graphics:
NVIDIA GeForce GTX 970M (GPU), Intel HD Graphics 530 (onboard - laptop mainboard)

Got app through Steam 

Simple as that.  Hopefully this is straightforward enough.  There is nothing to screenshot as it just hangs with no display.

DxDiag.txt

SavedLogs.zip

Edited by epikto

Share this post


Link to post
Share on other sites

Your logfiles won't let me read them, saying that my account doesn't have permission, although that might be intentional.  Have you tried reinstalling the game?  It might also help to run the executable located at "C:\Program Files (x86)\Steam\steamapps\common\ASTRONEER Early Access\Engine\Extras\Redist\en-us"

Peliex.

Share this post


Link to post
Share on other sites

here is the latest logfile directly not zipped.  hopefully you can read them.  I uninstalled and reinstalled (from steam) and i also ran that executable which you pointed me too.  Thx!  unfortunately i still have the same problem.  I may reboot a few times, cause you know, microsoft...

 

Also the attached log files are from last night.  I updated my graphic drivers just in case and the behavior changed from crashing to just hanging.

Problem remains unsolved.  Thank you for your reponse.

CrashContext.runtime-xml

UE4Minidump.dmp

Edited by epikto

Share this post


Link to post
Share on other sites

Navigate to this directory  Program Files (x86) \ Steam \ SteamApps \ common \ ASTRONER EarlyAccess \ Engine \ Binaries \ ThirdParty \ OpenVR \ OpenVRv0_9_12 \ Win64 and delete the file openvr_api.dll,, this has apparently fixed the issue for several other users, so worth a shot, at least.

Peliex.

Share this post


Link to post
Share on other sites

Completely removed all Astro directories and the local cached data.  Reset any graphics settings to default.  Installed everything again and still get issue.

Share this post


Link to post
Share on other sites

A clarification.  I cannot get the game to start at all.  It is an immediate crash.  At one point it was hanging.  Now I just get an immediate Unreal Engine Crash.  I've updated all of my graphics, i've tried a few settings with Phyx, reset everything to default, nothing has an effect thus far.

Share this post


Link to post
Share on other sites

I have the Same Problem. It seems to be a Problem with the nvidia drive. What worked for me was to roll back the nvidia graphics driver trough Windows Hardware Manager to a previeous Version. Might be a workaround but hopefully they soon  find a solution 

Share this post


Link to post
Share on other sites

i see.. do you know how far back you need to go?  Do you have your driver version?  at least initally, I thought i was using the drivers my machine shipped with.  So I updated it.  Any additional information will be helpful.

 

Thank you.

13 hours ago, Unlip said:

I have the Same Problem. It seems to be a Problem with the nvidia drive. What worked for me was to roll back the nvidia graphics driver trough Windows Hardware Manager to a previeous Version. Might be a workaround but hopefully they soon  find a solution 

 

Share this post


Link to post
Share on other sites

When i Use the driver roll back Feature given by Windows in the Hardware Manager it Sets the driver back to the year 2012 xD this should be the Version my  Laptop was shipped with when i bought it. It Sounds a bit crazy that a driver that old works better but hey... 

Edited by Unlip

Share this post


Link to post
Share on other sites

welp that didn't work.. still open to ideas.  Tried using sfc /RUNNOW and possibly have some registry errors.. but not sure what specifically i can do at this point.

 

Share this post


Link to post
Share on other sites

I managed to get the game working even with the latest graphics driver installed. There is a problem with UE4 and the voltage scaling on some graphics cards. If I understand it correct the core voltage your graphics card is running with is scaled depending on the task the card has to perform. Now there seems to be a bug which causes that process to fail and crashing your graphics diver.

In some other forum someone set the voltage on a constant maximum setting in MSI afterburner (feature called "forced constant voltage" or something like that. I have it in German).

I just tried it and well, it works. Hope it helps you to.

Share this post


Link to post
Share on other sites

Thank you for that i'll try it as soon as i'm done with the current round of testing/fixes.

The cycle i'm in involves running the following two commands to resolve any corrupting in my registry settings

sfc /SCANNOW

dism /online /cleanup-image /restorehealth

 

once i'm complete with this testing i'll try the GPU setting.  Thanks again for the heads up!

Epikto

Share this post


Link to post
Share on other sites

nope nothing has worked.  And for my nvidia setup with Intel graphics there wasn't a setting for me to change.  So i'm at the end of my rope here.

Thank you for all your help but i might be at a situation where i have to return this game.

Share this post


Link to post
Share on other sites

This is my white whale.  I can't stop trying to figure this out.  I'm sure it's a part of the build process and the devs will figure it out but all the same.

The latest thing i've tried is deleting the \\%userfolder%\AppData\Local\UnrealEngine directory and reinstalling.  Still no change.  I'll see what's on nvidia's support page as well.

 

cheers!

Share this post


Link to post
Share on other sites

Found and downloaded MSI Afterburner.  made appropriate changes as mentioned above.  No effect.  Had family members with similar hardware purchase the game and run it.  Dang it! they love it!  aaannndd i'm still dead in the water (go figure).  I'll keep looking for a set of drivers which may work or a hardware fix somewhere.

Share this post


Link to post
Share on other sites

So I up and completely uninstalled all nvidia drivers in a fit of mad rage.  Nuke it from orbit... it's the only way to be sure.  And guess what.  I was able to load the application just using the default intel drivers.  I'm sure my performance is severely hampered.  However HA! i can play it!!!!  I'll try to get simple drivers and find out exactly what broke.  Like others have reported, there is most likely something with recent drivers that it doesn't like.

 

cheers!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now