Mindstormer

[Merged] FPS Drop Reports

Recommended Posts

Hello System Era devs, thanks for this amazing and awesome game!

My game has several major performance & playability bugs; primarily in certain areas (areas with resources, base items, etc.) I get extremely low framerates. Often, this will lead to a complete game freeze as well as audio clipping. Attempting to raise the game client's process cpu priority to high or realtime has assisted slightly, but the problem still persists.

Another common bug I've noticed is that upon entering the game from a save file, the items/resources in the backpack float a reasonable distance away from the sockets in the backpack (still attached mind you), but they exist floating off the back of the astroneer.

Thank you.

Here is my DxDiag text:

DxDiag.txt

Share this post


Link to post
Share on other sites

I'm getting these issues as well. Game literally becomes unplayable when walking into high resource areas, and walking away from them does not seem to help. I also have the backpack bug where loading up my save has my items floating above my backpack instead of being "attached" to the sockets, though to be clear the items are attached in their slots, but do not appear physically to be attached, as they are floating above the socket they are sitting in.

 

My system:

Windows 10 Pro

FX-6300 @ 3.5GHz

GTX 1080

32GB RAM

 

I should easily be able to play this game, but it is literally unplayable when walking near densely populated resource veins. I think this is related to AMD processors, since I saw on the Steam forums for this game other users are complaining about the game being unplayable on their FX-8350, and other FX processors, but people with i5s and i7s are having no issues.

 

Attaching my DxDiag as well:

DxDiag.txt

 

Edit: I can't access Mindstormer's DxDiag, and s/he didn't mention if they also have an AMD processor, so I can't confirm, but this is what I suspect.

Edited by Hotrian
Clarity.

Share this post


Link to post
Share on other sites

I updated to the latest NVidia Drivers and fully updated my Windows 10, as well as updating the game. Updating the game made performance worse for me. Updating NVidia drivers from 375 to 376 definitely increased performance! Lag went from being large hangs where the game would lag as long as 30 seconds before playing a few frames and going back to lagging, to hanging for about one to two seconds. Serious improvement! Updating my Windows to the latest version actually made performance slight worse, lag now happens whenever I'm moving around, but I can still enter caves now which is a huge plus.

 

Edit: Attached is my new DxDiag in case it helps. Still lots of lagging but it's definitely better. More often but in shorter bursts.

DxDiag.txt

Edited by Hotrian
Attached DxDiag

Share this post


Link to post
Share on other sites

Hello,

I have big FPS drops in any resolution. 

Graphic Drivers updated 376.33.

I love this game SO much. Please I wish to play Astroneer in comfort.

 

Thank you System Era for this amazing game. Can't wait when you guys release Astroneer.

DxDiag.txt

Share this post


Link to post
Share on other sites

Hotrian, I do indeed have an AMD processor. I didn't realize the DxDiag wasn't visible to other users. I'll post my specs here:

Windows 10 Home 64-bit

AMD FX-8320 @ 4.01GHz

8GB G.Skill Ram

Asus Sabertooth 990fx R2.0

Nvidia GeForce GTX 780 (Driver Version: 376.33)

With the latest patch, updated drivers, and elevated game process priority I DO get improved frames and less freezes... but alas the game still hangs for 3 or 4 seconds at 9-15 second intervals.

Edited by Mindstormer

Share this post


Link to post
Share on other sites

Guys, can you try launching the game with the "-nosound" flag? This almost completely fixed my lag. Tiny tiny stutters now, totally playable where as before it would lag horribly every time I moved even a little bit (in some areas, but not all, in some areas I could move fine without lag).

  1. Right Click the game in your Steam Library
  2. Click properties
  3. Navigate to General Tab (should be selected by default)
  4. Click "Set Launch Options..."
  5. Type in "-nosound" without quotes
  6. Click "Okay"
  7. Click "Close" on Properties Window
  8. Launch Game
  9. Profit?

Share this post


Link to post
Share on other sites

For some reason it won't let me edit my last post, so sorry for the double post:

So for me at least, it turns out this is because I use a program called Breakaway Audio Enhancer! I have no idea why, and I've never had any issues with any other game. Breakaway is using 1% CPU so it's not having any issues itself, but for some reason Astroneer does NOT want to pipe audio through Breakaway. When I close and disable Breakaway, and disable all audio devices except my Optical Out I can use sound again and no lag!

 

Any chance you guys are using some type of sound equalizer or processor? Try disabling all audio devices except the one you are using, and all audio equalizers if you have any such software installed.

Edited by Hotrian
Accidentally a word.

Share this post


Link to post
Share on other sites

Ran into massive FPS issues and audio playback glitching on first launch of game, this coming after installing prior to the patch that should have fixed the issues. When attempting to walk, FPS drops from approximately 60 to less than 5, even hanging for several seconds. Audio is stuttery and static the entire time, and game jumps to roughly 70% CPU usage when walking.

Using GTX 960 FTW card with 2GB video memory and AMD FX-4100 Quad-core CPU

OS Name:                   Microsoft Windows 10 Pro
OS Version:                10.0.14393 N/A Build 14393
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Standalone Workstation
OS Build Type:             Multiprocessor Free

System Manufacturer:       Gigabyte Technology Co., Ltd.
System Model:              GA-990XA-UD3
System Type:               x64-based PC
Processor(s):              1 Processor(s) Installed.
                           [01]: AMD64 Family 21 Model 1 Stepping 2 AuthenticAMD ~3600 Mhz
BIOS Version:              Award Software International, Inc. F13, 10/26/2012

Total Physical Memory:     16,365 MB
Available Physical Memory: 11,558 MB
Virtual Memory: Max Size:  18,797 MB
Virtual Memory: Available: 12,805 MB
Virtual Memory: In Use:    5,992 MB

Share this post


Link to post
Share on other sites

Hi, have you tried adding "-NOSOUND" without the quotes in the Steam parameters ? This will disable the sound but if your FPS are good after that it'll probably help the devs to add your case to the list. Also if you have a different sound card, try using it.

DxDiag.txt

Share this post


Link to post
Share on other sites
7 hours ago, Deodus said:

Hi, have you tried adding "-NOSOUND" without the quotes in the Steam parameters ? This will disable the sound but if your FPS are good after that it'll probably help the devs to add your case to the list. Also if you have a different sound card, try using it.

DxDiag.txt

I tried launching with -NOSOUND, the game runs smoother, but still experiences lagging during movement and crashes after about two minutes.

Share this post


Link to post
Share on other sites

Yep, same story here. Resetting entire PC, updating drivers and adding -NOSOUND barely did anything, it added like 5 fps but i still crashed within less than a minute.

Share this post


Link to post
Share on other sites

game has become unplayable after and hour on xbox one heavy fps drop and screen freezing restarted xbox incase this was problem but continues ... not happening to other games on xbox one ! please get a hotfix i would love to actually play the game considering i payed for the pre alpha

Share this post


Link to post
Share on other sites

Was working OK until the latest PC patch.  Was previously 60 - 100 FPS now running between 10 - 20 FPS with occasional drops below 10 FPS.  Updated to the latest nVidia drivers and rebooted - no change. Using the -nosound launch option does not impact the FPS in this case.  GPUs are under 50% utilisation (running 2 x 980TI in SLI configuration).  Happy to provide additional information if needed.

Share this post


Link to post
Share on other sites

Disabling sound helped a little bit, but the primary issue is still present. I have better framerate overall and it catches/freezes less often, but it still happens. Thanks for the tip Hotrian.

Share this post


Link to post
Share on other sites

Windows 10, 64-bit

Asus ROG G751

Intel Core i7-4710HQ CPU @ 2.5 (8 CPUs)

RAM: 16 GB

NVIDIA GTX 970M

Hard drive: SSD 250, SATA 1TB

 

No crashes, but very low FPS during the game.

Please fix this, this game is AWESOME! :) 

 

DxDiag.txt

Share this post


Link to post
Share on other sites

Built some stuff around my base now whenever I'm walking or looking around the frame rate drops very low and I definitely can't drive the rover as the screen will freeze and go by like a slideshow 

Edited by Wyvyrias
Adjusted title after merge

Share this post


Link to post
Share on other sites

I am also experiencing very low FPS on Xbox One, to the point the game crashes, it would appear the more assets i.e. Tethers and base modules I add the more the game will struggle to process this. Just recently tried building a truck which for me is a game killer due to low FPS.

 

Low FPS on Xbox One.mp4

Share this post


Link to post
Share on other sites

Any time I use a vehicle around tethers it drops the frame rate. Keeping it away from the tethers helps that problem. You may have to delete the tether clsest to it then replace it once the vehicle is further away.

Share this post


Link to post
Share on other sites

yes, vehicles cause 0.1 fps on xbox one.

i move away my sapcecar in 0.1fps :D its funny and not. so when you move away. the fps comes back to 10-18fps....maximum

please fix this CRITICAL gamebreaking issue before everything...

Share this post


Link to post
Share on other sites

Is there any reason other than poor optimization due to the game being early access that I would be getting less than 10fps on average. Is there anything that you've done to try to mitigate frame lag?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now