Bender42

Petition: XB1 Frame Rate

Recommended Posts

I know that frame rate drops are a big problem in both versions of the game but it is so much worse on XB1 that its pretty much unplayable. Its perfectly fine when you start a new save, runs great, looks great, no problems and surprisingly few bugs. But the more you play the faster it drops. The game is so much fun though that i suffered through playing it at 10-15 fps levels just because i loved exploring so much. 

After a few fresh games i noticed that the FPS plummetted much faster in saves where I did more complex and extensive terrain manipulation. For instance, its been well established that tethers have a cumulative impact on performance, so on a world that had an extensive tunnel system, I did almost no building and just explored as far as I could underground, and though after about an hour of getting as far as I could laying tethers along the way and only harvesting compound for tethers and Oxygen to explore ahead, i only got a few 2-3 minute periods of 20 fps when I would enter a new level of the cave system and it went back to normal. By this point I was so far ahead that I didnt really know how to get back.

Eventually however, the tether linkage bug cropped up. I knew at this point that it would, but i had placed more than 100 tethers without it happening, when I usually cant make it even 30 without the line breaking, so I wasnt ready for it. (I placed the tethers close together, on the ground, without the terrain bisecting their connection lines or putting them on the roof or doing anything fun with them, I think thats why they went so long without breaking) Anyway, i got worried i wouldnt find the break point, so I just started making a ramp to get back to the surface from about 3 levels down.

After about 5 minutes of making a meandering tunnel through the ground, then switching to a ramp, then back, my fps began to PLUMMIT. The more terrain modding I did, the more it screwed up.  I had plenty of stored O2 and Power (my whole pack pretty much), so I went back down and used the smooth tool to try and straighten it out, I thought getting rid of some high complexity, high poly surface area might make things work better.

It didnt. I started from the bottom, using the smooth tool to make a shear ramp straight to the top, making sure to eliminate all of the complex tunnel geometry I had made so far, and by the time i got there, it was running below 10fps consistently. I had no buildings but the starting habitat with one extention that had 2 solar generators connected to it to power my tether, and two solars on my backpack, plus the 90-120 some tether line that I left along my path. I did this pretty much entirely to test the performance of the game and to provide feedback.

Additionally, in games where ive done alot of building, but used the terrain tool just for mining, using established caves ONLY, it lasted much longer before the frame rate dropped, stablizing at a semi playable 20-25 fps with sub 10 drops that would last about 30 seconds, once I built a rover or a truck, it would loose about 5 fps immediately and then degrade more as I drove the damn thing (PS I love the way you peice the buildings and vehicles together, but the collision detection is completely broken on rovers, and the HALO-esque control sceme is either completely non functional or the rovers arent connected to the physics system right).

I just played a game where I did just mining, no terrain modding for pathway or play,  no rover or truck AT ALL, extensive base building (lots of nodes for printed objects, a printer, researcher, and vehicle bay just for spacecraft) on a flat plane so not much auto terrain modding, and it was playable at around 30 FPS untill I got greedy and built a spaceship to head to the planets moon. Big mistake, it dropped to below 10 fps, like it loaded the moon but didnt garbage collect the planet at all.

That is pretty much all the feedback I can give you on how it performs on Xbox1, now please make the frame rate your top priority for the next patch and please make an XB1 patch something to expect in the near future. This game is wonderful, even without any new buildings or game mechanics its incredibly fun, and with the additions you might be working on i an imagine it being so much more. On pc there are other games like Space Engineers and so on, but on console this game is COMPLETELY UNIQUE! For someone wanting an infinite exploration and creation experience like Minecraft or NO MAN'S SKY, this is your only decent option and it has so much potential that it could easily become what NMS should have been.

So dont worry about any new buildings, features or game mechanics for PC, YOU HAVE FANS ON XBOX EVEN IN ITS CURRENT UNPLAYABLE STATE AND WE NEED 30FPS!

Any other XB1 players, please put a statement of support in this thread to let the Developers know they have XB1 players who love the game so much they play it at 10 FPS, but really deserve a proper frame rate. 

Share this post


Link to post
Share on other sites

I play on PC but we have frame rate issues, as well.  So I'm here to support this thread!  Because if they can fix frame rate issue on one platform it can be ported to the other.  So if they fix it on Xbox it will be fixed on PC and vise versa! 

Share this post


Link to post
Share on other sites

I currently have ceased to play as long as the frame rate will not be repaired. oglio not ruin the game. At present it is unplayable hope that the patches are very fast.

Share this post


Link to post
Share on other sites

Hey guys !

 

Got the same issuses as mentionend in the post on top. I do play it on PC , got a good working average system. I don't need max. high res. or blur . I just want a smooth and chilled gameplay. Would be aweseome if Systemera could fix that out ..

I also tried the config.ini change and so on. I had some FPS more, but not that much - sadly.

Im not worried at all, of coz its sad. But its the pre alpha, game runs like a week ... We should give them the chance.

Thanks for everything until yet, you doing great Systemera !

 

Share this post


Link to post
Share on other sites

I think the developers are well aware of these problems. With the first patch the thing has improved significantly. So this is probably synonymous with the next updates so be. Always remember that it is a Pre Alpha. We are all testers and can not expect a perfect game yet. Of course, the Framerate has great priority, as the testing is not fun.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now