Stickdude247

Have to press keys multiple times to register.

Recommended Posts

On keyboard and mouse on steam, I have to press (most notably) e and q several times before the game registers me pressing the button and opening my terrain tool or backpack respectively. It has gotten bad enough that I don't play this game anymore. Please fix because this is still one of my favorite games. The bug is just really annoying.

Share this post


Link to post
Share on other sites

I've had the same behavior since January. I noticed it's Q, E, TAB, and SPACE that are take multiple hits to register. WASD and the mouse clicks register immediately without fail. 

Share this post


Link to post
Share on other sites

I've had the same problem myself and posted about it on Jan 19 in this forum.  Issue persists with 122 and 123 patches.  Trying an external keyboard didn't mitigate the issue, so unless it's a subtle keyboard interface bug in my software stack (Win10) that only shows up with Astroneer (because this issue doesn't exist with anything else on my system) the issue seems to be with Astroneer.

I also haven't seen anything from developers acknowledging this issue, though I haven't exhaustively searched all threads reporting it and could be wrong there.  Hope they know about it and fix it soon, because it's quite annoying at times to have to hit Tab 6-10 times or more to enter/exit a vehicle.

 

Share this post


Link to post
Share on other sites
On 2/13/2017 at 7:08 PM, derpsters44 said:

this may be your keyboard, do you normally have issues like this

This happens with multiple different keyboards as well as the laptop built-in keyboard. My keyboard works normally in other games and applications. It even used to work normally in Astroneer, but it stopped working well at some stage. 

I have tried uninstalling Astronner and deleting all of the saves. I started fresh, and it still takes 3 to 6 tries hitting TAB to exit a vehicle or Q to open/close the backpack. Same with E and SPACE. 

Share this post


Link to post
Share on other sites
On 2/13/2017 at 7:08 PM, derpsters44 said:

this may be your keyboard, do you normally have issues like this

Sorry for the late reply, but my keyboard works completely fine 100% of the time aside from this. Shift+Tab works first try and typing messages works normally. It's only in game that this problem occurs.

Share this post


Link to post
Share on other sites

A patch went out in last day or so which leaves patchlevel at 125 but keyboard issue has disappeared, for me at least.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now