SES_Adam

Feb. 9 - EXPERIMENTAL build updated, HELP NEEDED!

Recommended Posts

Bugs I've noticed have been reported, but maybe knowing they're not isolated events might help.

Wind turbine not producing energy when slotted, but spins and has the lights indicating it will produce power when it is placed on the ground by itself.

A stack of resin I was picking up and dropping to carry back to the homestead seemingly vanished, only to reappear later when gathering organic material.  Possibly fell through the surface?

Partially used stack of power not getting used up when in any vehicle, storage, or backpack slot.  (Only one stack seemed to have this issue.)  Also walked toward a partial power stack that was floating, only for it to realize I had seen it misbehaving and fell back to the surface.

I haven't yet checked to see if any of my settings reset, but the game is loading visuals slowly.  Not sure if it's a hardware issue.  Will try to remember to give it a look next time I play.  It wouldn't load flora until I was either standing on it or very close.  Driving in vehicles past areas I had created a hole collecting resources would appear to be untapped, only to be the hole I created previously when driving back the other way. 

This game is a blast, and I can get lost in it for hours at a time.  Keep up the good work!

 

Share this post


Link to post
Share on other sites
On 2/9/2017 at 4:30 PM, SES_Adam said:

Hello!

We just pushed "122" to the EXPERIMENTAL build of the game on Steam. This update contains some fixes and updates that we'd like to do some testing with before we officially role it out to the main Steam, Win 10, and Xbox One versions.

 

If you want to play and help us test things out - thank you!

There's a few things you need to understand first:

  • This is part of the EXPERIMENTAL build on Steam and is not at all compatible with your previous save games. When its pushed to the MAIN build of Astroneer the goal is for your save games to be compatible. But for now, you'll need to start fresh.
    • How do you join the EXPERIMENTAL build? In your Steam library:
      • Right Click on Astroneer
      • Properties
      • Betas tab
      • From the drop down select, "experimental - Latest untested builds"
      • Hit 'Close'
      • Steam should automatically grab that build. Once it's done, run the game. You're now running the Experimental build of Astroneer.
      • When you want to go back to the MAIN build, repeat these steps but choose "NONE" from the drop down list in 'Betas' tab.
  • We need your help testing bugs NOT from the main branch: I.E.: Report issues only relevant to the below update notes. Do not post bugs of things already happening in the main build!
    • Post your bugs as a reply to this post.
    • Any reply that is NOT a bug report will be removed by the moderators.
  • This is Experimental, expect things to break and be buggy.
  • Save Games are incompatible with Main build saves.

 

What's added to the EXPERIMENTAL build:

  • Step 1 of our sweeping performance update. Flora, grass, and small vegetation now optimized to load/offload more intelligently.
  • Dynamite is in and can destroy terrain and things under them. E.g. Place them on top of a rover (Don't snap them together) and activate the Dynamite. Boom, no more rover.
  • Updated art and effects: Drop ship, Smelter, Trade Module
  • Updated launch sequence + effects.
  • New research items to discover, tweaks to Research gameplay
  • New wrecks to discover.
  • New idle animations

 

If you see any bugs pertaining to this update, please reply to this post with those issues. Any reply that is NOT a bug report will be removed by the moderators. Make sure you include system specs and steps to reproduce!

Does this mean wer loose our old saves ? You say we have to start from scratch ?

Share this post


Link to post
Share on other sites

This was a great exercise.  Thanks for letting us take part.

One last comment before it is closed down.  Not so much a bug, but a system problem.  

I understand the idea of reducing the render range to help reduce lag and there is no problems with that as far as vegetation and relics are concerned (although, in a vehicle it is quite easy to scoot by a relic without seeing it if it is not right in your pathway).   But holes in the ground, like ravines, canyons and cave entrances are a whole new kettle of fish.  With the short rendering range it is far to easy to drive straight into a hole while driving either of the vehicles.  If it is not possible to extend the render range for holes in the terrain separate from other surface items, then maybe the solution is to slow down the speed at which the vehicles travel (or better still, give them a couple of selectable speeds).

 

Cheers and thanks for an awesome game.

Share this post


Link to post
Share on other sites

Game freeze and eventual crash in process of collecting compound.

Steam client version. Windows 10 latest updates, i5 2.2 GHz, 8 MB RAM, Intel HD Graphics Integrated 5500 with 256 MB onboard running game at 720p.

Attached log file. For some reason, the dates in log are not correct (one day off; 12th instead of 13th).

Astro-backup-2017.02.13-16.41.16.log

Share this post


Link to post
Share on other sites

Ok one bug found. when i fill up one side of the storage object and enter the vehicle you can clearly see, that the 4th slot empties itself when i returned to my base, a 2nd nugget was missing too.

 

 

Edited by Ljorius

Share this post


Link to post
Share on other sites

a little tricky to re-create, but you can "run" on a rover (maybe also the truck) and push it forward and it doens't need any power

Spoiler

 

giphy.gif.983d274a880630ee68a47f086b6e4b23.gif

 

Edited by SuperVK

Share this post


Link to post
Share on other sites

And last:

1. Need a handbrake for Vehicles. If i am outside the Truck stand like a Rock (in Storm too), but in or at the crane it sliding even at flat Terrain! Using crane at slope is nearly impossible.

2. A (larger?) collision Box for Vehicles! If i brake the Trailer always glich into the Truck.

Edited by Feuerwalze

Share this post


Link to post
Share on other sites

 

Summary:

Disappearing or random driving truck

Description: 

Truck and cart disappeared while i was off messing about when i got out and it poofed out of existence. I was able to run back to my base without dying and proceeded to make another truck to drive in. after i got in it would start driving (with or without battery charge) in reverse on it's own accord, bounce around and then shoot into air..

Platform:

Steam

Version / Build Number: 

Experimental 123

Specifications:

20170213211241_1.jpg

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.