SUPERGOVERNMENT

Unable to set Astroneer to use dedicated graphics card. Windows 10.

Recommended Posts

Hey There,

With Windows 10, you are unable to set Astroneer to use a dedicated graphics card. You should be able to add a program exception to your video driver software like NVidia control panel or AMD Catalyst, but you cannot do this since the executable for Astroneer is encrypted in the windows apps on your PC. When you try to select the Astroneer executable for a custom profile, you receive an error that you don't have permission to open this file. This is because the file is encrypted. Without the ability to assign the video card within Astroneer, you cannot effectively assign the correct video card. See attached screenshot. This is extremely frustrating. We need the ability to assign the graphics card from within Astroneer, so I don't have to play using integrated graphics. :( 

EDIT: I have tried taking ownership of the file and giving myself full permission, but is still a no go. Again, due to encryption. 

Capture.JPG

Edited by SUPERGOVERNMENT
Performed additional test.

Share this post


Link to post
Share on other sites
1 hour ago, SUPERGOVERNMENT said:

We need the ability to assign the graphics card from within Astroneer, so I don't have to play using integrated graphics. :( 

What do you mean "assign the graphics card"?  So you already have whatever model of Radeon card installed, yes?  If so, why would your computer still be using the integrated graphics for anything at all?  If your card is not yet installed, when you plug it into the PCIe slot and update the drivers it should override the integrated graphics.

Share this post


Link to post
Share on other sites

Thanks for the reply. Yes, I have all of the drivers installed, however Windows insists on using the integrated graphics. It is a known issue with Windows 10 and mobility graphics card. The solution has been to manually assign the program to use the desired video card via the video card application like Catalyst or NVidia control panel. This does not work for UWP apps because of they way they are built. 

Share this post


Link to post
Share on other sites

I found my own solution. I navigated to the Astro executable in the above screenshot. Right-click on the executable>Send To>Desktop (Create shortcut.) I then went back into Catalyst control center, and added a High Performance profile, and selected the shortcut I created instead of the executable itself. Astroneer is now using my video card. Hope this helps some of you!.

Share this post


Link to post
Share on other sites
10 hours ago, SUPERGOVERNMENT said:

I found my own solution. I navigated to the Astro executable in the above screenshot. Right-click on the executable>Send To>Desktop (Create shortcut.) I then went back into Catalyst control center, and added a High Performance profile, and selected the shortcut I created instead of the executable itself. Astroneer is now using my video card. Hope this helps some of you!.

Yep.

However, I would suggest just going into bios and disabling onboard gpu/integrated graphics.  This way your video card will always be the default.  There's been some issues with laptops and notebooks not selecting the video card and using onboard only.  Could be a symptom of the setup.  Or astroneers file location.

In time I expect they'll move the files to steam like most other steam games.

Share this post


Link to post
Share on other sites
On ‎2‎/‎3‎/‎2017 at 6:42 PM, Martin said:

Yep.

However, I would suggest just going into bios and disabling onboard gpu/integrated graphics.  This way your video card will always be the default.  There's been some issues with laptops and notebooks not selecting the video card and using onboard only.  Could be a symptom of the setup.  Or astroneers file location.

In time I expect they'll move the files to steam like most other steam games.

The OP mentioned in the first post that this is a Win10 game, meaning it was purchased through the MS Store. It doesn't store games and apps in the same way Steam does, and I doubt Microsoft will suddenly move their Store infrastructure to Steam.

Share this post


Link to post
Share on other sites
1 hour ago, LameLefty said:

The OP mentioned in the first post that this is a Win10 game, meaning it was purchased through the MS Store. It doesn't store games and apps in the same way Steam does, and I doubt Microsoft will suddenly move their Store infrastructure to Steam.

Then they'll probably move it to a move obvious public location, like 90% of all other non steam games, ie either directly to a drive or under c:\programs file (x86) games are usually in obvious places, not hidden under appdata.

And it isn't really microsoft store that decides where stuff installs unless not specified by devs.  Even so it's kinda rare to see them hidden away.

But neither really matters my main point was to disable onboard via bios and it doesn't matter where a game is located for that.

Edited by Martin

Share this post


Link to post
Share on other sites
29 minutes ago, Martin said:

Then they'll probably move it to a move obvious public location, like 90% of all other non steam games, ie either directly to a drive or under c:\programs file (x86) games are usually in obvious places, not hidden under appdata.

And it isn't really microsoft store that decides where stuff installs unless not specified by devs.  Even so it's kinda rare to see them hidden away.

But neither really matters my main point was to disable onboard via bios and it doesn't matter where a game is located for that.

You don't get software from the Store in Win10 do you? It's all stored in the same, weird way regardless of publisher.

That said, disabling hardware components via a BIOS setting is ridiculous; people shouldn't have to reboot in order to change something that basic. On the other hand, it may be an AMD thing. I have an Nvidia card in my systems and the game has no problem using the dedicated GPU instead of the integrated one.

Edited by LameLefty

Share this post


Link to post
Share on other sites

No I don't use windows store.. too expensive.  That's like buying stuff from Harods.

It isn't because it's amd or nvidia, it usually depends on the manufacturer.. some are cheapskates.. other's make very high quality.  The cheapskates often don't get picked up correctly on connection and onboard tries to override it, you shouldn't need to force disable something, but it's often the quickest and simplest solution.

Share this post


Link to post
Share on other sites
3 hours ago, Martin said:

No I don't use windows store.. too expensive.  That's like buying stuff from Harods.

Everything I've seen is the same price, whether Steam, Windows Store, GOG, etc. aside from periodic sales. Astroneer was certainly the same price.

Share this post


Link to post
Share on other sites

Yeh astroneer is ea tho, but all aaa titles are anything from 40-80£ most of the "more" renowned markets, tend to sell at max price with no sales.. I use the little shops in tax havens etc.. much cheaper.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now