Can't Set Resolution - Partial Fix!


Recommended Posts

I found the cause of the issue where Astroneer can't set or save the proper resolution (but keeps defaulting to 720p only).  It has to do with Windows Font Scaling/Sizing.  If don't use 100% then you can't set the resolution in Astroneer.    The problem is my 4k TV, when font scaling set to 100% is so microscopic you can't read it on the screen (I was at 300% so I could read it), but it does not permit Astroneer to set the appropriate resolution.  So to fix it you can either a) live with 100% font scaling using 4k resolution with super-tiny text, or b) set your native resolution to 1080p (1920 x 1080) with 100% scaling (you won't get 4K images), and either one these works until System Era can get this work apart from the font scaling issue.


Link to post
Share on other sites

I found an even better solution as well, just now, ... this applies to Steam/ Windows 10, as above. 

This solution allows you to run Astroneer in any resolution up to 4k (and save it!) if your equipment allows it, AND it allows your Windows desktop to run at 4K (I run mine at 3840 x 2160).

And you can keep your windows scaling high (mine's at 225%).

Just modify your Steam Shortcut (right click - properties), push Compatibility, Click on "Disable display scaling on high DPI settings".  I use Big Picture mode.

This way you won't have to run Windows in only 1080p mode (1920 x 1080) mode as above @ 100% font scaling, though that method works too (see topic above).

This method works for other games too, with same problem, though Astroneer is the only one I've found with this scaling problem (Windows font scaling causes Astroneer to not be able to set its resolution properly.)

Steam / Windows 10 / GTX 1070

Link to post
Share on other sites

It does fix it, however, my FPS went from 30 to 12, so, for those that don't have the specs for it, don't do it. 

i5 6500 with integrated HD 530 graphics for reference, ima stick to my 30 fps game lol

Link to post
Share on other sites

Still experimenting with these settings.   Seems the 100% or no-font-scale while setting your native windows resolution to 1920 x 1080 works best.  Then run Astroneer at 1920 x 1080.  Seems some games just don't run well with any font scaling -- had an issue today with Battlefield one while using windows font scaling.   So i'm back to this idea -- setting native resolution to 1920 x 1080 for windows and font scaling to 100% (no scaling).

Link to post
Share on other sites

Still perfecting.   All these fixes work as above.   This solution is pretty good too:  Set windows (and/or nvidia control panel/amd) to default to 1080p (=1920 x 1080 res) with standard 100% font scaling = no percentage change to font sizing / scaling, then you can just run Astroneer as normal is 1080p mode, which works great, OR you can even change it from there to say 3840 x 2160 if you have  4k tv.   So far this is the best approach.   You won't need "override DPI scaling option" at the shortcut level.   The overall idea is what kills Astroneer resolution is using any windows font scaling.   I've found font scaling causes and issue for BF1 too.   So just don't use it -- keep it at the default value of 100%.  

Link to post
Share on other sites

The reason for this whole wrong behavior is that the game is using the fullscreen windowed mode and not the real fullscreen mode that exists in the Unreal Engine.
It can be changed and doing so will gain quite a bunch in performance (for me around 20% on a laptop), but... The user settings are quite messed up in this game. By that I mean that the file is overwritten with default settings each time we open the options screen in the game (it's also why the sound settings for instance are not remembered, or the view distance).

One way to do that on Windows is by editing the file C:\Users\<NAME>\AppData\Local\Astro\Saved\Config\WindowsNoEditor\GameUserSettings.ini

And locate the key "FullscreenMode". It's by default set to 1 and you should set it to 0.
The different values are:
0 sets the game to true fullscreen.
1 sets the game to windowed fullscreen.
2 sets the game to windowed mode.

Then you can change your resolution in the same file . Easy enough, you can find those 2 lines:
ResolutionSizeX=1920
ResolutionSizeY=1080

Then save and don't forget: Don't open the options screen in the game or the game will instantly go back to the main Windows resolution and reset the file.

There a lot of other graphic improvement settings that can be done via other files (that won't get erased). I already posted a few. I was able to go from 5 fps to 30-35 fps on my non gaming laptop. I might make a new more complete post about that in a few days or so.

Edited by guiohm
Link to post
Share on other sites
  • 2 years later...

Bumping topic as this is still an issue. Changing fullscreen mode to 0 works but then the cursor is so small I can't see it so really need this implemented correctly with a cursor that scales with UI resolution. Trying to run this at 4k with 100% scaling to make it work "properly" is just not practical with anything less than a 60" television. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

×   Your link has been automatically embedded.   Display as a link instead