Search the Community

Showing results for tags 'bad save system'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Astroneer Forum
    • Announcements
    • Patch Notes
    • General Discussion
    • Suggestions and Ideas
    • Support
  • System Era
    • Announcements
    • General Discussion

Calendars

  • Community Calendar
  • Astroneer Livestream Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 1 result

  1. Have laid back on Astroneer as it seems pretty buggy... but gave it another go. So - just lost YET ANOTHER Rover - insta-evaporate in a cave. Got out to get some POWER and looked around and no Rover in sight! This is the 3rd vehicle I've lost this way. Also the crazy 'jumping vehicle" but is still around... At least I HOPE it is a bug and not a feature. A big PITA to get out of your vehicle and have it do insane flopping and jumping for no good reason. A wonderful game - just not really ready for any serious play - far to easy to loose hours of work thru no error or mistake. The Save System is a bummer as well. There appears to be only ONE current save - and if you restore a game from a week ago - too bad - your current game is now that week old game - No going back! Sorry hard-core Dayz-vets - This pseudo-permadeath is NOT fun. Think it is time to wait for a few releases to go by and see if the game gets a bit more forgiving... even as a pre-release Alfa this is pretty unstable.