Echoplex

Members
  • Content count

    5
  • Joined

  • Last visited

About Echoplex

  • Rank
    Newbie
  1. Echoplex

    Terms Of Service question

    No worries, right on. Thank you!
  2. I couldn't seem to find anything for Terms of Service, I have question. If I want to do a podcast with some friends, while we play video games, is it within your TOS that I am legally able to display the game while we do our podcast? It is not reviewing the game, nor bashing it or anything really about the game outside of conversational pieces, but just general random topics of our choosing, while playing and showing Astroneer. Thank you for your time.
  3. Had three buggies, 2 were attached with 1 person seat, second one by itself with a winch. When I went into space and landed on another planet, I returned to my home starting location and the buggies were all three gone. I did notice when orbiting that some objects were in space flying no where near any planets that had the same icons on them as my vehicles. Console is Xbox One
  4. Had three buggies, 2 were attached with 1 person seat, second one by itself with a winch. When I went into space and landed on another planet, I returned to my home starting location and the buggies were all three gone. I did notice when orbiting that some objects were in space flying no where near any planets that had the same icons on them as my vehicles. Console is Xbox One
  5. A few hours into the game. I have a researcher, printer, smelter and vehicle maker. A storage unit and several solar panels all in close proximity. All inside a sculpted crater. I created a buggy but when driving it after about 5 seconds the frame rate drops down so low it almost can't move, a frame every two seconds or so. I've reset my game a dozen times and issues continues, reset the console as well. Only experiencing when in a vehicle. Console is xbox one.